summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRui Ventura2019-11-02 22:07:49 +0000
committerRui Ventura2019-11-02 22:07:49 +0000
commitc1004f7503ace67b7509090e7c51335a121d00a2 (patch)
treeb84af00a0dfcaeff97ca394ed6be860ce8190ed2
parent54ef28f68f521ee86ec21af41769bdbe1eba8741 (diff)
downloadaur-c1004f7503ace67b7509090e7c51335a121d00a2.tar.gz
Update to 1.1.0
PKGBUILD changes: + Make a few deps explicit * Remove quotes from simple strings * Tweak building phase, adapt install accordingly + Build for release + Build in 'build' sub-directory - Leave tarball name alone
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13a286b7162e..e2dca74dfc5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = chiaki
pkgdesc = Free and Open Source PS4 Remote Play Client
- pkgver = 1.0.4
- pkgrel = 2
+ pkgver = 1.1.0
+ pkgrel = 1
url = https://github.com/thestr4ng3r/chiaki
arch = x86_64
license = GPL
makedepends = cmake
makedepends = protobuf
makedepends = python-protobuf
+ depends = ffmpeg
+ depends = gcc-libs
depends = qt5-multimedia
depends = qt5-svg
- depends = ffmpeg
- depends = libopusenc
+ depends = opus
depends = openssl>=1.1
+ depends = sdl2
provides = chiaki
- source = chiaki.tar.gz::https://github.com/thestr4ng3r/chiaki/releases/download/v1.0.4/chiaki-v1.0.4-src.tar.gz
- sha256sums = 92f45d6acf87d6340ed7af577e43cf8acabd03b963ea942343e57932379ee1ab
+ source = https://github.com/thestr4ng3r/chiaki/releases/download/v1.1.0/chiaki-v1.1.0-src.tar.gz
+ sha256sums = ae434eb8da9f15e6ba68b38812ade9a9f22a86a2119111f18dad636bac540180
pkgname = chiaki
diff --git a/PKGBUILD b/PKGBUILD
index fcf7ef7c420c..af4910ad8c62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Rui Ventura <rventura.pt@outlook.com>
pkgname=chiaki
-pkgver=1.0.4
-pkgrel=2
-pkgdesc='Free and Open Source PS4 Remote Play Client'
-arch=('x86_64')
-url='https://github.com/thestr4ng3r/chiaki'
-license=('GPL')
-provides=('chiaki')
-depends=('qt5-multimedia' 'qt5-svg' 'ffmpeg' 'libopusenc' 'openssl>=1.1')
-makedepends=('cmake' 'protobuf' 'python-protobuf')
-source=("$pkgname.tar.gz::$url/releases/download/v$pkgver/$pkgname-v$pkgver-src.tar.gz")
-sha256sums=('92f45d6acf87d6340ed7af577e43cf8acabd03b963ea942343e57932379ee1ab')
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Free and Open Source PS4 Remote Play Client"
+arch=(x86_64)
+url=https://github.com/thestr4ng3r/chiaki
+license=(GPL)
+provides=(chiaki)
+depends=(ffmpeg gcc-libs qt5-multimedia qt5-svg opus "openssl>=1.1" sdl2)
+makedepends=(cmake protobuf python-protobuf)
+source=("$url/releases/download/v$pkgver/$pkgname-v$pkgver-src.tar.gz")
+sha256sums=(ae434eb8da9f15e6ba68b38812ade9a9f22a86a2119111f18dad636bac540180)
build() {
cd "$srcdir/$pkgname"
- cmake . -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake -B build -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname/build"
make DESTDIR="$pkgdir" install
}