summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMd Jahidul Hamid2019-10-05 14:29:47 +0600
committerMd Jahidul Hamid2019-10-05 14:29:47 +0600
commitd96f9ae84fd0e6bb1c53cbb09772739ec13f9331 (patch)
treea14bc0dc1e3fff944dc7260fba958431279ecce9
downloadaur-d96f9ae84fd0e6bb1c53cbb09772739ec13f9331.tar.gz
initial release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de10ba97c566
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = chibu
+ pkgdesc = Create Hybrid ISO Bootable USB
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/neurobin/chibu
+ arch = any
+ license = BSD
+ depends = python
+ depends = systemd
+ depends = syslinux
+ source = https://github.com/neurobin/chibu/archive/release.tar.gz
+ md5sums = SKIP
+
+pkgname = chibu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..711198d8acf3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Md. Jahidul Hamid <jahidulhamid@yahoo.com>
+pkgname=chibu
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Create Hybrid ISO Bootable USB"
+download_branch=release
+arch=(any)
+url="https://github.com/neurobin/chibu"
+license=('BSD')
+depends=(python systemd syslinux)
+source=( "https://github.com/neurobin/$pkgname/archive/$download_branch.tar.gz" )
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/$pkgname-$download_branch"
+ ./$pkgname -v | grep -P 'Version:.*' |grep -oP '[\d.]+$'
+}
+
+
+package() {
+ cd "$pkgname-$download_branch"
+ make DESTDIR="$pkgdir/" install
+}