summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-12-30 17:28:47 +0100
committerPhilip Goto2018-12-30 17:28:47 +0100
commita3d526297c8404612e313e05f05436f4484afee9 (patch)
treee040e1f3b2f34c9bced04067001e40fec6a1f553
downloadaur-a3d526297c8404612e313e05f05436f4484afee9.tar.gz
Initialize package
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD56
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de815e5d05eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = chicago95-git
+ pkgdesc = Windows 95 theme
+ pkgver = r128.7ca8525
+ pkgrel = 1
+ url = https://github.com/grassmunk/Chicago95
+ arch = any
+ license = GPL
+ source = git+https://github.com/grassmunk/Chicago95.git
+ sha256sums = SKIP
+
+pkgname = chicago95-gtk-theme-git
+ pkgdesc = Windows 95 inspired GTK theme
+ provides = chicago95-gtk-theme
+ conflicts = chicago95-gtk-theme
+
+pkgname = chicago95-icon-theme-git
+ pkgdesc = Windows 95 inspired icon theme
+ provides = chicago95-icon-theme
+ conflicts = chicago95-icon-theme
+
+pkgname = xcursor-chicago95-git
+ pkgdesc = Windows 95 inspired cursors
+ provides = xcursor-chicago95
+ conflicts = xcursor-chicago95
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20093847a01d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgbase=chicago95-git
+pkgname=(chicago95-gtk-theme-git
+ chicago95-icon-theme-git
+ xcursor-chicago95-git)
+pkgver=r128.7ca8525
+pkgrel=1
+pkgdesc="Windows 95 theme"
+arch=(any)
+url="https://github.com/grassmunk/Chicago95"
+license=('GPL')
+depends=()
+makedepends=()
+source=("git+https://github.com/grassmunk/Chicago95.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd Chicago95
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package_chicago95-gtk-theme-git() {
+ pkgdesc="Windows 95 inspired GTK theme"
+ provides=(chicago95-gtk-theme)
+ conflicts=(chicago95-gtk-theme)
+
+ cd Chicago95
+ install -d "${pkgdir}/usr/share/themes/"
+ cp -r "Theme/Chicago95/" "${pkgdir}/usr/share/themes/Chicago95/"
+}
+
+package_chicago95-icon-theme-git() {
+ pkgdesc="Windows 95 inspired icon theme"
+ provides=(chicago95-icon-theme)
+ conflicts=(chicago95-icon-theme)
+
+ cd Chicago95
+ install -d "${pkgdir}/usr/share/icons/"
+ cp -r "Icons/Chicago95/" "${pkgdir}/usr/share/icons/Chicago95/"
+ cp -r "Icons/Chicago95-tux/" "${pkgdir}/usr/share/icons/Chicago95-tux/"
+}
+
+package_xcursor-chicago95-git() {
+ pkgdesc="Windows 95 inspired cursors"
+ provides=(xcursor-chicago95)
+ conflicts=(xcursor-chicago95)
+
+ cd Chicago95
+ install -d "${pkgdir}/usr/share/icons/Chicago95_Cursor_Black/"
+ cp -r "Cursors/Chicago95_Cursor_Black/cursors/" "${pkgdir}/usr/share/icons/Chicago95_Cursor_Black/cursors/"
+ install -d "${pkgdir}/usr/share/icons/Chicago95_Cursor_White/"
+ cp -r "Cursors/Chicago95_Cursor_White/cursors/" "${pkgdir}/usr/share/icons/Chicago95_Cursor_White/cursors/"
+ install -d "${pkgdir}/usr/share/icons/Chicago95_Emerald/"
+ cp -r "Cursors/Chicago95_Emerald/cursors/" "${pkgdir}/usr/share/icons/Chicago95_Emerald/cursors/"
+}