summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSelfRef2024-08-24 21:32:17 +0200
committerSelfRef2024-08-24 21:32:17 +0200
commit57e29d0eea8d17d76f28bfa1377111f482ad202f (patch)
treefe444ab95679d15120e1ca4c4e1b314c34a6bd6f
downloadaur-57e29d0eea8d17d76f28bfa1377111f482ad202f.tar.gz
Initial version
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD90
3 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b44df9ef548
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = chicago95-theme-git
+ pkgdesc = A rendition of everyone's favorite 1995 Microsoft operating system for Linux (complete theme, git version)
+ pkgver = r598.bdf5cf3
+ pkgrel = 1
+ url = https://github.com/grassmunk/Chicago95
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = zip
+ optdepends = libcanberra: Sound theme
+ optdepends = qt5-styleplugins: QT theme
+ optdepends = ttf-ms-fonts: MS fonts
+ optdepends = lightdm-webkit-greeter: LightDM theme
+ provides = chicago95-theme
+ provides = chicago95-gtk-theme
+ provides = chicago95-icon-theme
+ provides = chicago95-cursor-theme
+ provides = chicago95-sound-theme
+ provides = chicago95-plymouth-theme
+ provides = chicago95-sddm-theme
+ provides = chicago95-lightdm-webkit-theme
+ provides = chicago95-libreoffice-theme
+ conflicts = chicago95-theme
+ conflicts = chicago95
+ conflicts = chicago95-gtk-theme
+ conflicts = chicago95-icon-theme
+ conflicts = xcursor-chicago95
+ conflicts = chicago95-sddm-theme-git
+ source = chicago95::git+https://github.com/grassmunk/Chicago95.git
+ md5sums = SKIP
+
+pkgname = chicago95-theme-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0b6d6887ad73
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*/
+*.pkg.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aba63920724f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,90 @@
+# Maintainer: SelfRef <arch@selfref.dev>
+
+# NOTE: This package installs all theme components that can be installed system-wide
+# except Plus! Theme Conversion that's available in separate package `chicago95-plus-git`.
+# Manual steps are required to enable theme components as described in manual:
+# https://github.com/grassmunk/Chicago95/blob/master/INSTALL.md#config_theme
+# The Extras components are included in this package and are installed under `/usr/share/chicago95`.
+
+_basename=chicago95
+pkgname="${_basename}-theme-git"
+pkgver=r598.bdf5cf3
+pkgrel=1
+pkgdesc="A rendition of everyone's favorite 1995 Microsoft operating system for Linux (complete theme, git version)"
+arch=('any')
+url="https://github.com/grassmunk/Chicago95"
+license=('GPL')
+makedepends=('git' 'zip')
+optdepends=(
+ 'libcanberra: Sound theme'
+ 'qt5-styleplugins: QT theme'
+ 'ttf-ms-fonts: MS fonts'
+ 'lightdm-webkit-greeter: LightDM theme'
+)
+provides=(
+ 'chicago95-theme'
+ 'chicago95-gtk-theme'
+ 'chicago95-icon-theme'
+ 'chicago95-cursor-theme'
+ 'chicago95-sound-theme'
+ 'chicago95-plymouth-theme'
+ 'chicago95-sddm-theme'
+ 'chicago95-lightdm-webkit-theme'
+ 'chicago95-libreoffice-theme'
+)
+conflicts=(
+ 'chicago95-theme'
+ 'chicago95'
+ 'chicago95-gtk-theme'
+ 'chicago95-icon-theme'
+ 'xcursor-chicago95'
+ 'chicago95-sddm-theme-git'
+)
+source=("chicago95::git+https://github.com/grassmunk/Chicago95.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_basename"
+ ( set -o pipefail
+ git describe --long --abbrev=7 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+ )
+}
+
+build() {
+ if [ -d "$_basename/Extras/libreoffice-chicago95-iconset/iconsets/c95" ]; then
+ cd "$_basename/Extras/libreoffice-chicago95-iconset/iconsets/c95"
+ zip -r images_chicago95.zip *
+ else
+ echo '[W] LibreOffice theme not found, skipping'
+ fi
+}
+
+package() {
+ cd "$_basename"
+
+ # Components
+ install -dm755 "$pkgdir"/usr/share/{themes,icons,fonts,sounds,backgrounds,plymouth/themes,lightdm-webkit/themes,sddm/themes,plasma/look-and-feel,xfce4/terminal/colorschemes,chicago95}
+ cp -r Theme/*/ "$pkgdir/usr/share/themes"
+ cp -r Icons/*/ "$pkgdir/usr/share/icons"
+ cp -r Cursors/*/ "$pkgdir/usr/share/icons"
+ cp -r sounds/*/ "$pkgdir/usr/share/sounds"
+ cp -r Fonts/vga_font "$pkgdir/usr/share/fonts"
+ cp -r Fonts/bitmap/cronyx-cyrillic "$pkgdir/usr/share/fonts"
+ cp -r Lightdm/*/ "$pkgdir/usr/share/lightdm-webkit/themes"
+ cp -r KDE/SDDM/*/ "$pkgdir/usr/share/sddm/themes"
+ cp -r KDE/Splash/*/ "$pkgdir/usr/share/plasma/look-and-feel"
+ cp -r Plymouth/*/ "$pkgdir/usr/share/plymouth/themes"
+
+ # Extras
+ cp -r Extras/* "$pkgdir/usr/share/chicago95"
+ cp sounds/chicago95-startup.desktop "$pkgdir/usr/share/chicago95"
+ ln -s $pkgdir/usr/share/chicago95/Chicago95.theme "$pkgdir/usr/share/xfce4/terminal/colorschemes/Chicago95.theme"
+ ln -s $pkgdir/usr/share/chicago95/Backgrounds "$pkgdir/usr/share/backgrounds/chicago95"
+
+ # LibreOffice theme
+ LIBREOFFICETHEME=Extras/libreoffice-chicago95-iconset/iconsets/c95/images_chicago95.zip
+ if [ -f "$LIBREOFFICETHEME" ]; then
+ install -Dm644 "$LIBREOFFICETHEME" "$pkgdir/usr/lib/libreoffice/share/config/images_chicago95.zip"
+ fi
+}