summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Willemse2015-07-09 23:53:25 +0200
committerTom Willemse2015-07-09 23:53:25 +0200
commitc76bfa2fa61f0a77bd13a59494fc8de390be5d40 (patch)
tree3c8fa6711ca91852ef693983c1f4f26a16749099
downloadaur-c76bfa2fa61f0a77bd13a59494fc8de390be5d40.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD55
-rw-r--r--chicken.install15
-rw-r--r--dbus.patch11
4 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10999f925f23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = chicken-dbus
+ pkgdesc = Chicken Scheme Egg: A binding for libdbus, the IPC mechanism
+ pkgver = 0.93
+ pkgrel = 1
+ url = http://chicken.wiki.br/eggref/4/dbus
+ install = chicken.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = chicken>=4.5.0
+ depends = chicken-easyffi
+ depends = chicken-matchable
+ depends = chicken-miscmacros
+ depends = chicken-foreigners
+ depends = dbus-core
+ options = docs
+ options = !libtool
+ options = !emptydirs
+ source = chicken-dbus-0.93.chunked::http://chicken.kitten-technologies.co.uk/henrietta.cgi?name=dbus&version=0.93
+ source = chicken-dbus-0.93.html::http://wiki.call-cc.org/eggref/4/dbus.html
+ source = dbus.patch
+ md5sums = 891f74b8231f0d655297444e140f5e4f
+ md5sums = 503a55be746bee8815a95f8ff07bef97
+ md5sums = 3abccbef575aa13ac1b3cbaefee12ff1
+
+pkgname = chicken-dbus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bc4dfd08745
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jim Pryor <profjim@jimpryor.net>
+# Warning: The chicken-* egg PKGBUILDS in AUR are auto-generated.
+# Please report errors you notice so that I can tweak the generation script.
+
+pkgname=chicken-dbus
+pkgver=0.93
+pkgrel=1
+pkgdesc="Chicken Scheme Egg: A binding for libdbus, the IPC mechanism"
+arch=('i686' 'x86_64')
+url="http://chicken.wiki.br/eggref/4/dbus"
+license=('MIT')
+depends=('chicken>=4.5.0' 'chicken-easyffi' 'chicken-matchable' 'chicken-miscmacros' 'chicken-foreigners' 'dbus-core')
+options=(docs !libtool !emptydirs)
+install="chicken.install"
+source=("$pkgname-$pkgver.chunked::http://chicken.kitten-technologies.co.uk/henrietta.cgi?name=dbus&version=$pkgver"
+ "$pkgname-$pkgver.html::http://wiki.call-cc.org/eggref/4/dbus.html"
+ "dbus.patch")
+md5sums=('891f74b8231f0d655297444e140f5e4f'
+ '503a55be746bee8815a95f8ff07bef97'
+ '3abccbef575aa13ac1b3cbaefee12ff1')
+
+build() {
+ # unchunk the blob that was downloaded from henrietta
+ cd "$srcdir"
+ mkdir -p "dbus-$pkgver"
+ cat "$pkgname-$pkgver.chunked" | while :; do
+ while read -r bar ver endbar fname len; do
+ [[ -n "$ver" ]] && break
+ done
+ [[ "$endbar" = "|#" ]] || fname="$ver" len="$endbar"
+ [[ -z "$fname" ]] && break
+ fname="${fname:1:${#fname}-2}" # delete quotes around fname
+ if [[ "${fname: -1}" == / ]]; then
+ mkdir -p "dbus-$pkgver/$fname"
+ elif [[ "$len" -eq 0 ]]; then
+ touch "dbus-$pkgver/$fname"
+ else
+ dd iflag=fullblock of="dbus-$pkgver/$fname" ibs="$len" count=1 2>/dev/null
+ fi
+ done
+
+ patch "dbus-${pkgver}/dbus.scm" dbus.patch
+}
+
+package () {
+ cd "$srcdir/dbus-$pkgver"
+ cp ../$pkgname-$pkgver.html dbus.html
+
+
+ mkdir -p "$pkgdir/usr/lib/chicken/5" "$pkgdir/usr/share/chicken/dbus"
+
+ chicken-install -p "$pkgdir/usr"
+
+ install -Dm644 "dbus.html" "$pkgdir/usr/share/doc/$pkgname/dbus.html"
+}
diff --git a/chicken.install b/chicken.install
new file mode 100644
index 000000000000..2022006b327d
--- /dev/null
+++ b/chicken.install
@@ -0,0 +1,15 @@
+## arg 1: the new package version
+post_install() {
+ chicken-install -u
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+## arg 1: the old package version
+post_remove() {
+ post_install
+}
diff --git a/dbus.patch b/dbus.patch
new file mode 100644
index 000000000000..e9441a3eade8
--- /dev/null
+++ b/dbus.patch
@@ -0,0 +1,11 @@
+--- dbus/dbus.scm 2015-07-08 22:17:28.746987420 +0200
++++ dbus-patched/dbus.scm 2015-05-31 20:24:57.469958384 +0200
+@@ -275,7 +275,7 @@
+ (if (null? rem-keys)
+ subtree
+ (loop (cdr rem-keys)
+- (let ([pr (assq (car rem-keys) subtree)])
++ (let ([pr (assq (car rem-keys) (or subtree '()))])
+ (and (pair? pr) (cdr pr))))))))
+
+ ;; The "tree" version of asset!: drills down into an assq-tree