summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Willemse2015-07-09 23:57:59 +0200
committerTom Willemse2015-07-09 23:57:59 +0200
commit914b9510886bca8ec4f1f7a89232d5cc8f0c2206 (patch)
tree3cea23a8e59743ce6e19e8c129633e2a59fa6c2f
downloadaur-914b9510886bca8ec4f1f7a89232d5cc8f0c2206.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD55
-rw-r--r--chicken.install15
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5abb1167276d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = chicken-filepath
+ pkgdesc = Chicken Scheme Egg: Cross-platform file path manipulation.
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://chicken.wiki.br/eggref/4/filepath
+ install = chicken.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = chicken>=4.5.0
+ depends = chicken-matchable
+ options = docs
+ options = !libtool
+ options = !emptydirs
+ source = chicken-filepath-1.5.chunked::http://chicken.kitten-technologies.co.uk/henrietta.cgi?name=filepath&version=1.5
+ source = chicken-filepath-1.5.html::http://wiki.call-cc.org/eggref/4/filepath.html
+ md5sums = 82313ef72f684b7de33722a369a0673c
+ md5sums = 861bc4f472062364cd75c127f7ba35da
+
+pkgname = chicken-filepath
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c754462bdd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jim Pryor <profjim@jimpryor.net>
+# Warning: The chicken-* egg PKGBUILDS in AUR are auto-generated.
+# Please report errors you notice so that I can tweak the generation script.
+
+pkgname=chicken-filepath
+pkgver=1.5
+pkgrel=1
+pkgdesc="Chicken Scheme Egg: Cross-platform file path manipulation."
+arch=('i686' 'x86_64')
+url="http://chicken.wiki.br/eggref/4/filepath"
+license=('BSD')
+depends=('chicken>=4.5.0' 'chicken-matchable' )
+options=(docs !libtool !emptydirs)
+install="chicken.install"
+source=("$pkgname-$pkgver.chunked::http://chicken.kitten-technologies.co.uk/henrietta.cgi?name=filepath&version=$pkgver"
+ "$pkgname-$pkgver.html::http://wiki.call-cc.org/eggref/4/filepath.html")
+md5sums=('82313ef72f684b7de33722a369a0673c'
+ '861bc4f472062364cd75c127f7ba35da')
+
+# template start; name=chicken-module; version=1;
+_name=${pkgname#chicken-}
+
+build() {
+ # unchunk the blob that was downloaded from henrietta
+ cd "$srcdir"
+ mkdir -p "${_name}-${pkgver}"
+ cat "${pkgname}-${pkgver}.chunked" | while :; do
+ while read -r bar ver endbar fname len; do
+ [[ -n "$ver" ]] && break
+ done
+ [[ "$endbar" = "|#" ]] || fname="$ver" len="$endbar"
+ [[ -z "$fname" ]] && break
+ fname="${fname:1:${#fname}-2}" # delete quotes around fname
+ if [[ "${fname: -1}" == / ]]; then
+ mkdir -p "${_name}-${pkgver}/${fname}"
+ elif [[ "$len" -eq 0 ]]; then
+ touch "${_name}-${pkgver}/${fname}"
+ else
+ dd iflag=fullblock of="${_name}-${pkgver}/${fname}" ibs="$len" count=1 2>/dev/null
+ fi
+ done
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ cp "../${pkgname}-${pkgver}.html" "${_name}.html"
+
+
+ mkdir -p "${pkgdir}/usr/lib/chicken/5" "${pkgdir}/usr/share/chicken/${_name}"
+
+ chicken-install -p "${pkgdir}/usr"
+
+ install -Dm644 "${_name}.html" "${pkgdir}/usr/share/doc/${pkgname}/${_name}.html"
+}
+# template end;
diff --git a/chicken.install b/chicken.install
new file mode 100644
index 000000000000..2022006b327d
--- /dev/null
+++ b/chicken.install
@@ -0,0 +1,15 @@
+## arg 1: the new package version
+post_install() {
+ chicken-install -u
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+## arg 1: the old package version
+post_remove() {
+ post_install
+}