summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamadi van Koten2016-09-11 01:00:45 +0100
committerSamadi van Koten2016-09-11 01:00:45 +0100
commite0f7c9aa6c0cc4fb2cce981d822e4c6897589e94 (patch)
treefef81c4d859fb0124ac7fcd68919f7032438a1a4
parentac93c8b42339380245311354b1586a281aa9c491 (diff)
downloadaur-e0f7c9aa6c0cc4fb2cce981d822e4c6897589e94.tar.gz
Fix issue causing CHICKEN to be unable to load extensions
I forgot to specify PREFIX on the make task in build(), which had the effect of CHICKEN being unable to load the files in /usr/lib/chicken/8/, which broke basically everything. Note to self: test stuff _properly_ before committing.
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 347117de51b9..5167abf0a584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chicken-git
pkgver=4.11.1.r3356.116f42e
-pkgrel=1
+pkgrel=2
pkgdesc='Feature rich R5RS Scheme compiler and interpreter'
arch=('any')
url='http://call-cc.org/'
@@ -24,7 +24,7 @@ pkgver() {
build() {
cd "$srcdir/chicken-core"
- make PLATFORM=linux
+ make PLATFORM=linux PREFIX='/usr'
}
check() {