summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Willemse2015-07-10 00:01:40 +0200
committerTom Willemse2015-07-10 00:01:40 +0200
commit11eef417d2ba428376417aed46a1f49958841dd9 (patch)
treeed2de6d90c6edfe45a4492f0156928119af14d01
downloadaur-11eef417d2ba428376417aed46a1f49958841dd9.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD53
-rw-r--r--chicken.install15
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e2004c56b5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = chicken-imperative-command-line-a
+ pkgdesc = Chicken Scheme Egg: A simple, imperative-style command-line parser.
+ pkgver = 0.4
+ pkgrel = 1
+ url = http://wiki.call-cc.org/eggref/4/imperative-command-line-a
+ install = chicken.install
+ arch = x86_64
+ license = BSD
+ depends = chicken>=4.5.0
+ depends = chicken-miscmacros
+ options = docs
+ options = !libtool
+ options = !emptydirs
+ source = chicken-imperative-command-line-a-0.4.chunked::http://chicken.kitten-technologies.co.uk/henrietta.cgi?name=imperative-command-line-a&version=0.4
+ source = chicken-imperative-command-line-a-0.4.html::http://wiki.call-cc.org/eggref/4/imperative-command-line-a.html
+ md5sums = 7932a503dadd4e6bb56aa8398be6f53e
+ md5sums = 10bfa8ae3f7d23df8f600574d4475d83
+
+pkgname = chicken-imperative-command-line-a
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae13b8eb35b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Tom Willemse <tom@ryuslash.org>
+
+pkgname=chicken-imperative-command-line-a
+pkgver=0.4
+pkgrel=1
+pkgdesc="Chicken Scheme Egg: A simple, imperative-style command-line parser."
+arch=('x86_64')
+url='http://wiki.call-cc.org/eggref/4/imperative-command-line-a'
+license=('BSD')
+depends=('chicken>=4.5.0' 'chicken-miscmacros')
+options=(docs !libtool !emptydirs)
+install="chicken.install"
+source=("${pkgname}-${pkgver}.chunked::http://chicken.kitten-technologies.co.uk/henrietta.cgi?name=imperative-command-line-a&version=${pkgver}"
+ "${pkgname}-${pkgver}.html::http://wiki.call-cc.org/eggref/4/imperative-command-line-a.html")
+md5sums=('7932a503dadd4e6bb56aa8398be6f53e'
+ '10bfa8ae3f7d23df8f600574d4475d83')
+
+# template start; name=chicken-module; version=1;
+_name=${pkgname#chicken-}
+
+build() {
+ # unchunk the blob that was downloaded from henrietta
+ cd "$srcdir"
+ mkdir -p "${_name}-${pkgver}"
+ cat "${pkgname}-${pkgver}.chunked" | while :; do
+ while read -r bar ver endbar fname len; do
+ [[ -n "$ver" ]] && break
+ done
+ [[ "$endbar" = "|#" ]] || fname="$ver" len="$endbar"
+ [[ -z "$fname" ]] && break
+ fname="${fname:1:${#fname}-2}" # delete quotes around fname
+ if [[ "${fname: -1}" == / ]]; then
+ mkdir -p "${_name}-${pkgver}/${fname}"
+ elif [[ "$len" -eq 0 ]]; then
+ touch "${_name}-${pkgver}/${fname}"
+ else
+ dd iflag=fullblock of="${_name}-${pkgver}/${fname}" ibs="$len" count=1 2>/dev/null
+ fi
+ done
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ cp "../${pkgname}-${pkgver}.html" "${_name}.html"
+
+
+ mkdir -p "${pkgdir}/usr/lib/chicken/5" "${pkgdir}/usr/share/chicken/${_name}"
+
+ chicken-install -p "${pkgdir}/usr"
+
+ install -Dm644 "${_name}.html" "${pkgdir}/usr/share/doc/${pkgname}/${_name}.html"
+}
+# template end;
diff --git a/chicken.install b/chicken.install
new file mode 100644
index 000000000000..2022006b327d
--- /dev/null
+++ b/chicken.install
@@ -0,0 +1,15 @@
+## arg 1: the new package version
+post_install() {
+ chicken-install -u
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+## arg 1: the old package version
+post_remove() {
+ post_install
+}