summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Willemse2015-07-10 00:37:14 +0200
committerTom Willemse2015-07-10 00:37:14 +0200
commitca7859e4ef63e225f83a4e176135c07db1cbd3b9 (patch)
tree8d2705f7f1fd70833954abd08134fe27068f2675
downloadaur-ca7859e4ef63e225f83a4e176135c07db1cbd3b9.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD55
-rw-r--r--chicken.install15
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9a46c125e9c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = chicken-xlib
+ pkgdesc = Chicken Scheme Egg: Xlib bindings
+ pkgver = 1.2
+ pkgrel = 4
+ url = http://chicken.wiki.br/eggref/4/xlib
+ install = chicken.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = chicken>=4.5.0
+ depends = chicken-matchable
+ depends = libx11
+ options = docs
+ options = !libtool
+ options = !emptydirs
+ source = chicken-xlib-1.2.chunked::http://chicken.kitten-technologies.co.uk/henrietta.cgi?name=xlib&version=1.2
+ source = chicken-xlib-1.2.html::http://wiki.call-cc.org/eggref/4/xlib.html
+ md5sums = 951268d1fa79c41046260f1a0f75aa1e
+ md5sums = 687f763efb2880565ab2eb8a4f9914aa
+
+pkgname = chicken-xlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dbfb686d39e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jim Pryor <profjim@jimpryor.net>
+# Warning: The chicken-* egg PKGBUILDS in AUR are auto-generated.
+# Please report errors you notice so that I can tweak the generation script.
+
+pkgname=chicken-xlib
+pkgver=1.2
+pkgrel=4
+pkgdesc="Chicken Scheme Egg: Xlib bindings"
+arch=('i686' 'x86_64')
+url="http://chicken.wiki.br/eggref/4/xlib"
+license=('unknown')
+depends=('chicken>=4.5.0' 'chicken-matchable' 'libx11')
+options=(docs !libtool !emptydirs)
+install="chicken.install"
+source=("$pkgname-$pkgver.chunked::http://chicken.kitten-technologies.co.uk/henrietta.cgi?name=xlib&version=$pkgver"
+ "$pkgname-$pkgver.html::http://wiki.call-cc.org/eggref/4/xlib.html")
+md5sums=('951268d1fa79c41046260f1a0f75aa1e'
+ '687f763efb2880565ab2eb8a4f9914aa')
+
+# template start; name=chicken-module; version=1;
+_name=${pkgname#chicken-}
+
+build() {
+ # unchunk the blob that was downloaded from henrietta
+ cd "$srcdir"
+ mkdir -p "${_name}-${pkgver}"
+ cat "${pkgname}-${pkgver}.chunked" | while :; do
+ while read -r bar ver endbar fname len; do
+ [[ -n "$ver" ]] && break
+ done
+ [[ "$endbar" = "|#" ]] || fname="$ver" len="$endbar"
+ [[ -z "$fname" ]] && break
+ fname="${fname:1:${#fname}-2}" # delete quotes around fname
+ if [[ "${fname: -1}" == / ]]; then
+ mkdir -p "${_name}-${pkgver}/${fname}"
+ elif [[ "$len" -eq 0 ]]; then
+ touch "${_name}-${pkgver}/${fname}"
+ else
+ dd iflag=fullblock of="${_name}-${pkgver}/${fname}" ibs="$len" count=1 2>/dev/null
+ fi
+ done
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ cp "../${pkgname}-${pkgver}.html" "${_name}.html"
+
+
+ mkdir -p "${pkgdir}/usr/lib/chicken/5" "${pkgdir}/usr/share/chicken/${_name}"
+
+ chicken-install -p "${pkgdir}/usr"
+
+ install -Dm644 "${_name}.html" "${pkgdir}/usr/share/doc/${pkgname}/${_name}.html"
+}
+# template end;
diff --git a/chicken.install b/chicken.install
new file mode 100644
index 000000000000..2022006b327d
--- /dev/null
+++ b/chicken.install
@@ -0,0 +1,15 @@
+## arg 1: the new package version
+post_install() {
+ chicken-install -u
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+## arg 1: the old package version
+post_remove() {
+ post_install
+}