summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRussell Greene2017-05-07 09:49:40 -0600
committerRussell Greene2017-05-07 09:50:29 -0600
commite8ad892cb12b5904f86190d039152d9a5256fa65 (patch)
tree4b80d19097fba322ef436a84c86850031ab7f286
downloadaur-e8ad892cb12b5904f86190d039152d9a5256fa65.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d789b408693
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = chigraph-git
+ pkgdesc = A visual programming language
+ pkgver = 244c0d0a512158d6f126713fc0ca0e2a3b532989
+ pkgrel = 1
+ url = https://github.com/chigraph/chigraph
+ arch = i686
+ arch = x86_64
+ makedepends = cmake
+ makedepends = git
+ makedepends = boost
+ depends = libgit2
+ depends = llvm
+ depends = clang
+ depends = lldb
+ depends = boost-libs
+ source = chigraph::git+https://github.com/chigraph/chigraph
+ md5sums = SKIP
+
+pkgname = chigraph-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8324adbc3625
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Russell Greene <russellgreene8 at gmail dot com>
+
+pkgname=chigraph-git
+pkgver=244c0d0a512158d6f126713fc0ca0e2a3b532989
+pkgrel=1
+arch=('i686' 'x86_64')
+
+pkgdesc="A visual programming language"
+url='https://github.com/chigraph/chigraph'
+
+depends=('libgit2' 'llvm' 'clang' 'lldb' 'boost-libs')
+makedepends=('cmake' 'git' 'boost')
+
+source=("chigraph::git+https://github.com/chigraph/chigraph")
+md5sums=('SKIP')
+
+pkgver() {
+ cd chigraph
+ git rev-parse HEAD
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../chigraph -DCMAKE_BUILD_TYPE=Release -DCG_USE_SYSTEM_LIBGIT2=ON -DCG_USE_SYSTEM_BOOST=ON -DCG_BUILD_TESTS=OFF -DCMAKE_INSTALL_PREFIX=/usr
+ make -j`nproc`
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}