summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-02-04 02:25:20 +0800
committerChocobo12020-02-04 02:41:00 +0800
commitad8d5c6428e2ba5a0d0ad6a2b3bdf567265d6549 (patch)
tree2bb627275682df415e43a536d21dda1e38ec6ede
parent1ded36a2492cfebf3a9ed6569c929eacb4609d0c (diff)
downloadaur-ad8d5c6428e2ba5a0d0ad6a2b3bdf567265d6549.tar.gz
upgpkg: chihaya 1.0.2-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c88dd6a44f96..ffa80c3e33ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chihaya
pkgdesc = A customizable, multi-protocol BitTorrent tracker
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/chihaya/chihaya
arch = i686
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = chihaya
makedepends = go-pie
depends = glibc
backup = etc/chihaya.json
- source = https://github.com/chihaya/chihaya/archive/v1.0.2.tar.gz
+ source = chihaya-1.0.2.tar.gz::https://github.com/chihaya/chihaya/archive/v1.0.2.tar.gz
source = chihaya.service::https://aur.archlinux.org/cgit/aur.git/plain/chihaya.service?h=chihaya-git
source = chihaya.sysusers::https://aur.archlinux.org/cgit/aur.git/plain/chihaya.sysusers?h=chihaya-git
sha256sums = 17207aeaf1887befba4a100df4e860000fe2e4747ab0c518aad98005606b05fd
diff --git a/PKGBUILD b/PKGBUILD
index e977ef37a44f..63335dbfc081 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chihaya
pkgver=1.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="A customizable, multi-protocol BitTorrent tracker"
arch=('i686' 'x86_64')
url="https://github.com/chihaya/chihaya"
@@ -10,7 +10,7 @@ license=('BSD')
depends=('glibc')
makedepends=('go-pie')
backup=('etc/chihaya.json')
-source=("https://github.com/chihaya/chihaya/archive/v$pkgver.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/chihaya/chihaya/archive/v$pkgver.tar.gz"
"chihaya.service::https://aur.archlinux.org/cgit/aur.git/plain/chihaya.service?h=chihaya-git"
"chihaya.sysusers::https://aur.archlinux.org/cgit/aur.git/plain/chihaya.sysusers?h=chihaya-git")
sha256sums=('17207aeaf1887befba4a100df4e860000fe2e4747ab0c518aad98005606b05fd'
@@ -21,8 +21,11 @@ sha256sums=('17207aeaf1887befba4a100df4e860000fe2e4747ab0c518aad98005606b05fd'
build() {
cd "$pkgname-$pkgver"
+ touch "go.mod"
+
GO111MODULE=on \
go build \
+ -trimpath \
-ldflags "-extldflags $LDFLAGS" \
./cmd/chihaya
}
@@ -36,12 +39,12 @@ check() {
package() {
cd "$pkgname-$pkgver"
- install -Dm755 "chihaya" "$pkgdir/usr/bin/chihaya"
-
- install -Dm644 "$srcdir/chihaya.service" "$pkgdir/usr/lib/systemd/system/chihaya.service"
- install -Dm644 "$srcdir/chihaya.sysusers" "$pkgdir/usr/lib/sysusers.d/chihaya.conf"
+ install -Dm755 "chihaya" -t "$pkgdir/usr/bin"
install -Dm644 "example_config.json" "$pkgdir/etc/chihaya.json"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/chihaya/LICENSE"
+ install -Dm644 "$srcdir/chihaya.service" -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm644 "$srcdir/chihaya.sysusers" "$pkgdir/usr/lib/sysusers.d/chihaya.conf"
+
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/chihaya"
}