summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSigmund2015-07-09 00:19:01 +0100
committerSigmund2015-07-09 00:19:01 +0100
commitf9ae74a7465a0a00634bd8e1eceec8f51e2fdb37 (patch)
tree048c6a6d83f8a21131a75e6de747e35f74729281
downloadaur-f9ae74a7465a0a00634bd8e1eceec8f51e2fdb37.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
-rw-r--r--childsplay3
-rw-r--r--childsplay.desktop13
-rw-r--r--childsplay.install13
5 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a34b9b1a5f67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = childsplay
+ pkgdesc = A suite of educational games for young children
+ pkgver = 2.6.5
+ pkgrel = 2
+ url = http://www.childsplay.mobi
+ install = childsplay.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2-pygame
+ depends = pygtk
+ depends = python2-sqlalchemy
+ depends = python2-numpy
+ optdepends = childsplay-alphabet-sounds
+ source = http://download.savannah.gnu.org/releases/childsplay/childsplay-2.6.5.tgz
+ source = childsplay.desktop
+ source = childsplay
+ sha256sums = 16b232db3e1806e37748ecf563523cfd7da78fe6b86a625c63e58993b73ca88a
+ sha256sums = 84414248cb8b55d73569414884ef2cbd8c10f3ddf7803d10f912a2f3fcf42e5f
+ sha256sums = 487b8649729b3d8fae8c7d8fb2f76450abf516354e6b4c0d7bf280332ff8f1b1
+
+pkgname = childsplay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..114c2fe6bda2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sigmund Vestergaard <sigmundv at gmail dot com>
+# Contributor: Jakob Nixdorf <jakob.nixdorf@online.de>
+# Contributor: Evangelos Foutras <foutrelis@gmail.com>
+
+pkgname=childsplay
+pkgver=2.6.5
+pkgrel=2
+pkgdesc="A suite of educational games for young children"
+arch=('i686' 'x86_64')
+url="http://www.childsplay.mobi"
+license=('GPL')
+depends=('python2-pygame' 'pygtk' 'python2-sqlalchemy' 'python2-numpy')
+optdepends=('childsplay-alphabet-sounds')
+install=childsplay.install
+source=(http://download.savannah.gnu.org/releases/childsplay/$pkgname-$pkgver.tgz
+ childsplay.desktop childsplay)
+sha256sums=('16b232db3e1806e37748ecf563523cfd7da78fe6b86a625c63e58993b73ca88a'
+ '84414248cb8b55d73569414884ef2cbd8c10f3ddf7803d10f912a2f3fcf42e5f'
+ '487b8649729b3d8fae8c7d8fb2f76450abf516354e6b4c0d7bf280332ff8f1b1')
+
+package() {
+ cd $srcdir
+
+ mkdir -p "$pkgdir/usr/local/games/"
+ mkdir -p "$pkgdir/usr/bin/"
+ cp -R "$pkgname-$pkgver" "$pkgdir/usr/local/games/$pkgname"
+
+ install -D -m755 "$srcdir/childsplay" "$pkgdir/usr/local/games/$pkgname/childsplay"
+ install -D -m644 "$srcdir/childsplay.desktop" \
+ "$pkgdir/usr/share/applications/childsplay.desktop"
+ install -D -m644 "$pkgname-$pkgver/lib/SPData/themes/childsplay/logo_cp_32x32.xpm" \
+ "$pkgdir/usr/share/pixmaps/childsplay.xpm"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/childsplay b/childsplay
new file mode 100644
index 000000000000..484e7dec25ba
--- /dev/null
+++ b/childsplay
@@ -0,0 +1,3 @@
+#!/usr/bin/env bash
+
+python2 /usr/local/games/childsplay/childsplay.py "$@"
diff --git a/childsplay.desktop b/childsplay.desktop
new file mode 100644
index 000000000000..8d0db0df4d2e
--- /dev/null
+++ b/childsplay.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Childsplay
+GenericName=Childsplay
+Comment=Suite of educational games for young children
+Comment[ca]=Conjunt de jocs educatius per a xiquets
+Comment[es]=Conjunto de juegos educativos para niƱos
+Icon=childsplay
+Exec=childsplay
+Terminal=false
+StartupNotify=false
+Categories=Game;Education;KidsGame;2DGraphics;
diff --git a/childsplay.install b/childsplay.install
new file mode 100644
index 000000000000..f268790c71fd
--- /dev/null
+++ b/childsplay.install
@@ -0,0 +1,13 @@
+post_install () {
+ ln -s /usr/local/games/childsplay/childsplay /usr/bin/childsplay
+ echo "To use childsplay with your own language, use"
+ echo "childsplay --language={choose from ar ca de el en es fr it nb nl pl pt ro sl sv uk vi}"
+}
+
+post_upgrade () {
+ post_install
+}
+
+post_remove () {
+ rm -rf /usr/bin/childsplay
+}