summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco V2023-04-15 18:15:24 -0400
committerFrancisco V2023-04-15 18:15:24 -0400
commit78c26f766f9e553bc4018b433f846a7826296eed (patch)
treeeea70ffa14a2f79a2ee496909cfd686e4a1c1f04
downloadaur-78c26f766f9e553bc4018b433f846a7826296eed.tar.gz
Create package chillspot in the AUR
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cc42993862b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = chillspot
+ pkgdesc = Fan curve control and temperature monitor for MSI laptops
+ pkgver = 0.1.1
+ pkgrel = 1
+ arch = x86_64
+ license = GPL
+ checkdepends = meson
+ makedepends = meson
+ makedepends = ninja
+ depends = python-gobject
+ depends = python-configupdater
+ depends = libadwaita
+ depends = gtk4
+ depends = polkit
+ optdepends = isw: configuration values persistence
+ backup = usr/share/chillspot/chillspot/chillspot.conf
+ source = chillspot-0.1.1.tar.gz::https://gitlab.com/fvtronics/chillspot/-/archive/0.1.1/chillspot-0.1.1.tar.gz
+ sha256sums = ede07ee06d6eb9466e6ba932e82d568ac37e87260b8668af164dd7bbb60da48a
+
+pkgname = chillspot
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd97792c389b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Francisco V. <fvasquez dot public at fvtronics dot com>
+pkgname=chillspot
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Fan curve control and temperature monitor for MSI laptops"
+arch=('x86_64')
+url=""
+license=('GPL')
+depends=(
+ 'python-gobject'
+ 'python-configupdater'
+ 'libadwaita'
+ 'gtk4'
+ 'polkit'
+)
+makedepends=(
+ 'meson'
+ 'ninja'
+)
+checkdepends=('meson')
+optdepends=('isw: configuration values persistence')
+backup=("usr/share/$pkgname/$pkgname/$pkgname.conf")
+source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/fvtronics/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('ede07ee06d6eb9466e6ba932e82d568ac37e87260b8668af164dd7bbb60da48a')
+
+build() {
+ arch-meson $pkgname-$pkgver build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}