summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlesh Slovak2022-05-27 18:20:50 -0400
committerAlesh Slovak2022-05-27 18:20:50 -0400
commit986f3ab420b068dc4c629b5a4108779f8531a42d (patch)
tree047522147e8a22519a549f316b7f41c431fafa93
parent364ed2e95961b502a74fe05bf9467105a9246ddd (diff)
downloadaur-986f3ab420b068dc4c629b5a4108779f8531a42d.tar.gz
release 0.14.7
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 611d09888dc2..52a7afd2e8c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chimera
pkgdesc = Configure and manage games in Steam
- pkgver = 0.14.6
+ pkgver = 0.14.7
pkgrel = 1
url = https://github.com/chimeraos/chimera
arch = any
@@ -16,6 +16,7 @@ pkgbase = chimera
depends = python-pygame
depends = python-bcrypt
depends = python-psutil
+ depends = python-pyudev
depends = retroarch
depends = libretro-genesis-plus-gx
depends = libretro-mgba
@@ -42,11 +43,12 @@ pkgbase = chimera
optdepends = libretro-stella2014-git
optdepends = libretro-opera-git
optdepends = srt-live-server
+ optdepends = steam-removable-media-git
provides = steam-tweaks
provides = steam-buddy
conflicts = steam-tweaks
conflicts = steam-buddy
- source = chimera-0.14.6.tar.gz::https://github.com/chimeraos/chimera/archive/0.14.6.tar.gz
- md5sums = 979e95c02ff41e515fd3ebcc46c91439
+ source = chimera-0.14.7.tar.gz::https://github.com/chimeraos/chimera/archive/0.14.7.tar.gz
+ md5sums = c63da19dc2f490d9aab62648a7e5c7b2
pkgname = chimera
diff --git a/PKGBUILD b/PKGBUILD
index 6563a7ad9bda..3aee65deda1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alesh Slovak <aleshslovak@gmail.com>
pkgname=chimera
-pkgver=0.14.6
+pkgver=0.14.7
pkgrel=1
pkgdesc="Configure and manage games in Steam"
arch=('any')
@@ -9,10 +9,10 @@ url="https://github.com/chimeraos/chimera"
license=('MIT')
provides=('steam-tweaks' 'steam-buddy')
conflicts=('steam-tweaks' 'steam-buddy')
-depends=('python' 'python-bottle' 'python-pyftpdlib' 'python-yaml' 'python-vdf' 'python-inotify-simple' 'python-requests' 'python-beaker' 'python-pygame' 'python-bcrypt' 'python-psutil' 'retroarch' 'libretro-genesis-plus-gx' 'libretro-mgba' 'libretro-nestopia' 'libretro-snes9x' 'libretro-mupen64plus-next' 'libretro-beetle-pce-fast' 'libretro-flycast' 'libretro-beetle-psx-hw' 'libretro-play' 'libretro-kronos' 'libretro-dolphin' 'retroarch-autoconfig-udev-git' 'flatpak' 'xdotool' 'ponymix' 'libretro-picodrive' 'legendary' 'ttf-dejavu' 'wyvern' 'innoextract' 'mesa-utils')
-optdepends=('libretro-mame-git' 'libretro-stella2014-git' 'libretro-opera-git' 'srt-live-server') # compiling cores takes a long time, so make them optional
+depends=('python' 'python-bottle' 'python-pyftpdlib' 'python-yaml' 'python-vdf' 'python-inotify-simple' 'python-requests' 'python-beaker' 'python-pygame' 'python-bcrypt' 'python-psutil' 'python-pyudev' 'retroarch' 'libretro-genesis-plus-gx' 'libretro-mgba' 'libretro-nestopia' 'libretro-snes9x' 'libretro-mupen64plus-next' 'libretro-beetle-pce-fast' 'libretro-flycast' 'libretro-beetle-psx-hw' 'libretro-play' 'libretro-kronos' 'libretro-dolphin' 'retroarch-autoconfig-udev-git' 'flatpak' 'xdotool' 'ponymix' 'libretro-picodrive' 'legendary' 'ttf-dejavu' 'wyvern' 'innoextract' 'mesa-utils')
+optdepends=('libretro-mame-git' 'libretro-stella2014-git' 'libretro-opera-git' 'srt-live-server' 'steam-removable-media-git') # compiling cores takes a long time, so make them optional
source=("$pkgname-$pkgver.tar.gz::https://github.com/chimeraos/$pkgname/archive/$pkgver.tar.gz")
-md5sums=('979e95c02ff41e515fd3ebcc46c91439')
+md5sums=('c63da19dc2f490d9aab62648a7e5c7b2')
build() {
cd "$srcdir/$pkgname-$pkgver"