summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordevome2024-03-22 17:09:02 +0800
committerdevome2024-03-22 17:09:02 +0800
commit31018d42cecc2050c72079a7b060d1cc667c7002 (patch)
treeaeee1ffb78301e985a7e34b7624c7789504f5bb7
parent74e59bd346791b3ba9b3d2494a4ebca05401b9cf (diff)
downloadaur-31018d42cecc2050c72079a7b060d1cc667c7002.tar.gz
remove package in base from depends
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5baca132eae..0ba6dfdd6c8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,9 +17,6 @@ pkgbase = chinesesubfinder
makedepends = git
makedepends = go
depends = ffmpeg
- depends = gcc-libs
- depends = glibc
- depends = systemd
source = chinesesubfinder::git+https://github.com/ChineseSubFinder/ChineseSubFinder.git#tag=v0.55.3
source = chinesesubfinder.service
source = chinesesubfinder.sysusers
diff --git a/PKGBUILD b/PKGBUILD
index 1cfb337fc844..51dcacb2c0f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64' 'riscv64')
url="https://github.com/${_reponame}/${_reponame}"
license=("MIT")
install="${pkgname}.install"
-depends=("ffmpeg" "gcc-libs" "glibc" "systemd")
+depends=("ffmpeg")
makedepends=("npm" "git" "go")
source=("${pkgname}::git+${url}.git#tag=v${pkgver}"
"${pkgname}.service"
@@ -41,10 +41,10 @@ build() {
}
package() {
- install -Dm755 "${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
- install -Dm644 "${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
- install -Dm644 "${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ install -Dm755 "${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+ install -Dm644 "${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
+ install -Dm644 "${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
install -Dm644 "${pkgname}.user.service" "${pkgdir}/usr/lib/systemd/user/${pkgname}.service"
- install -Dm644 "${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}