summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2018-01-22 18:19:15 +0100
committerMichael Straube2018-01-22 18:20:25 +0100
commit6052df9b36e681a46ce9f034e177ca00011eb2c8 (patch)
tree26d54d5926077bf70b942983b224a2ba44ef5402
parent8fcb6eac4989a53403d7a86b5b43edddbd30281f (diff)
downloadaur-6052df9b36e681a46ce9f034e177ca00011eb2c8.tar.gz
chipmachine-1.43b-2
- add .desktop file - remove insecure rpath
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
-rw-r--r--chipmachine1
3 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78397377ed0a..c815db7da93e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = chipmachine
pkgdesc = Demoscene/Retro Music Player
pkgver = 1.4b3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sasq64/chipmachine
arch = i686
arch = x86_64
license = MIT
makedepends = cmake
makedepends = vim
+ makedepends = gendesk
depends = mpg123
depends = glew
depends = glfw
@@ -19,7 +20,7 @@ pkgbase = chipmachine
source = cm
sha256sums = b01f123e157d72eee4f4d3784f82b1ab0cc5b4d968067b0af50163321d3f5cb4
sha256sums = e411d6515064bb2c952a95aad6bcfc70c1f6b58f40d7874f671ef26185911156
- sha256sums = 5b2cc9b2eaa7b7a1fcbad0c405950b0d05f200caa5d99203ce3be988ca1f05ab
+ sha256sums = 55bc037642af379ac1bec1c0b6ab10a1af8d13d5fb98fd92e413984516afcd30
sha256sums = 75659c95d717851986bbadcf3d3dddb3d72f92720cdd58a97b870e91daf73b5c
pkgname = chipmachine
diff --git a/PKGBUILD b/PKGBUILD
index 3f694c557149..7f6aa97f7804 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,27 @@
pkgname=chipmachine
pkgver=1.4b3
-pkgrel=1
+pkgrel=2
pkgdesc='Demoscene/Retro Music Player'
arch=('i686' 'x86_64')
url='https://github.com/sasq64/chipmachine'
license=('MIT')
depends=('mpg123' 'glew' 'glfw' 'curl' 'fftw')
-makedepends=('cmake' 'vim')
+makedepends=('cmake' 'vim' 'gendesk')
source=("chipmachine-v1.4b3.tar.gz::https://github.com/sasq64/chipmachine/archive/v1.4b3.tar.gz"
"apone-chipmachine-v1.4b3.tar.gz::https://github.com/sasq64/apone/archive/chipmachine-v1.4b3.tar.gz"
"chipmachine"
"cm")
sha256sums=('b01f123e157d72eee4f4d3784f82b1ab0cc5b4d968067b0af50163321d3f5cb4'
'e411d6515064bb2c952a95aad6bcfc70c1f6b58f40d7874f671ef26185911156'
- '5b2cc9b2eaa7b7a1fcbad0c405950b0d05f200caa5d99203ce3be988ca1f05ab'
+ '55bc037642af379ac1bec1c0b6ab10a1af8d13d5fb98fd92e413984516afcd30'
'75659c95d717851986bbadcf3d3dddb3d72f92720cdd58a97b870e91daf73b5c')
prepare() {
cd $pkgname-$pkgver
+ gendesk -f -n --pkgname="$pkgname" --pkgdesc="$pkgdesc" --categories="AudioVideo"
ln -sf ../apone-chipmachine-v1.4b3 apone
+ sed -i '/link_directories(\/usr\/local\/lib)/d' CMakeLists.txt # remove insecure rpath
mkdir -p ../build
}
@@ -35,10 +37,16 @@ build() {
package() {
cd $pkgname-$pkgver
install -d "$pkgdir"/{usr/bin,opt/chipmachine}
+
install -m755 ../build/chipmachine "$pkgdir"/opt/chipmachine/
# install -m755 ../build/cm "$pkgdir"/opt/chipmachine/
cp -r data lua "$pkgdir"/opt/chipmachine/
+
install -m755 ../chipmachine "$pkgdir"/usr/bin/
# install -m755 ../cm "$pkgdir"/usr/bin/
+
+ install -Dm644 chipmachine.desktop "$pkgdir"/usr/share/applications/chipmachine.desktop
+ install -Dm644 note.png "$pkgdir"/usr/share/pixmaps/chipmachine.png
+
install -Dm644 apone/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/chipmachine b/chipmachine
index 57a062bc7c37..55efd70ab9e2 100644
--- a/chipmachine
+++ b/chipmachine
@@ -2,4 +2,3 @@
cd /opt/chipmachine
exec ./chipmachine "$@"
-