summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-12-20 21:39:30 +0100
committerMichael Straube2017-12-20 21:39:30 +0100
commit8fcb6eac4989a53403d7a86b5b43edddbd30281f (patch)
tree602b04d8acec3596767f126cc496056ea3a3727b
parent269d3d52a887d60aeb5631a1e66dd8ce9c0a3180 (diff)
downloadaur-8fcb6eac4989a53403d7a86b5b43edddbd30281f.tar.gz
Update to 1.4b3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
-rw-r--r--chipmachine5
-rw-r--r--chipmachine-1.3c-fixed-against-latest-apone.patch79
-rw-r--r--chipmachine-1.3c-two-missing-std-specifiers.patch36
-rw-r--r--cm4
6 files changed, 40 insertions, 144 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3107d00de40..78397377ed0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = chipmachine
pkgdesc = Demoscene/Retro Music Player
- pkgver = 1.3c
- pkgrel = 2
+ pkgver = 1.4b3
+ pkgrel = 1
url = https://github.com/sasq64/chipmachine
arch = i686
arch = x86_64
license = MIT
makedepends = cmake
makedepends = vim
- makedepends = git
depends = mpg123
depends = glew
depends = glfw
depends = curl
- source = chipmachine-1.3c.tar.gz::https://github.com/sasq64/chipmachine/archive/v1.3c.tar.gz
- source = git+https://github.com/sasq64/apone.git#commit=d320e07159a35f47cbc81ea45f145c27a976f98c
- source = chipmachine-1.3c-two-missing-std-specifiers.patch
- source = chipmachine-1.3c-fixed-against-latest-apone.patch
- sha256sums = fe83080035a6ba23917a79b9133e29b2b934e7711fb21e8039eff3a9411fd354
- sha256sums = SKIP
- sha256sums = 7dc76d37e016a5109efb471b30b3c46246ea231ad3cd6e45bd8a6a438cccfd44
- sha256sums = 531db4559b7cb57e20409e26d500aa82dc8e6c03aa437547affdd88c5cb03997
+ depends = fftw
+ source = chipmachine-v1.4b3.tar.gz::https://github.com/sasq64/chipmachine/archive/v1.4b3.tar.gz
+ source = apone-chipmachine-v1.4b3.tar.gz::https://github.com/sasq64/apone/archive/chipmachine-v1.4b3.tar.gz
+ source = chipmachine
+ source = cm
+ sha256sums = b01f123e157d72eee4f4d3784f82b1ab0cc5b4d968067b0af50163321d3f5cb4
+ sha256sums = e411d6515064bb2c952a95aad6bcfc70c1f6b58f40d7874f671ef26185911156
+ sha256sums = 5b2cc9b2eaa7b7a1fcbad0c405950b0d05f200caa5d99203ce3be988ca1f05ab
+ sha256sums = 75659c95d717851986bbadcf3d3dddb3d72f92720cdd58a97b870e91daf73b5c
pkgname = chipmachine
diff --git a/PKGBUILD b/PKGBUILD
index 8f47be417173..3f694c557149 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,26 @@
# Contributor: Sebastian Wolf <fatmike303 at googlemail dot com>
pkgname=chipmachine
-pkgver=1.3c
-pkgrel=2
+pkgver=1.4b3
+pkgrel=1
pkgdesc='Demoscene/Retro Music Player'
arch=('i686' 'x86_64')
url='https://github.com/sasq64/chipmachine'
license=('MIT')
-depends=('mpg123' 'glew' 'glfw' 'curl')
-makedepends=('cmake' 'vim' 'git')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/sasq64/$pkgname/archive/v$pkgver.tar.gz"
- "git+https://github.com/sasq64/apone.git#commit=d320e07159a35f47cbc81ea45f145c27a976f98c"
- "chipmachine-1.3c-two-missing-std-specifiers.patch"
- "chipmachine-1.3c-fixed-against-latest-apone.patch")
-sha256sums=('fe83080035a6ba23917a79b9133e29b2b934e7711fb21e8039eff3a9411fd354'
- 'SKIP'
- '7dc76d37e016a5109efb471b30b3c46246ea231ad3cd6e45bd8a6a438cccfd44'
- '531db4559b7cb57e20409e26d500aa82dc8e6c03aa437547affdd88c5cb03997')
+depends=('mpg123' 'glew' 'glfw' 'curl' 'fftw')
+makedepends=('cmake' 'vim')
+source=("chipmachine-v1.4b3.tar.gz::https://github.com/sasq64/chipmachine/archive/v1.4b3.tar.gz"
+ "apone-chipmachine-v1.4b3.tar.gz::https://github.com/sasq64/apone/archive/chipmachine-v1.4b3.tar.gz"
+ "chipmachine"
+ "cm")
+sha256sums=('b01f123e157d72eee4f4d3784f82b1ab0cc5b4d968067b0af50163321d3f5cb4'
+ 'e411d6515064bb2c952a95aad6bcfc70c1f6b58f40d7874f671ef26185911156'
+ '5b2cc9b2eaa7b7a1fcbad0c405950b0d05f200caa5d99203ce3be988ca1f05ab'
+ '75659c95d717851986bbadcf3d3dddb3d72f92720cdd58a97b870e91daf73b5c')
prepare() {
cd $pkgname-$pkgver
- patch -p1 -i ../chipmachine-1.3c-two-missing-std-specifiers.patch
- patch -p1 -i ../chipmachine-1.3c-fixed-against-latest-apone.patch
+ ln -sf ../apone-chipmachine-v1.4b3 apone
mkdir -p ../build
}
@@ -35,8 +34,11 @@ build() {
package() {
cd $pkgname-$pkgver
- install -d "$pkgdir"/usr/{bin,share/chipmachine}
- install -m755 ../build/{chipmachine,cm} "$pkgdir"/usr/bin/
- cp -r data lua "$pkgdir"/usr/share/chipmachine/
- install -Dm644 ../apone/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -d "$pkgdir"/{usr/bin,opt/chipmachine}
+ install -m755 ../build/chipmachine "$pkgdir"/opt/chipmachine/
+# install -m755 ../build/cm "$pkgdir"/opt/chipmachine/
+ cp -r data lua "$pkgdir"/opt/chipmachine/
+ install -m755 ../chipmachine "$pkgdir"/usr/bin/
+# install -m755 ../cm "$pkgdir"/usr/bin/
+ install -Dm644 apone/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/chipmachine b/chipmachine
new file mode 100644
index 000000000000..57a062bc7c37
--- /dev/null
+++ b/chipmachine
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+cd /opt/chipmachine
+exec ./chipmachine "$@"
+
diff --git a/chipmachine-1.3c-fixed-against-latest-apone.patch b/chipmachine-1.3c-fixed-against-latest-apone.patch
deleted file mode 100644
index a6e7f42f83d5..000000000000
--- a/chipmachine-1.3c-fixed-against-latest-apone.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From 44ed091a4305b2231595bd7f62c11803eb66aeb7 Mon Sep 17 00:00:00 2001
-From: Jonas Minnberg <sasq64@gmail.com>
-Date: Sat, 11 Jun 2016 17:10:30 +0200
-Subject: [PATCH] Fixed against latest apone
-
----
- CMakeLists.txt | 4 ++--
- src/RemoteLoader.cpp | 6 +++---
- src/RemoteLoader.h | 4 ++--
- 3 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 75de5dd..7d201d1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -6,8 +6,8 @@ include(${AP1_ROOT}/cmake/Utils.cmake)
-
- add_definitions(-DAPP_NAME=chipmachine)
-
--set(CMAKE_OSX_SYSROOT /Users/jonasm/MacOSX10.9.sdk)
--set(CMAKE_OSX_DEPLOYMENT_TARGET "10.9")
-+# set(CMAKE_OSX_SYSROOT /Users/jonasm/MacOSX10.9.sdk)
-+# set(CMAKE_OSX_DEPLOYMENT_TARGET "10.9")
-
- if(RASPBERRYPI)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=armv6 -mfpu=vfp -mfloat-abi=hard")
-diff --git a/src/RemoteLoader.cpp b/src/RemoteLoader.cpp
-index 80a9a2c..0aca3ab 100644
---- a/src/RemoteLoader.cpp
-+++ b/src/RemoteLoader.cpp
-@@ -81,7 +81,7 @@ bool RemoteLoader::load(const std::string &p, function<void(File f)> done_cb) {
- url = url.substr(0, url.length() - 4);
- }
-
-- lastSession = webgetter.getFile(url, [=](webutils::Web::Job job) {
-+ lastSession = webgetter.getFile(url, [=](webutils::WebJob job) {
- LOGD("CODE %d", job.code());
- auto f = job.file();
- string fileName = f.getName();
-@@ -97,7 +97,7 @@ bool RemoteLoader::load(const std::string &p, function<void(File f)> done_cb) {
-
- void RemoteLoader::preCache(const std::string &path) {}
-
--std::shared_ptr<webutils::Web::Job>
-+std::shared_ptr<webutils::WebJob>
- RemoteLoader::stream(const std::string &p,
- std::function<bool(int what, const uint8_t *data, int size)> data_cb) {
-
-@@ -119,7 +119,7 @@ RemoteLoader::stream(const std::string &p,
- string url = source.url + path;
- bool headers = false;
- lastSession = webgetter.streamData(
-- url, [=](webutils::Web::Job &job, uint8_t *data, int size) mutable -> bool {
-+ url, [=](webutils::WebJob &job, uint8_t *data, int size) mutable -> bool {
- if(!headers) {
- string s = job.getHeader("icy-metaint");
- if(s != "") {
-diff --git a/src/RemoteLoader.h b/src/RemoteLoader.h
-index 05d9086..eb46da3 100644
---- a/src/RemoteLoader.h
-+++ b/src/RemoteLoader.h
-@@ -17,7 +17,7 @@ class RemoteLoader {
-
- bool load(const std::string &path, std::function<void(utils::File)> done_cb);
-
-- std::shared_ptr<webutils::Web::Job>
-+ std::shared_ptr<webutils::WebJob>
- stream(const std::string &path,
- std::function<bool(int what, const uint8_t *data, int size)> data_cb);
-
-@@ -55,7 +55,7 @@ class RemoteLoader {
- std::unordered_map<std::string, Source> sources;
-
- webutils::Web webgetter;
-- std::shared_ptr<webutils::Web::Job> lastSession;
-+ std::shared_ptr<webutils::WebJob> lastSession;
- };
-
- #endif // REMOTE_LOADER_H
diff --git a/chipmachine-1.3c-two-missing-std-specifiers.patch b/chipmachine-1.3c-two-missing-std-specifiers.patch
deleted file mode 100644
index 09e2df54fca9..000000000000
--- a/chipmachine-1.3c-two-missing-std-specifiers.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 31181465d5c8ba87efa6450c149dc00acffe0f6d Mon Sep 17 00:00:00 2001
-From: Jonas Minnberg <sasq64@gmail.com>
-Date: Tue, 17 May 2016 10:38:42 +0200
-Subject: [PATCH] Two missing std specifiers
-
----
- demofx/Scroller.h | 2 +-
- src/ChipMachine.h | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/demofx/Scroller.h b/demofx/Scroller.h
-index b17e286..46d8e2c 100644
---- a/demofx/Scroller.h
-+++ b/demofx/Scroller.h
-@@ -15,7 +15,7 @@ class Scroller : public Effect {
- program = grappix::get_program(grappix::TEXTURED_PROGRAM).clone();
-
- grappix::Resources::getInstance().load<std::string>(utils::File::getCacheDir() / "sine_shader.glsl",
-- [=](std::shared_ptr<string> source) {
-+ [=](std::shared_ptr<std::string> source) {
- try {
- program.setFragmentSource(*source);
- } catch(grappix::shader_exception &e) {
-diff --git a/src/ChipMachine.h b/src/ChipMachine.h
-index 35b9623..1515e9f 100644
---- a/src/ChipMachine.h
-+++ b/src/ChipMachine.h
-@@ -223,7 +223,7 @@ class ChipMachine {
-
- //
-
-- string currentNextPath;
-+ std::string currentNextPath;
- SongInfo currentInfo;
- SongInfo dbInfo;
- int currentTune = 0;
diff --git a/cm b/cm
new file mode 100644
index 000000000000..a67ea1b3fa8a
--- /dev/null
+++ b/cm
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/chipmachine
+exec ./cm "$@"