summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Hug2017-01-08 21:50:48 +0100
committerPhilipp Hug2017-01-08 21:50:48 +0100
commit13454afc6849322fc8c850f82d3eedee8a84fbb7 (patch)
treee66fbe1c8f05a1673711e71f75eceb4e4f93e336
downloadaur-13454afc6849322fc8c850f82d3eedee8a84fbb7.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD62
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44340c782d3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = chipsec-dkms-git
+ pkgdesc = Platform Security Assessment Framework
+ pkgver = v1.2.5.r20.gc377a72
+ pkgrel = 1
+ url = https://github.com/chipsec/chipsec
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = python
+ depends = python2
+ source = chipsec-dkms-git::git+https://github.com/chipsec/chipsec
+ md5sums = SKIP
+
+pkgname = chipsec-dkms-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63ac957784e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Philipp Hug <arch@hug.cx>
+pkgname=chipsec-dkms-git
+pkgver=v1.2.5.r20.gc377a72
+pkgrel=1
+epoch=
+pkgdesc="Platform Security Assessment Framework"
+arch=("x86_64")
+url="https://github.com/chipsec/chipsec"
+license=('GPL2')
+groups=()
+depends=('python' 'python2')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname::git+https://github.com/chipsec/chipsec")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+}
+
+check() {
+ cd "$pkgname"
+}
+
+package() {
+ cd "$pkgname/drivers/linux"
+
+ # Copy dkms.conf
+ install -Dm644 dkms.conf "${pkgdir}"/usr/src/${pkgname}/dkms.conf
+
+ # Set name and version
+ sed -e "s/@_PKGBASE@/${pkgname}/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${pkgdir}"/usr/src/${pkgname}/dkms.conf
+
+ # Copy sources (including Makefile)
+ cp -r ./* "${pkgdir}"/usr/src/${pkgname}/
+}