summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorK5TRP2023-01-22 16:04:10 -0600
committerK5TRP2023-01-22 16:04:10 -0600
commita2074b18abaf7109522eb89943bf4297ef5f04b9 (patch)
treef2769d51048071e3bb4b745733e51d3c41e61261
downloadaur-a2074b18abaf7109522eb89943bf4297ef5f04b9.tar.gz
Created chirp-next
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD32
-rw-r--r--chirp-next.install7
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01b43a8e3716
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = chirp-next
+ pkgdesc = GUI tool for programming ham radios, built from daily build
+ pkgver = 20230122
+ pkgrel = 1
+ url = https://chirp.danplanet.com
+ install = chirp-next.install
+ arch = any
+ license = GPL3
+ depends = python-six
+ depends = python-pyserial
+ depends = python-future
+ depends = python-requests
+ depends = python-suds
+ depends = python-yattag
+ depends = python-wxpython
+ optdepends = hamradio-menus: XDG menus for ham radio software
+ provides = chirp
+ conflicts = chirp
+ conflicts = chirp-daily
+ options = !emptydirs
+ source = https://trac.chirp.danplanet.com/chirp_next/next-20230122/chirp-next-20230122.tar.gz
+ sha1sums = a28a631cbd860889296479f07e9129c9cc0c5055
+
+pkgname = chirp-next
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d0dfe4733fdb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+chirp-next-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0d1e5b913f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Thanks to the maintainer(s) of chirp-daily
+# Maintainer: K5TRP <K5TRP@protonmail.com>
+# Contributor: 0b100100 <0b100100 at protonmail dot ch>
+# Contributor: Ashley Roll (ash@digitalnemesis.com)
+# Contributor: Erez Raviv (erezraviv@gmail.com)
+
+pkgname=chirp-next
+pkgver=20230122
+pkgrel=1
+pkgdesc="GUI tool for programming ham radios, built from daily build"
+arch=('any')
+url="https://chirp.danplanet.com"
+license=('GPL3')
+depends=('python-six' 'python-pyserial' 'python-future' 'python-requests' 'python-suds' 'python-yattag' 'python-wxpython')
+optdepends=('hamradio-menus: XDG menus for ham radio software')
+options=(!emptydirs)
+conflicts=('chirp' 'chirp-daily')
+provides=(chirp)
+install=$pkgname.install
+source=("https://trac.chirp.danplanet.com/chirp_next/next-$pkgver/chirp-next-$pkgver.tar.gz")
+# Checksum: https://trac.chirp.danplanet.com/chirp_daily/daily-$pkgver/SHA1SUM
+sha1sums=('a28a631cbd860889296479f07e9129c9cc0c5055')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
diff --git a/chirp-next.install b/chirp-next.install
new file mode 100644
index 000000000000..b7033a389575
--- /dev/null
+++ b/chirp-next.install
@@ -0,0 +1,7 @@
+post_install() {
+ # serial port permissions
+ # (https://chirp.danplanet.com/projects/chirp/wiki/Running_Under_Linux#serial-port-permissions)
+ echo "==> You may need to add your user to the 'uucp' group to access serial ports and devices."
+ echo -e "==> This can be accomplished with: '\e[32msudo usermod -aG uucp \$USER\e[0m'"
+ echo "==> Then you will need to log out and back in for it to take effect."
+}