summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2017-01-07 14:19:17 +1100
committerMatthew Gamble2017-01-07 14:19:17 +1100
commit080dadb2cb0c05eb019e3b61e52ae20b172482ae (patch)
tree86737070dcd034e48ecfe5a555122352de37e5b5
parent843aaa201fdb31012da4e7ef4bc0ba9edd03707c (diff)
downloadaur-080dadb2cb0c05eb019e3b61e52ae20b172482ae.tar.gz
Update to latest version (includes python3.6 rebuild)
- Update URL - Code style fixes
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e32e532c1225..a2c2278b2085 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
+# Generated by mksrcinfo v8
+# Sat Jan 7 03:19:09 UTC 2017
pkgbase = chkcrontab
pkgdesc = A tool for checking system crontab files (/etc/crontab and /etc/cron.d normally) for errors and common mistakes.
- pkgver = 1.6
+ pkgver = 1.7
pkgrel = 1
- url = http://code.google.com/p/chkcrontab/
+ url = https://github.com/lyda/chkcrontab
arch = any
license = Apache
depends = python
- source = https://github.com/lyda/chkcrontab/archive/v1.6.tar.gz
- sha256sums = be7436d5ece4ad6390365f6edf0f1dc59dfd655a9de3b4699884343ceb150f2e
+ source = https://github.com/lyda/chkcrontab/archive/v1.7.tar.gz
+ sha256sums = 1725172dbdea26f1aef915b9acd7100605e49f8675761900bc0992a227d767b9
pkgname = chkcrontab
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d72b4cd24ca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.pkg.tar.xz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
index 2038566c8b5f..c7b6c6e1e63f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: Matthew Gamble
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
pkgname=chkcrontab
-pkgver=1.6
+pkgver=1.7
pkgrel=1
pkgdesc="A tool for checking system crontab files (/etc/crontab and /etc/cron.d normally) for errors and common mistakes."
-arch=('any')
-url='http://code.google.com/p/chkcrontab/'
-license=('Apache')
-depends=('python')
-source=("https://github.com/lyda/chkcrontab/archive/v$pkgver.tar.gz")
-sha256sums=("be7436d5ece4ad6390365f6edf0f1dc59dfd655a9de3b4699884343ceb150f2e")
+arch=("any")
+url="https://github.com/lyda/chkcrontab"
+license=("Apache")
+depends=("python")
+source=("https://github.com/lyda/chkcrontab/archive/v${pkgver}.tar.gz")
+sha256sums=('1725172dbdea26f1aef915b9acd7100605e49f8675761900bc0992a227d767b9')
package() {
- cd "chkcrontab-$pkgver"
- python setup.py install --root="$pkgdir"
+ cd "chkcrontab-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
}