summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCédric Connes2017-10-23 20:30:33 +0200
committerCédric Connes2017-10-23 20:30:33 +0200
commit4b759104c27f84e70c5a35b6f575b16272c1b017 (patch)
treedc6fbdc2854ddbd79880d19d2fdc75661ba97034
downloadaur-4b759104c27f84e70c5a35b6f575b16272c1b017.tar.gz
Initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD28
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84f7b22cba8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = chkit
+ pkgdesc = The Containerum CLI
+ pkgver = 2.1.5
+ pkgrel = 1
+ url = https://containerum.com/documentation
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ source = https://github.com/containerum/chkit/raw/2.1.5/LICENSE
+ md5sums = bfa4ddd8612478bdf362161209972c9b
+ source_i686 = https://github.com/containerum/chkit/releases/download/2.1.5/chkit_linux_x86_v2.1.5.tar.gz
+ md5sums_i686 = 43c014f6ea407491831418c482fe58d7
+ source_x86_64 = https://github.com/containerum/chkit/releases/download/2.1.5/chkit_linux_x64_v2.1.5.tar.gz
+ md5sums_x86_64 = 6c91816a28252f8ac2d7854906eb27af
+ source_arm = https://github.com/containerum/chkit/releases/download/2.1.5/chkit_linux_arm_v2.1.5.tar.gz
+ md5sums_arm = 78aa5c144494568f0afb421598d4b823
+ source_armv6h = https://github.com/containerum/chkit/releases/download/2.1.5/chkit_linux_arm_v2.1.5.tar.gz
+ md5sums_armv6h = 78aa5c144494568f0afb421598d4b823
+ source_armv7h = https://github.com/containerum/chkit/releases/download/2.1.5/chkit_linux_arm_v2.1.5.tar.gz
+ md5sums_armv7h = 78aa5c144494568f0afb421598d4b823
+ source_aarch64 = https://github.com/containerum/chkit/releases/download/2.1.5/chkit_linux_arm_v2.1.5.tar.gz
+ md5sums_aarch64 = 78aa5c144494568f0afb421598d4b823
+
+pkgname = chkit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d7e81b88a72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Cédric Connes <cedric.connes@gmail.com>
+
+pkgname=chkit
+pkgver=2.1.5
+pkgrel=1
+pkgdesc="The Containerum CLI"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://containerum.com/documentation"
+license=('MIT')
+source=("https://github.com/containerum/chkit/raw/$pkgver/LICENSE")
+source_i686=("https://github.com/containerum/chkit/releases/download/$pkgver/chkit_linux_x86_v$pkgver.tar.gz")
+source_x86_64=("https://github.com/containerum/chkit/releases/download/$pkgver/chkit_linux_x64_v$pkgver.tar.gz")
+source_arm=("https://github.com/containerum/chkit/releases/download/$pkgver/chkit_linux_arm_v$pkgver.tar.gz")
+source_armv6h=("https://github.com/containerum/chkit/releases/download/$pkgver/chkit_linux_arm_v$pkgver.tar.gz")
+source_armv7h=("https://github.com/containerum/chkit/releases/download/$pkgver/chkit_linux_arm_v$pkgver.tar.gz")
+source_aarch64=("https://github.com/containerum/chkit/releases/download/$pkgver/chkit_linux_arm_v$pkgver.tar.gz")
+md5sums=('bfa4ddd8612478bdf362161209972c9b')
+md5sums_i686=('43c014f6ea407491831418c482fe58d7')
+md5sums_x86_64=('6c91816a28252f8ac2d7854906eb27af')
+md5sums_arm=('78aa5c144494568f0afb421598d4b823')
+md5sums_armv6h=('78aa5c144494568f0afb421598d4b823')
+md5sums_armv7h=('78aa5c144494568f0afb421598d4b823')
+md5sums_aarch64=('78aa5c144494568f0afb421598d4b823')
+
+package() {
+ install -D -m755 chkit "$pkgdir/usr/bin/chkit"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}