summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-24 10:10:22 +1300
committercaltlgin2020-10-24 10:10:22 +1300
commit5db40c5d502b7f669f2820d329bc85db070999e3 (patch)
treeef39eb01f3084d8b97a41ddf0dce3f5b5aba6ccf
downloadaur-5db40c5d502b7f669f2820d329bc85db070999e3.tar.gz
Add to AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbdfe4f6fc04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = chkservice-git
+ pkgdesc = Systemd units manager with ncurses terminal interface
+ pkgver = 0.3.r1.gea40b14
+ pkgrel = 1
+ url = https://github.com/linuxenko/chkservice
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ depends = libsystemd
+ provides = chkservice
+ conflicts = chkservice
+ source = git+https://github.com/linuxenko/chkservice.git
+ sha256sums = SKIP
+
+pkgname = chkservice-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4576023e3a58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='chkservice'
+pkgname="${_pkgname,,}-git"
+pkgver=0.3.r1.gea40b14
+pkgrel=1
+pkgdesc='Systemd units manager with ncurses terminal interface'
+arch=('x86_64')
+url='https://github.com/linuxenko/chkservice'
+license=('GPL3')
+depends=('libsystemd')
+makedepends=('cmake' 'git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B 'build' -S "${_pkgname}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C 'build'
+}
+
+package() {
+ make DESTDIR="${pkgdir}" PREFIX='/usr' -C 'build' install
+ install -Dvm644 "${_pkgname}/README.md" -t "${pkgdir}/usr/share/doc/${_pkgname}"
+}
+
+# vim: ts=2 sw=2 et: