summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchaca2019-10-28 22:24:33 +0400
committerchaca2019-10-28 22:24:33 +0400
commit1b16f91ba79d3b5c85618cb37c0b1acf7cacf0b9 (patch)
tree66541db5394abc7069db925731ac3135264bacb5
parentbbc70fa7ae4e25da249f6d199e40a288ed9c6f15 (diff)
downloadaur-1b16f91ba79d3b5c85618cb37c0b1acf7cacf0b9.tar.gz
update to go-pie and names
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efc90164782c..62ba9e007c89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = chksum-git
license = Apache
makedepends = git
makedepends = go-pie
+ provides = chksum
conflicts = chksum
source = git+https://gitlab.com/chacas0/chksum#branch=master
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 951869d518bd..2360ab6eecb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,6 +6,7 @@ pkgdesc='Check and compare easily the checksum of a file.'
arch=('x86_64')
url="https://gitlab.com/ChacaS0/chksum"
license=('Apache')
+provides=("chksum")
conflicts=("chksum")
makedepends=('git' 'go-pie')
source=("git+https://gitlab.com/chacas0/chksum#branch=master")
@@ -21,6 +22,6 @@ build() {
package() {
cd "$srcdir/$pkgname"
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/chksum"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "${pkgname%-bin-git}" "$pkgdir/usr/bin/chksum"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-bin-git}/LICENSE"
}