summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel T. Borelli2019-05-27 17:26:40 -0300
committerDaniel T. Borelli2019-05-27 17:26:40 -0300
commite4a2051fce9ac828a95c20006c4bdbfb5f34641d (patch)
treed034a3a27a253650b60d1b144deadfed4324cd16
downloadaur-e4a2051fce9ac828a95c20006c4bdbfb5f34641d.tar.gz
First commit.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD36
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71f19ad0f898
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = chkuuid
+ pkgdesc = Compare the UUID of each partition with those found in FSTAB.
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/daltomi/chkuuid
+ arch = x86_64
+ license = GPL3
+ depends = udev
+ depends = libutil-linux
+ conflicts = chkuuid-git
+ source = https://github.com/daltomi/chkuuid/releases/download/v1.1/chkuuid-git-1.1-1-x86_64.pkg.tar.xz
+ source = https://github.com/daltomi/chkuuid/releases/download/v1.1/chkuuid-git-1.1-1-x86_64.pkg.tar.xz.sig
+ validpgpkeys = 51479755D90A2AACFA90A6551DD242462908D08B
+ sha256sums = 5916bc4232315e0747bf39d97f81093d9df38b39638122cf862e33a3bdbef756
+ sha256sums = SKIP
+
+pkgname = chkuuid
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cbc9d47f0996
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.xz
+*.xz.sig
+pkg
+src
+clean.sh
+checksum.sh
+*.part
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9116fc172643
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Daniel T. Borelli < danieltborelli@gmail.com>
+
+pkgbase=chkuuid
+pkgname=$pkgbase
+pkgver=1.1
+pkgrel=1
+_remotepkgbase=$pkgbase-git
+_remotepkgrel=1
+_gitname=chkuuid
+_gittag="v${pkgver}"
+
+pkgdesc="Compare the UUID of each partition with those found in FSTAB."
+
+arch=('x86_64')
+
+conflicts=('chkuuid-git')
+
+url="https://github.com/daltomi/$_gitname"
+
+license=('GPL3')
+
+depends=('udev' 'libutil-linux')
+
+source=("$url/releases/download/v$pkgver/$_remotepkgbase-$pkgver-$_remotepkgrel-x86_64.pkg.tar.xz"{,.sig})
+
+sha256sums=('5916bc4232315e0747bf39d97f81093d9df38b39638122cf862e33a3bdbef756'
+ 'SKIP'
+ )
+
+validpgpkeys=('51479755D90A2AACFA90A6551DD242462908D08B')
+
+package() {
+ install -Dm755 "$srcdir/usr/bin/chkuuid" "$pkgdir/usr/bin/chkuuid"
+}
+
+# vim: set ts=8 sw=8 tw=500 et :