summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2019-09-16 17:23:08 -0700
committerMike Swanson2019-09-16 17:23:08 -0700
commitd8f3d40e702246d4ccca5303965a5b712aebe20c (patch)
tree05d37b093c37bb8940f49630c7129f014db16ac2
parent3071dee8b6c4d4ffe90a090fdf5ce4ec8c05b9d7 (diff)
downloadaur-d8f3d40e702246d4ccca5303965a5b712aebe20c.tar.gz
Merge package into non-split one
-rw-r--r--.SRCINFO55
-rw-r--r--PKGBUILD127
2 files changed, 35 insertions, 147 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ece8819daf10..c4679f53acc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
-# Generated by mksrcinfo v8
-# Thu Oct 25 19:43:20 UTC 2018
pkgbase = chocolate-doom
pkgdesc = Historically-accurate Doom, Heretic, Hexen, and Strife ports.
pkgver = 3.0.0
- pkgrel = 3
+ pkgrel = 4
url = http://www.chocolate-doom.org/
+ install = chocolate-doom.install
arch = i686
arch = x86_64
license = GPL2
@@ -13,50 +12,24 @@ pkgbase = chocolate-doom
depends = libsamplerate
depends = sdl2_mixer
depends = sdl2_net
+ optdepends = freedm: Free deathmatch game
+ optdepends = freedoom1: Free Ultimate Doom-compatible game
+ optdepends = freedoom2: Free Doom II-compatible game
+ conflicts = chocolate-common
+ conflicts = chocolate-heretic
+ conflicts = chocolate-hexen
+ conflicts = chocolate-strife
+ replaces = chocolate-common
+ replaces = chocolate-heretic
+ replaces = chocolate-hexen
+ replaces = chocolate-strife
source = https://www.chocolate-doom.org/downloads/3.0.0/chocolate-doom-3.0.0.tar.gz
source = https://www.chocolate-doom.org/downloads/3.0.0/chocolate-doom-3.0.0.tar.gz.asc
source = 0001_fix-bash-completion.patch
+ validpgpkeys = 6D2C117E0310664497AA9546F6C2EE9C23354344
sha512sums = 41f235c0d84ef21070636ad0610e97898dfd366fae7f9244bd2aebf8974db98dcf55f70bcab2f93589b9bf31dd421db32e8af88e0f8e0a655d2b9f1d4ead2afd
sha512sums = SKIP
sha512sums = 5da61fcabd332698b3a8934670195d42f9d9db949fd666c3a670c47252af0376cf8cd0e3f2d78c9d6593446d68dab02b3db14b995a9fa8c973859cd2fd8bc3d0
pkgname = chocolate-doom
- pkgdesc = Doom port accurately reproducing the original DOS EXEs.
- depends = libpng
- depends = libsamplerate
- depends = sdl2_mixer
- depends = sdl2_net
- depends = chocolate-common
- optdepends = freedm: Free deathmatch game
- optdepends = freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)
- optdepends = freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)
-
-pkgname = chocolate-heretic
- pkgdesc = Heretic port accurately reproducing the original DOS EXEs.
- depends = libpng
- depends = libsamplerate
- depends = sdl2_mixer
- depends = sdl2_net
- depends = chocolate-common
- optdepends = blasphemer: Free Heretic-compatible game
-
-pkgname = chocolate-hexen
- pkgdesc = Hexen port accurately reproducing the original DOS EXEs.
- depends = libpng
- depends = libsamplerate
- depends = sdl2_mixer
- depends = sdl2_net
- depends = chocolate-common
-
-pkgname = chocolate-strife
- pkgdesc = Strife port accurately reproducing the original DOS EXEs.
- depends = libpng
- depends = libsamplerate
- depends = sdl2_mixer
- depends = sdl2_net
- depends = chocolate-common
-
-pkgname = chocolate-common
- pkgdesc = Files shared in common with Chocolate Doom-based games.
- install = chocolate-doom.install
diff --git a/PKGBUILD b/PKGBUILD
index 36a5321089c4..1a421aa7d6b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,24 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
-pkgname=(chocolate-{doom,heretic,hexen,strife,common})
-pkgbase=${pkgname[0]}
+pkgname=chocolate-doom
pkgdesc="Historically-accurate Doom, Heretic, Hexen, and Strife ports."
pkgver=3.0.0
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64')
url="http://www.chocolate-doom.org/"
license=('GPL2')
+install=chocolate-doom.install
depends=('libpng' 'libsamplerate' 'sdl2_mixer' 'sdl2_net')
makedepends=('python')
-source=(https://www.chocolate-doom.org/downloads/${pkgver}/${pkgbase}-${pkgver}.tar.gz{,.asc}
+optdepends=('freedm: Free deathmatch game'
+ 'freedoom1: Free Ultimate Doom-compatible game'
+ 'freedoom2: Free Doom II-compatible game')
+conflicts=(chocolate-common
+ chocolate-heretic
+ chocolate-hexen
+ chocolate-strife)
+replaces=(${conflicts[@]})
+source=(https://www.chocolate-doom.org/downloads/${pkgver}/${pkgname}-${pkgver}.tar.gz{,.asc}
0001_fix-bash-completion.patch)
sha512sums=('41f235c0d84ef21070636ad0610e97898dfd366fae7f9244bd2aebf8974db98dcf55f70bcab2f93589b9bf31dd421db32e8af88e0f8e0a655d2b9f1d4ead2afd'
'SKIP'
@@ -36,110 +44,17 @@ build() {
make
}
-package_chocolate-common() {
- pkgdesc="Files shared in common with Chocolate Doom-based games."
- install=chocolate-doom.install
-
- cd "${pkgbase}-${pkgver}"
- make DESTDIR="${pkgdir}" install
- install -dm 755 "${pkgdir}"/usr/share/games/doom
-
- cd "${pkgdir}"/usr/bin
- mv chocolate-doom-setup chocolate-setup
- rm -f chocolate-{doom,heretic,hexen,strife}{,-setup}
-
- cd "${pkgdir}"/usr/share
- rm -rf bash-completion doc man/man5
- rm -rf applications/chocolate-{doom,heretic,hexen,strife}.desktop \
- applications/screensavers
- rm -rf appdata
- cd man/man6
- rm -f chocolate-{doom,heretic,hexen,strife}{,-setup}.6
-}
-
-package_chocolate-doom() {
- pkgdesc="Doom port accurately reproducing the original DOS EXEs."
- depends=(${depends[@]} 'chocolate-common')
- optdepends=('freedm: Free deathmatch game'
- 'freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)'
- 'freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)')
-
+package() {
cd "${pkgbase}-${pkgver}"
- make DESTDIR="${pkgdir}" install
-
- cd "${pkgdir}"/usr/bin
- rm -f chocolate-{heretic,hexen,strife,server} chocolate*setup
- ln -s chocolate{,-doom}-setup
-
- cd "${pkgdir}"/usr/share
- rm -rf doc/chocolate-{heretic,hexen,strife}
- rm -rf applications/chocolate-{setup,heretic,hexen,strife}.desktop icons
- rm -f appdata/chocolate-{heretic,hexen,strife}.appdata.xml
- rm -f bash-completion/completions/chocolate-{heretic,hexen,strife}
- rm -f man/man?/chocolate-{heretic,hexen,strife,setup,server}* \
- man/man5/{heretic,hexen,strife}.cfg*
-}
-
-package_chocolate-heretic() {
- pkgdesc="Heretic port accurately reproducing the original DOS EXEs."
- depends=(${depends[@]} 'chocolate-common')
- optdepends=('blasphemer: Free Heretic-compatible game')
- cd "${pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
+ install -dm 755 "${pkgdir}"/usr/share/games/doom
- cd "${pkgdir}"/usr/bin
- rm -f chocolate-{doom,hexen,strife,server} chocolate*setup
- ln -s chocolate{,-heretic}-setup
-
- cd "${pkgdir}"/usr/share
- rm -rf doc/chocolate-{doom,hexen,strife}
- rm -rf applications/chocolate-{setup,doom,hexen,strife}.desktop \
- applications/screensavers icons
- rm -f appdata/chocolate-{doom,hexen,strife}.appdata.xml
- rm -f bash-completion/completions/chocolate-{doom,hexen,strife}
- rm -f man/man?/chocolate-{doom,hexen,strife,setup,server}* \
- man/man5/{default,hexen,strife}.cfg*
-}
-
-package_chocolate-hexen() {
- pkgdesc="Hexen port accurately reproducing the original DOS EXEs."
- depends=(${depends[@]} 'chocolate-common')
-
- cd "${pkgbase}-${pkgver}"
- make DESTDIR="${pkgdir}" install
-
- cd "${pkgdir}"/usr/bin
- rm -f chocolate-{doom,heretic,strife,server} chocolate*setup
- ln -s chocolate{,-hexen}-setup
-
- cd "${pkgdir}"/usr/share
- rm -rf doc/chocolate-{doom,heretic,strife}
- rm -rf applications/chocolate-{setup,doom,heretic,strife}.desktop \
- applications/screensavers icons
- rm -f appdata/chocolate-{doom,heretic,strife}.appdata.xml
- rm -f bash-completion/completions/chocolate-{doom,heretic,strife}
- rm -f man/man?/chocolate-{doom,heretic,strife,setup,server}* \
- man/man5/{default,heretic,strife}.cfg*
-}
-
-package_chocolate-strife() {
- pkgdesc="Strife port accurately reproducing the original DOS EXEs."
- depends=(${depends[@]} 'chocolate-common')
-
- cd "${pkgbase}-${pkgver}"
- make DESTDIR="${pkgdir}" install
-
- cd "${pkgdir}"/usr/bin
- rm -f chocolate-{doom,heretic,hexen,server} chocolate*setup
- ln -s chocolate{,-strife}-setup
-
- cd "${pkgdir}"/usr/share
- rm -rf doc/chocolate-{doom,heretic,hexen}
- rm -rf applications/chocolate-{setup,doom,heretic,hexen}.desktop \
- applications/screensavers icons
- rm -f appdata/chocolate-{doom,heretic,hexen}.appdata.xml
- rm -f bash-completion/completions/chocolate-{doom,heretic,hexen}
- rm -f man/man?/chocolate-{doom,heretic,hexen,setup,server}* \
- man/man5/{default,heretic,hexen}.cfg*
+ # dedup all the *setup programs, make desktop file work
+ rm "${pkgdir}"/usr/bin/chocolate-{heretic,hexen,strife}-setup
+ mv "${pkgdir}"/usr/bin/chocolate-doom-setup "${pkgdir}"/usr/bin/chocolate-setup
+ ln -s chocolate-setup "${pkgdir}"/usr/bin/chocolate-doom-setup
+ ln -s chocolate-setup "${pkgdir}"/usr/bin/chocolate-heretic-setup
+ ln -s chocolate-setup "${pkgdir}"/usr/bin/chocolate-hexen-setup
+ ln -s chocolate-setup "${pkgdir}"/usr/bin/chocolate-strife-setup
}