summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2014-06-04 17:27:33 -0700
committerMike Swanson2014-06-04 17:27:33 -0700
commit25ed8b30b4a8711a09182c13a22f44f73472bd15 (patch)
treefd38eea53d4e3659d35d3d6aa7c0d90b51c1e676
parent0b010bdc982990836cbb417151481979d6029a53 (diff)
downloadaur-25ed8b30b4a8711a09182c13a22f44f73472bd15.tar.gz
reorder the PKGBUILD fields for cleanliness
Now that the AUR demands uploads made via mkaurball, the metadata info is contained as part of the package itself. The AUR is no longer trying to parse potentially-complicated shell scripts and I no longer need to outsmart it.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10d98aa7af5f..70b01cfb4c5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chocolate-doom-git
- pkgdesc = Doom, Heretic, Hexen, Strife port accurately reproducing the originals.
- pkgver = 2.0.0.178.g1591773
+ pkgdesc = Historically-accurate Doom, Heretic, Hexen, and Strife ports.
+ pkgver = 2.0.0.184.gea6bc74
pkgrel = 1
url = http://www.chocolate-doom.org/
install = chocolate-doom.install
@@ -25,7 +25,7 @@ pkgname = chocolate-doom-git
conflicts = chocolate-doom
pkgname = chocolate-heretic-git
- pkgdesc = Heretic port accurately reproducing the original DOS EXE.
+ pkgdesc = Heretic port accurately reproducing the original DOS EXEs.
depends = libsamplerate
depends = sdl_mixer
depends = sdl_net
@@ -33,7 +33,7 @@ pkgname = chocolate-heretic-git
conflicts = chocolate-heretic
pkgname = chocolate-hexen-git
- pkgdesc = Hexen port accurately reproducing the original DOS EXE.
+ pkgdesc = Hexen port accurately reproducing the original DOS EXEs.
depends = libsamplerate
depends = sdl_mixer
depends = sdl_net
diff --git a/PKGBUILD b/PKGBUILD
index 3382d86891e2..672adb413055 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
-pkgname=chocolate-doom-git
-_pkgname=${pkgname/-git/}
-true && pkgname=(chocolate-{doom,heretic,hexen,strife,common}-git)
-pkgver=2.0.0.178.g1591773
+pkgname=(chocolate-{doom,heretic,hexen,strife,common}-git)
+_pkgname=${pkgname[0]/-git/}
+pkgver=2.0.0.184.gea6bc74
pkgrel=1
+pkgdesc="Historically-accurate Doom, Heretic, Hexen, and Strife ports."
arch=('i686' 'x86_64')
url="http://www.chocolate-doom.org/"
license=('GPL2')
+depends=('libsamplerate' 'sdl_mixer' 'sdl_net')
makedepends=('git' 'autoconf' 'python')
install=${_pkgname}.install
source=(git+https://github.com/chocolate-doom/chocolate-doom.git)
@@ -72,7 +73,7 @@ package_chocolate-doom-git() {
}
package_chocolate-heretic-git() {
- pkgdesc="Heretic port accurately reproducing the original DOS EXE."
+ pkgdesc="Heretic port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'chocolate-common-git')
conflicts=(chocolate-heretic)
@@ -91,7 +92,7 @@ package_chocolate-heretic-git() {
}
package_chocolate-hexen-git() {
- pkgdesc="Hexen port accurately reproducing the original DOS EXE."
+ pkgdesc="Hexen port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'chocolate-common-git')
conflicts=(chocolate-hexen)
@@ -127,6 +128,3 @@ package_chocolate-strife-git() {
rm -f man/man?/chocolate-{doom,heretic,hexen,setup,server}* \
man/man5/{default,heretic,hexen}.cfg*
}
-
-pkgdesc="Doom, Heretic, Hexen, Strife port accurately reproducing the originals."
-depends=('libsamplerate' 'sdl_mixer' 'sdl_net')