summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2014-10-21 23:39:43 -0700
committerMike Swanson2014-10-21 23:39:43 -0700
commit39f434c75d477e15b2420177c8646bccd2d8ea5c (patch)
tree71e11ad1b2e75669323a6708a9ee3107f13b0fc4
parent1b649e661e2ea267e60e35d4cebf907d6fd78c66 (diff)
downloadaur-39f434c75d477e15b2420177c8646bccd2d8ea5c.tar.gz
Update for 2.1.0, add new optdepends
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--chocolate-doom.install7
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 287a04e665d5..04e61dc1c58e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chocolate-doom-git
pkgdesc = Historically-accurate Doom, Heretic, Hexen, and Strife ports.
- pkgver = 2.0.0.189.ga2c75d2
+ pkgver = 2.1.0
pkgrel = 1
url = http://www.chocolate-doom.org/
install = chocolate-doom.install
@@ -22,6 +22,9 @@ pkgname = chocolate-doom-git
depends = sdl_mixer
depends = sdl_net
depends = chocolate-common-git
+ optdepends = freedm: Free deathmatch game
+ optdepends = freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)
+ optdepends = freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)
conflicts = chocolate-doom
pkgname = chocolate-heretic-git
@@ -30,6 +33,7 @@ pkgname = chocolate-heretic-git
depends = sdl_mixer
depends = sdl_net
depends = chocolate-common-git
+ optdepends = blasphemer: Free Heretic-compatible game
conflicts = chocolate-heretic
pkgname = chocolate-hexen-git
diff --git a/PKGBUILD b/PKGBUILD
index 175e6f343821..96797a2ec5cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=(chocolate-{doom,heretic,hexen,strife,common}-git)
_pkgname=${pkgname[0]/-git/}
-pkgver=2.0.0.189.ga2c75d2
-pkgrel=1
pkgdesc="Historically-accurate Doom, Heretic, Hexen, and Strife ports."
+pkgver=2.1.0
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.chocolate-doom.org/"
license=('GPL2')
depends=('libsamplerate' 'sdl_mixer' 'sdl_net')
makedepends=('git' 'autoconf' 'python')
-install=${_pkgname}.install
+install=chocolate-doom.install
source=(git+https://github.com/chocolate-doom/chocolate-doom.git)
sha256sums=('SKIP')
@@ -56,6 +56,9 @@ package_chocolate-common-git() {
package_chocolate-doom-git() {
pkgdesc="Doom port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'chocolate-common-git')
+ optdepends=('freedm: Free deathmatch game'
+ 'freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)'
+ 'freedoom2: Free Doom II/Final Doom-compatible game (not vanilla compatible, but useful for mods)')
conflicts=(chocolate-doom)
cd "${_pkgname}"
@@ -75,6 +78,7 @@ package_chocolate-doom-git() {
package_chocolate-heretic-git() {
pkgdesc="Heretic port accurately reproducing the original DOS EXEs."
depends=(${depends[@]} 'chocolate-common-git')
+ optdepends=('blasphemer: Free Heretic-compatible game')
conflicts=(chocolate-heretic)
cd "${_pkgname}"
diff --git a/chocolate-doom.install b/chocolate-doom.install
index 0a95a48c7861..5a701f56e333 100644
--- a/chocolate-doom.install
+++ b/chocolate-doom.install
@@ -1,3 +1,8 @@
post_install() {
- echo "Copy any IWAD files to the global default /usr/share/games/doom"
+ echo "Install IWADs into /usr/share/games/doom or /usr/local/share/games/doom"
+ echo ""
+ echo "Files such as doom2.wad, heretic.wad, hexen.wad, strife1.wad"
+ echo "are IWADs appropriate for installation and usage with Chocolate"
+ echo "engines. These must be lower-case file names unless using a"
+ echo "case-insensitive file system."
}