summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2013-12-20 05:43:19 -0800
committerMike Swanson2013-12-20 05:43:19 -0800
commitc08f8e8dd7587bb67d26c18e03f1053c13517c8b (patch)
tree47c89c49ed961041e8a4141a329ffd4ab7ddd262
parente8a85ba6906b510961327b05cbfba8e06e0b8e28 (diff)
downloadaur-c08f8e8dd7587bb67d26c18e03f1053c13517c8b.tar.gz
Update chocolate-doom-git with main PKGBUILD.
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD104
-rw-r--r--chocolate-doom.install2
3 files changed, 134 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94bc09136a97..3042dbb87f7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chocolate-doom-git
pkgdesc = Doom, Heretic, Hexen, Strife port accurately reproducing the originals.
- pkgver = 2.0.0
+ pkgver = 2.0.0.5.gb9690ac
pkgrel = 1
url = http://www.chocolate-doom.org/
install = chocolate-doom.install
@@ -10,12 +10,46 @@ pkgbase = chocolate-doom-git
makedepends = git
makedepends = autoconf
makedepends = python
- depends = sdl
+ depends = libsamplerate
depends = sdl_mixer
depends = sdl_net
conflicts = chocolate-doom
- source = git://github.com/fragglet/chocolate-doom.git
+ conflicts = chocolate-heretic
+ conflicts = chocolate-hexen
+ conflicts = chocolate-strife
+ conflicts = chocolate-common
+ source = git://github.com/chocolate-doom/chocolate-doom.git
sha256sums = SKIP
pkgname = chocolate-doom-git
+ pkgdesc = Doom port accurately reproducing the original v1.9 EXEs.
+ depends = libsamplerate
+ depends = sdl_mixer
+ depends = sdl_net
+ depends = chocolate-common-git
+
+pkgname = chocolate-heretic-git
+ pkgdesc = Heretic port accurately reproducing the original v1.3 EXE.
+ depends = libsamplerate
+ depends = sdl_mixer
+ depends = sdl_net
+ depends = chocolate-common-git
+
+pkgname = chocolate-hexen-git
+ pkgdesc = Hexen port accurately reproducing the original v1.1 EXE.
+ depends = libsamplerate
+ depends = sdl_mixer
+ depends = sdl_net
+ depends = chocolate-common-git
+
+pkgname = chocolate-strife-git
+ pkgdesc = Strife port accurately reproducing the original v1.31 EXE.
+ depends = libsamplerate
+ depends = sdl_mixer
+ depends = sdl_net
+ depends = chocolate-common-git
+
+pkgname = chocolate-common-git
+ pkgdesc = Files shared in common with Chocolate Doom-based games.
+ depends = sdl_net
diff --git a/PKGBUILD b/PKGBUILD
index 13e342ae79c3..6eb79964056f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,16 @@
pkgname=chocolate-doom-git
_pkgname=${pkgname/-git/}
-pkgver=2.0.0
+true && pkgname=(chocolate-{doom,heretic,hexen,strife,common}-git)
+pkgver=2.0.0.5.gb9690ac
pkgrel=1
-pkgdesc="Doom, Heretic, Hexen, Strife port accurately reproducing the originals."
arch=('i686' 'x86_64')
url="http://www.chocolate-doom.org/"
license=('GPL2')
-depends=('sdl' 'sdl_mixer' 'sdl_net')
makedepends=('git' 'autoconf' 'python')
-conflicts=(${_pkgname})
-install=${pkgname/-git/}.install
-source=(git://github.com/fragglet/chocolate-doom.git)
+conflicts=(${pkgname[@]/-git/})
+install=${_pkgname}.install
+source=(git://github.com/chocolate-doom/chocolate-doom.git)
sha256sums=('SKIP')
pkgver() {
@@ -33,8 +32,97 @@ build() {
make
}
-package() {
+package_chocolate-common-git() {
+ pkgdesc="Files shared in common with Chocolate Doom-based games."
+ depends=('sdl_net')
+
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+ install -dm 755 "${pkgdir}"/usr/share/games/doom
+
+ cd "${pkgdir}"/usr/bin
+ mv chocolate-doom-setup chocolate-setup
+ rm -f chocolate-{doom,heretic,hexen,strife}{,-setup}
+
+ cd "${pkgdir}"/usr/share
+ rm -rf doc man/man5
+ rm -rf applications/chocolate-doom.desktop applications/screensavers \
+ icons/chocolate-doom.png
+ cd man/man6
+ rm -f chocolate-{doom,heretic,hexen,strife}.6
+}
+
+package_chocolate-doom-git() {
+ pkgdesc="Doom port accurately reproducing the original v1.9 EXEs."
+ depends=(${depends[@]} 'chocolate-common-git')
+
cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+
+ cd "${pkgdir}"/usr/bin
+ rm -f chocolate-{heretic,hexen,strife,server} chocolate*setup
+ ln -s chocolate{,-doom}-setup
+
+ cd "${pkgdir}"/usr/share
+ rm -rf doc/chocolate-{heretic,hexen,strife}
+ rm -f applications/chocolate-setup.desktop icons/chocolate-setup.png
+ rm -f man/man?/chocolate-{heretic,hexen,strife,setup,server}* \
+ man/man5/{heretic,hexen,strife}.cfg*
+}
+
+package_chocolate-heretic-git() {
+ pkgdesc="Heretic port accurately reproducing the original v1.3 EXE."
+ depends=(${depends[@]} 'chocolate-common-git')
+
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+
+ cd "${pkgdir}"/usr/bin
+ rm -f chocolate-{doom,hexen,strife,server} chocolate*setup
+ ln -s chocolate{,-heretic}-setup
- make DESTDIR="$pkgdir" install
+ cd "${pkgdir}"/usr/share
+ rm -rf doc/chocolate-{doom,hexen,strife}
+ rm -rf applications icons
+ rm -f man/man?/chocolate-{doom,hexen,strife,setup,server}* \
+ man/man5/{default,hexen,strife}.cfg*
}
+
+package_chocolate-hexen-git() {
+ pkgdesc="Hexen port accurately reproducing the original v1.1 EXE."
+ depends=(${depends[@]} 'chocolate-common-git')
+
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+
+ cd "${pkgdir}"/usr/bin
+ rm -f chocolate-{doom,heretic,strife,server} chocolate*setup
+ ln -s chocolate{,-hexen}-setup
+
+ cd "${pkgdir}"/usr/share
+ rm -rf doc/chocolate-{doom,heretic,strife}
+ rm -rf applications icons
+ rm -f man/man?/chocolate-{doom,heretic,strife,setup,server}* \
+ man/man5/{default,heretic,strife}.cfg*
+}
+
+package_chocolate-strife-git() {
+ pkgdesc="Strife port accurately reproducing the original v1.31 EXE."
+ depends=(${depends[@]} 'chocolate-common-git')
+
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+
+ cd "${pkgdir}"/usr/bin
+ rm -f chocolate-{doom,heretic,hexen,server} chocolate*setup
+ ln -s chocolate{,-strife}-setup
+
+ cd "${pkgdir}"/usr/share
+ rm -rf doc/chocolate-{doom,heretic,hexen}
+ rm -rf applications icons
+ rm -f man/man?/chocolate-{doom,heretic,hexen,setup,server}* \
+ man/man5/{default,heretic,hexen}.cfg*
+}
+
+pkgdesc="Doom, Heretic, Hexen, Strife port accurately reproducing the originals."
+depends=('libsamplerate' 'sdl_mixer' 'sdl_net')
diff --git a/chocolate-doom.install b/chocolate-doom.install
index 7faa3b09ad9f..0a95a48c7861 100644
--- a/chocolate-doom.install
+++ b/chocolate-doom.install
@@ -1,3 +1,3 @@
post_install() {
- echo ":: Copy any IWAD files to /usr/share/games/doom"
+ echo "Copy any IWAD files to the global default /usr/share/games/doom"
}