summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornyxkn2022-03-12 20:05:24 +0000
committernyxkn2022-03-12 21:05:28 +0000
commitb575a25383db51c80f2c9c33c776f03844ee3b0f (patch)
tree6e3d8fd8591680419cfe3bea3e9b9bc28d2c835d
downloadaur-b575a25383db51c80f2c9c33c776f03844ee3b0f.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD21
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cbe7461991e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = chowtapemodel-bin
+ pkgdesc = Physical modelling signal processing for analog tape recording
+ pkgver = 2.10.0
+ pkgrel = 1
+ url = https://chowdsp.com/
+ arch = x86_64
+ groups = vst3-plugins
+ groups = lv2-plugins
+ groups = pro-audio
+ license = GPL3
+ depends = libglvnd
+ depends = freetype2
+ depends = alsa-lib
+ conflicts = chowtapemodel-vst3-git
+ conflicts = chowtapemodel-lv2-git
+ conflicts = chowtapemodel-jack-git
+ conflicts = chowtapemodel-lv2.git
+ source = https://github.com/jatinchowdhury18/AnalogTapeModel/releases/download/v2.10.0/ChowTapeModel-Linux-x64-2.10.0.deb
+ sha256sums = 3f1a3f9a58ec341a42daeed927f541c3c41551aee81c00ca118670f448bc3328
+
+pkgname = chowtapemodel-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04fee6861575
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: nyxkn <dev@nyxkn.net>
+pkgname=chowtapemodel-bin
+pkgdesc="Physical modelling signal processing for analog tape recording"
+pkgver=2.10.0
+pkgrel=1
+arch=('x86_64')
+url="https://chowdsp.com/"
+license=('GPL3')
+groups=('vst3-plugins' 'lv2-plugins' 'pro-audio')
+conflicts=('chowtapemodel-vst3-git' 'chowtapemodel-lv2-git' 'chowtapemodel-jack-git' 'chowtapemodel-lv2.git')
+depends=('libglvnd' 'freetype2' 'alsa-lib')
+source=("https://github.com/jatinchowdhury18/AnalogTapeModel/releases/download/v$pkgver/ChowTapeModel-Linux-x64-$pkgver.deb")
+sha256sums=('3f1a3f9a58ec341a42daeed927f541c3c41551aee81c00ca118670f448bc3328')
+
+package() {
+ rm -rf usr data.tar.xz control.tar.xz debian-binary
+ ar x "ChowTapeModel-Linux-x64-$pkgver.deb"
+ tar xf data.tar.xz
+ cp -r usr "$pkgdir/"
+}
+