summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-08-27 00:36:55 +0100
committerMilk Brewster2020-08-27 00:36:55 +0100
commit77e62a78f7cd39c87ec5c83c1ed42ac06fb7289d (patch)
tree9ed446dbc999a8eb1eae455c0634b5fa0936a7b9
parent3164f8bd1c625e60b8754f0d130504fb2f6bed8e (diff)
downloadaur-77e62a78f7cd39c87ec5c83c1ed42ac06fb7289d.tar.gz
fix fix submodules
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09e7e850b4e7..2a08756fadfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,13 +4,17 @@ pkgbase = chowtapemodel.lv2-git
pkgrel = 1
url = https://github.com/jatinchowdhury18/AnalogTapeModel
arch = x86_64
+ groups = lv2plugins
license = GPL
+ depends = git
depends = alsa-lib
depends = libxcursor
depends = libxinerama
depends = libxrandr
depends = freeglut
depends = jack
+ provides = chowtapemodel.lv2
+ conflicts = chowtapemodel.lv2
source = chowtapemodel.lv2-git::git+https://github.com/jatinchowdhury18/AnalogTapeModel
source = git+https://github.com/jatinchowdhury18/JUCE.git
source = git+https://github.com/ffAudio/foleys_gui_magic.git
diff --git a/PKGBUILD b/PKGBUILD
index 37b09bf2a736..9374310a0214 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,17 @@ pkgname=chowtapemodel.lv2-git
pkgdesc="Physical modelling signal processing for analog tape recording."
pkgver=r114.6236290
pkgrel=1
-epoch=
arch=(x86_64)
url="https://github.com/jatinchowdhury18/AnalogTapeModel"
license=(GPL)
-groups=()
-depends=('alsa-lib' 'libxcursor' 'libxinerama' 'libxrandr' 'freeglut' 'jack')
+groups=(lv2plugins)
+conflicts=(chowtapemodel.lv2)
+provides=(chowtapemodel.lv2)
+depends=('git' 'alsa-lib' 'libxcursor' 'libxinerama' 'libxrandr' 'freeglut' 'jack')
makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
source=("$pkgname::git+https://github.com/jatinchowdhury18/AnalogTapeModel"
"git+https://github.com/jatinchowdhury18/JUCE.git"
"git+https://github.com/ffAudio/foleys_gui_magic.git")
-noextract=()
md5sums=('SKIP'
'SKIP'
'SKIP')
@@ -38,16 +29,20 @@ pkgver() {
prepare() {
cd "$pkgname"
+
rm -rf Plugin/Juce
- ln -s ../../JUCE Plugin/Juce
rm -rf Plugin/foleys_gui_magic
- ln -s ../../foleys_gui_magic Plugin/foleys_gui_magic
+ git submodule init
+ git config submodule.Plugin/Juce.url "${srcdir}"/JUCE
+ git config submodule.Plugin/foleys_gui_magic.url "${srcdir}"/foleys_gui_magic
+ git submodule sync --recursive
+ git submodule update
+
rm -rf Juce/VST2_SDK
}
build() {
- cd "$pkgname"
- cd Plugin/ && bash build_linux.sh
+ cd "$pkgname"/Plugin && bash build_linux.sh
}
package() {