summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbziemons2023-09-27 21:23:43 +0200
committerbziemons2023-09-27 21:23:43 +0200
commit0e8835bc7609b96933382055345f1a49917746e6 (patch)
treefcbddd2fa7f97018d493fe55ce48e58f4771f84f
parentcda18e10ac482d4a8010c72e539c21df1f6f2740 (diff)
downloadaur-0e8835bc7609b96933382055345f1a49917746e6.tar.gz
Add PKGBUILD patch for syntax highlighting
-rw-r--r--syntax-highlighting.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/syntax-highlighting.patch b/syntax-highlighting.patch
new file mode 100644
index 000000000000..07b29782881f
--- /dev/null
+++ b/syntax-highlighting.patch
@@ -0,0 +1,22 @@
+diff --git a/PKGBUILD b/PKGBUILD
+index 4baa079..f767e54 100644
+--- a/PKGBUILD
++++ b/PKGBUILD
+@@ -6,7 +6,7 @@ pkgdesc="Console-based editor designed for simplified use like gedit"
+ arch=("x86_64")
+ url="https://github.com/istoph/editor"
+ license=('Boost')
+-depends=('tuiwidgets-git' 'qt5-base' 'icu' 'gcc-libs')
++depends=('tuiwidgets-git' 'qt5-base' 'icu' 'gcc-libs' 'syntax-highlighting')
+ makedepends=(meson git)
+ provides=(chr-editor)
+ conflicts=(chr-editor)
+@@ -27,7 +27,7 @@ prepare() {
+ }
+
+ build() {
+- arch-meson editor _build
++ arch-meson -D syntax_highlighting=true editor _build
+ meson compile -C _build
+ }
+