summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbziemons2023-02-23 01:16:21 +0100
committerbziemons2023-02-23 01:16:21 +0100
commit0f194faa575c91b396727b680c1dc0e841ce6505 (patch)
tree5d78a4b0ee8efe92cd61b0aed80a2806b35eb962
downloadaur-0f194faa575c91b396727b680c1dc0e841ce6505.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
-rw-r--r--meson-install.patch20
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eef22e5ca071
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = chr-editor-git
+ pkgdesc = Console-based editor designed for simplified use like gedit
+ pkgver = r492.cd6cac3
+ pkgrel = 1
+ url = https://github.com/istoph/editor
+ arch = x86_64
+ license = Boost
+ makedepends = meson
+ makedepends = git
+ depends = tuiwidgets-git
+ depends = qt5-base
+ depends = icu
+ depends = gcc-libs
+ provides = chr-editor
+ conflicts = chr-editor
+ options = !strip
+ source = git+https://github.com/istoph/editor.git
+ source = meson-install.patch
+ sha512sums = SKIP
+ sha512sums = 10f3b013970d7e82f885facd4d666251ed1f0df35ee50d746ff9c5c3a91db92fd43a60deac50e1c376291236a3798630923d81e880bb4aea2c50511ef06545dd
+
+pkgname = chr-editor-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3e0f22869cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: bziemons <ben@rs485.network>
+pkgname=chr-editor-git
+pkgver=r497.fbb59e3
+pkgrel=1
+pkgdesc="Console-based editor designed for simplified use like gedit"
+arch=("x86_64")
+url="https://github.com/istoph/editor"
+license=('Boost')
+depends=(tuiwidgets-git 'qt5-base' 'icu' 'gcc-libs')
+makedepends=(meson git)
+provides=(chr-editor)
+conflicts=(chr-editor)
+options=(!strip)
+source=("git+https://github.com/istoph/editor.git"
+ "meson-install.patch")
+sha512sums=('SKIP'
+ '10f3b013970d7e82f885facd4d666251ed1f0df35ee50d746ff9c5c3a91db92fd43a60deac50e1c376291236a3798630923d81e880bb4aea2c50511ef06545dd')
+
+pkgver() {
+ cd "editor"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "editor"
+ patch --forward --strip=1 --input="${srcdir}/meson-install.patch"
+}
+
+build() {
+ meson setup --prefix /usr --buildtype=plain --wrap-mode nodownload -Db_lot=true -Db_pie=true -Ddefault_library=static editor _build
+ meson compile -C _build
+
+ # install manpages
+}
+
+check() {
+ meson test -C _build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C _build
+ install -d "${pkgdir}/usr/share/man/man1/"
+ install -pm 644 "${srcdir}/editor/manpages/"* "${pkgdir}/usr/share/man/man1"
+}
diff --git a/meson-install.patch b/meson-install.patch
new file mode 100644
index 000000000000..a26281e46350
--- /dev/null
+++ b/meson-install.patch
@@ -0,0 +1,20 @@
+diff --git a/src/meson.build b/src/meson.build
+index c809a0f..229688e 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -81,10 +81,12 @@ editor_lib = static_library('editor', editor_sources,
+ include_directories: include_directories('.'),
+ dependencies : [qt5_dep, tuiwidgets_dep, posixsignalmanager_dep])
+
+-executable('editor', main,
++executable('chr', main,
+ include_directories: include_directories('.'),
+ link_with: editor_lib,
+- dependencies : [qt5_dep, tuiwidgets_dep, posixsignalmanager_dep])
++ dependencies : [qt5_dep, tuiwidgets_dep, posixsignalmanager_dep],
++ install: true,
++ install_dir: '/usr/bin/')
+
+ executable('tests', tests,
+ qt5.preprocess(moc_headers: tests_headers, moc_sources: tests,
+