summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbziemons2023-03-08 23:51:44 +0100
committerbziemons2023-03-08 23:51:44 +0100
commit6d48a20635f7b7fd71e7e77cba192517cc045875 (patch)
tree583ff6cd4b3b9e18ebf1266838da5509eb3ac293
parent0f194faa575c91b396727b680c1dc0e841ce6505 (diff)
downloadaur-6d48a20635f7b7fd71e7e77cba192517cc045875.tar.gz
Update PKGBUILD, build with defaults
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eef22e5ca071..14274722105c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chr-editor-git
pkgdesc = Console-based editor designed for simplified use like gedit
- pkgver = r492.cd6cac3
+ pkgver = r519.5b7fbe5
pkgrel = 1
url = https://github.com/istoph/editor
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = chr-editor-git
depends = gcc-libs
provides = chr-editor
conflicts = chr-editor
- options = !strip
+ options = strip
source = git+https://github.com/istoph/editor.git
source = meson-install.patch
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e3e0f22869cd..6eb6fa220d03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: bziemons <ben@rs485.network>
pkgname=chr-editor-git
-pkgver=r497.fbb59e3
+pkgver=r519.5b7fbe5
pkgrel=1
pkgdesc="Console-based editor designed for simplified use like gedit"
arch=("x86_64")
url="https://github.com/istoph/editor"
license=('Boost')
-depends=(tuiwidgets-git 'qt5-base' 'icu' 'gcc-libs')
+depends=('tuiwidgets-git' 'qt5-base' 'icu' 'gcc-libs')
makedepends=(meson git)
provides=(chr-editor)
conflicts=(chr-editor)
-options=(!strip)
+options=(strip)
source=("git+https://github.com/istoph/editor.git"
"meson-install.patch")
sha512sums=('SKIP'
@@ -27,10 +27,8 @@ prepare() {
}
build() {
- meson setup --prefix /usr --buildtype=plain --wrap-mode nodownload -Db_lot=true -Db_pie=true -Ddefault_library=static editor _build
+ arch-meson editor _build
meson compile -C _build
-
- # install manpages
}
check() {
@@ -39,6 +37,8 @@ check() {
package() {
DESTDIR="$pkgdir" meson install -C _build
+
+ # install manpages
install -d "${pkgdir}/usr/share/man/man1/"
install -pm 644 "${srcdir}/editor/manpages/"* "${pkgdir}/usr/share/man/man1"
}