summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-08 23:44:13 +0000
committerDaniel Bermond2018-11-08 23:44:13 +0000
commit3f623a27c63d9383f36e1abb67468cd997c4710d (patch)
treef46a7c740bcaae28c4c556a6796d8b60d829dac1
parent34c73fa11828bea886922dee534b0b75acb666c4 (diff)
downloadaur-3f623a27c63d9383f36e1abb67468cd997c4710d.tar.gz
Change license. Add tests.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4a869772dd9..dd118deee3a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = chromaprint-fftw
pkgdesc = Extracts fingerprints from any audio source (uses fftw for FFT calculations instead of ffmpeg)
pkgver = 1.4.3
- pkgrel = 2
+ pkgrel = 3
url = https://acoustid.org/chromaprint
arch = i686
arch = x86_64
- license = GPL
+ license = MIT
makedepends = cmake
depends = fftw
provides = chromaprint
diff --git a/PKGBUILD b/PKGBUILD
index c4652b190461..ccde7dedbb3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,13 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
-# NOTE:
-# If you want the fpcalc utility: add 'ffmpeg' to depends and change '-DBUILD_TOOLS' to 'ON'.
-# FFT calculations will still be made using FFTW3. libchromaprint.so will still be free of
-# ffmpeg libraries. But the fpcalc utility will be linked against ffmpeg libraries, so be
-# warned that this can cause some sort of circular dependency with ffmpeg if your ffmpeg
-# build has '--enable-chromaprint'.
-
_srcname='chromaprint'
pkgname=chromaprint-fftw
pkgver=1.4.3
-pkgrel=2
+pkgrel=3
pkgdesc='Extracts fingerprints from any audio source (uses fftw for FFT calculations instead of ffmpeg)'
arch=('i686' 'x86_64')
url='https://acoustid.org/chromaprint'
-license=('GPL')
+license=('MIT')
makedepends=('cmake')
depends=('fftw')
provides=('chromaprint')
@@ -22,13 +15,19 @@ conflicts=('chromaprint')
source=("${_srcname}-${pkgver}.tar.gz"::"https://github.com/acoustid/chromaprint/archive/v${pkgver}.tar.gz")
sha256sums=('d4ae6596283aad7a015a5b0445012054c634a4b9329ecb23000cd354b40a283b')
+prepare() {
+ cd "${_srcname}-${pkgver}"
+
+ sed -n '18,36p' LICENSE.md > LICENSE
+}
+
build() {
cd "${_srcname}-${pkgver}"
cmake \
-DBIN_INSTALL_DIR:PATH='/usr/bin' \
-DBUILD_SHARED_LIBS:BOOL='ON' \
- -DBUILD_TESTS:BOOL='OFF' \
+ -DBUILD_TESTS:BOOL='ON' \
-DBUILD_TOOLS:BOOL='OFF' \
-DCMAKE_BUILD_TYPE:STRING='Release' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
@@ -41,8 +40,16 @@ build() {
make
}
+check() {
+ cd "${_srcname}-${pkgver}"
+
+ make check
+}
+
package() {
cd "${_srcname}-${pkgver}"
make DESTDIR="$pkgdir" install
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
}