summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2016-12-06 18:00:40 -0200
committerDaniel Bermond2016-12-06 18:00:40 -0200
commitadf2f2795ae9ba5bbe45d56d884c7f6365ab98f9 (patch)
tree412d044f9379bd692c2c98bfb59b5de2a6411736
parent86b3695e3b70a16e20bc065154bdb59d0591765a (diff)
downloadaur-adf2f2795ae9ba5bbe45d56d884c7f6365ab98f9.tar.gz
Updated to version 1.4
This upstream version introduces some changes in CMake configuration options. Some notable ones: - Building examples is not available anymore. - Library for FFT calculations is selected by option 'FFT_LIB'. - fpcalc binary utility can be easily compiled using FFmpeg, while maintaining FFTW3 for FFT calculations in libchromaprint.so. For details and implications, see note in PKGBUILD file.
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD38
2 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e52fb67e465b..28a9449aadea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Oct 31 17:13:45 UTC 2016
+# Tue Dec 6 19:54:11 UTC 2016
pkgbase = chromaprint-fftw
pkgdesc = Extracts fingerprints from any audio source (uses fftw for FFT calculations instead of ffmpeg)
- pkgver = 1.3.2
+ pkgver = 1.4
pkgrel = 1
url = https://acoustid.org/chromaprint
arch = i686
@@ -14,8 +14,8 @@ pkgbase = chromaprint-fftw
provides = libchromaprint.so
conflicts = chromaprint
conflicts = chromaprint-git
- source = https://bitbucket.org/acoustid/chromaprint/downloads/chromaprint-1.3.2.tar.gz
- sha256sums = c3af900d8e7a42afd74315b51b79ebd2e43bc66630b4ba585a54bf3160439652
+ source = https://bitbucket.org/acoustid/chromaprint/downloads/chromaprint-1.4.tar.gz
+ sha256sums = 4b8ed053d99e35ca3543e41f581659307a705c677e1f7eded91f047a580cebe8
pkgname = chromaprint-fftw
diff --git a/PKGBUILD b/PKGBUILD
index 0a10eec5d840..2012a8afff14 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,15 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
-# Chromaprint (uses fftw for FFT calculations instead of ffmpeg)
+# NOTE:
+# If you want the fpcalc utility: add 'ffmpeg' to depends and change '-DBUILD_TOOLS' to 'ON'.
+# FFT calculations will still be made using FFTW3. libchromaprint.so will still be free of
+# ffmpeg libraries. But the fpcalc utility will be linked against ffmpeg libraries, so be
+# warned that this can cause some sort of circular dependency with ffmpeg if your ffmpeg
+# build has '--enable-chromaprint'.
_srcname="chromaprint"
pkgname=chromaprint-fftw
-pkgver=1.3.2
+pkgver=1.4
pkgrel=1
pkgdesc="Extracts fingerprints from any audio source (uses fftw for FFT calculations instead of ffmpeg)"
arch=('i686' 'x86_64')
@@ -15,28 +20,25 @@ depends=('fftw')
provides=('chromaprint' 'libchromaprint.so')
conflicts=('chromaprint' 'chromaprint-git')
source=("https://bitbucket.org/acoustid/chromaprint/downloads/${_srcname}-${pkgver}.tar.gz")
-sha256sums=('c3af900d8e7a42afd74315b51b79ebd2e43bc66630b4ba585a54bf3160439652')
+sha256sums=('4b8ed053d99e35ca3543e41f581659307a705c677e1f7eded91f047a580cebe8')
build() {
cd "$_srcname"-"$pkgver"
cmake \
- -DBIN_INSTALL_DIR:PATH=/usr/bin \
- -DBUILD_SHARED_LIBS:BOOL=ON \
- -DBUILD_EXAMPLES:BOOL=OFF \
- -DBUILD_TESTS:BOOL=OFF \
- -DCMAKE_BUILD_TYPE:STRING=Release \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DEXEC_INSTALL_PREFIX:PATH=/usr \
- -DINCLUDE_INSTALL_DIR:PATH=/usr/include \
- -DWITH_AVFFT:BOOL=OFF \
- -DWITH_FFTW3:BOOL=ON \
- -DWITH_KISSFFT:BOOL=OFF \
- -DWITH_VDSP:BOOL=OFF \
- -Wno-dev \
- .
+ -DBIN_INSTALL_DIR:PATH=/usr/bin \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DBUILD_TESTS:BOOL=OFF \
+ -DBUILD_TOOLS:BOOL=OFF \
+ -DCMAKE_BUILD_TYPE:STRING=Release \
+ -DCMAKE_COLOR_MAKEFILE:BOOL=ON \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DEXEC_INSTALL_PREFIX:PATH=/usr \
+ -DFFT_LIB:STRING=fftw3 \
+ -DINCLUDE_INSTALL_DIR:PATH=/usr/include \
+ -Wno-dev \
+ .
make
-
}
package() {