summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-02-04 13:22:25 -0300
committerDaniel Bermond2023-02-04 13:22:25 -0300
commite4b32a1388ccc8c52c63c657de92e8840ac6650b (patch)
treefcb8ede6fdc030b8bee5f5ad17d804bf1a266b5b
parent0cd27843270a089ae91744b591775690f12be1b8 (diff)
downloadaur-e4b32a1388ccc8c52c63c657de92e8840ac6650b.tar.gz
Fix build with gtest 1.13.0
-rw-r--r--010-chromaprint-gtest-1.13.0-fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/010-chromaprint-gtest-1.13.0-fix.patch b/010-chromaprint-gtest-1.13.0-fix.patch
new file mode 100644
index 000000000000..cbbf7b72d52d
--- /dev/null
+++ b/010-chromaprint-gtest-1.13.0-fix.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -24,7 +24,7 @@ find_package(Threads)
+
+ option(BUILD_SHARED_LIBS "Build shared libraries" ON)
+
+-set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_STANDARD 14)
+
+ if(BUILD_SHARED_LIBS)
+ set(CMAKE_C_VISIBILITY_PRESET hidden)