summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaulius Lukauskas2015-08-05 11:47:11 +0100
committerSaulius Lukauskas2015-08-05 11:47:11 +0100
commitcc607a462765cfb3625ee83a39ec69c6c25a6c55 (patch)
treebfca97bfb29b7a0aa8ccfd4a6757d6bd442d0443
downloadaur-cc607a462765cfb3625ee83a39ec69c6c25a6c55.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f48727c1bd66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = chromasig-seq
+ pkgdesc = ChromaSig is an unsupervised learning method to search for common patterns (motifs) of histone modifications. Chromasig was proposed by Gary Hon et al
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://wanglab.ucsd.edu/star/download.php
+ arch = x86_64
+ arch = i686
+ license = unknown
+ depends = perl
+ depends = swig
+ depends = mysql
+ depends = perl-math-cdf
+ depends = perl-dbd-mysql
+ source = http://tabit.ucsd.edu/download/ChromaSig.tar.gz
+ sha1sums = 5ce0adc33dbc4c3f577a0476c5c5d5bea2b413f2
+
+pkgname = chromasig-seq
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c709e1e9e8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Sauliusl <luksaulius[at]gmail>
+pkgname=chromasig-seq
+pkgver=1.0
+pkgrel=1
+pkgdesc="ChromaSig is an unsupervised learning method to search for common patterns ("motifs") of histone modifications. Chromasig was proposed by Gary Hon et al"
+url="http://wanglab.ucsd.edu/star/download.php"
+arch=('x86_64' 'i686')
+license=('unknown')
+depends=('perl' 'swig' 'mysql' 'perl-math-cdf' 'perl-dbd-mysql')
+optdepends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=()
+source=("http://tabit.ucsd.edu/download/ChromaSig.tar.gz")
+sha1sums=('5ce0adc33dbc4c3f577a0476c5c5d5bea2b413f2')
+
+build() {
+ cd ${srcdir}/ChromaSig/ChromaSig-seq/
+ sed -i 's/gmake/make/' install.ChromaSig
+ ./install.ChromaSig # Ignore the name, this actually just builds it
+}
+
+package() {
+ install -d ${pkgdir}/usr/lib/chromasig-seq/euclidean_dist/
+ install -d ${pkgdir}/usr/lib/chromasig-seq/fast_pmf_cycle/
+ install -d ${pkgdir}/usr/bin/
+ cd ${srcdir}/ChromaSig/ChromaSig-seq/scripts
+ install -Dm0755 euclidean_dist/*.so ${pkgdir}/usr/lib/chromasig-seq/euclidean_dist/
+ install -Dm0644 euclidean_dist/*.o ${pkgdir}/usr/lib/chromasig-seq/euclidean_dist/
+ install -Dm0644 euclidean_dist/*.pm ${pkgdir}/usr/lib/chromasig-seq/euclidean_dist/
+ install -Dm0755 fast_pmf_cycle/*.so ${pkgdir}/usr/lib/chromasig-seq/fast_pmf_cycle/
+ install -Dm0644 fast_pmf_cycle/*.o ${pkgdir}/usr/lib/chromasig-seq/fast_pmf_cycle/
+ install -Dm0644 fast_pmf_cycle/*.pm ${pkgdir}/usr/lib/chromasig-seq/fast_pmf_cycle/
+
+ sed -i 's/use lib "$FindBin::Bin/use lib "\/usr\/lib\/chromasig-seq/' ChromaSig.pl
+
+ install -Dm0755 *.pl ${pkgdir}/usr/bin/
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file