summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Schichtel2017-10-14 17:15:39 +0200
committerPhillip Schichtel2017-10-14 17:15:39 +0200
commit533e469703894deb23a7837fa10cbded1324d7c0 (patch)
tree39a27f4e24e593d104c3efb227bed5c88e4fbf40
parentb2af879d25da86e6ada9943d7541eac991144089 (diff)
downloadaur-533e469703894deb23a7837fa10cbded1324d7c0.tar.gz
Build release version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 21 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48941c3d9d93..52e84bae5632 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,26 @@
# Generated by mksrcinfo v8
-# Tue Apr 18 13:14:39 UTC 2017
-pkgbase = chrome-gnome-shell-git
+# Sat Oct 14 15:15:16 UTC 2017
+pkgbase = chrome-gnome-shell
pkgdesc = Native connector for integration with extensions.gnome.org
- pkgver = 9.r0.g35851c7
+ pkgver = 9
pkgrel = 1
url = https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL
makedepends = git
makedepends = cmake
makedepends = jq
depends = gnome-shell
+ depends = python
depends = python-requests
depends = python-gobject
provides = chrome-gnome-shell
conflicts = gs-chrome-connector
- conflicts = chrome-gnome-shell
+ conflicts = chrome-gnome-shell-git
replaces = gs-chrome-connector
- source = git+https://git.gnome.org/browse/chrome-gnome-shell
+ source = git+https://git.gnome.org/browse/chrome-gnome-shell#tag=v9
md5sums = SKIP
-pkgname = chrome-gnome-shell-git
+pkgname = chrome-gnome-shell
diff --git a/PKGBUILD b/PKGBUILD
index d3accfcfa319..8853067086f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,28 @@
+# Maintainer: Phillip Schichtel <phillip@schich.tel>
+# Contributer: Rafael Fontenelle <rafaelff@gnome.org>
# Contributor: Andrew Querol <andrew@querol.me>
-# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
-
-_name=chrome-gnome-shell
-pkgname=$_name-git
-pkgver=9.r0.g35851c7
+pkgname=chrome-gnome-shell
+pkgver=9
pkgrel=1
pkgdesc="Native connector for integration with extensions.gnome.org"
-arch=('any')
+arch=('i686' 'x86_64')
url="https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome"
license=('GPL')
-depends=('gnome-shell' 'python-requests' 'python-gobject')
+depends=('gnome-shell' 'python' 'python-requests' 'python-gobject')
makedepends=('git' 'cmake' 'jq')
-provides=("$_name")
+provides=("$pkgname")
replaces=('gs-chrome-connector') # Old name
-conflicts=('gs-chrome-connector' "$_name")
-source=("git+https://git.gnome.org/browse/chrome-gnome-shell")
+conflicts=("${replaces[0]}" "${pkgname}-git")
+source=("git+https://git.gnome.org/browse/chrome-gnome-shell#tag=v${pkgver}")
md5sums=('SKIP')
-pkgver() {
- cd "$srcdir/$_name"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
-}
-
prepare() {
- cd "$srcdir/$_name"
+ cd "$srcdir/$pkgname"
mkdir -p 'build'
}
build() {
- cd "$srcdir/$_name/build"
+ cd "$srcdir/$pkgname/build"
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -36,6 +30,6 @@ build() {
}
package() {
- cd "$srcdir/$_name/build"
+ cd "$srcdir/$pkgname/build"
make DESTDIR="$pkgdir" install
}