summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClastres Térence2016-08-12 20:31:42 +0200
committerClastres Térence2016-08-12 20:31:42 +0200
commit4f00935918bddf83523064463f1391343f9b95a4 (patch)
tree3d20fa08508247f2f9ab3a8a8e90dcae010b5a1a
parent48e54ddac5e65f8370909c2bc01f946e4bd05da8 (diff)
downloadaur-4f00935918bddf83523064463f1391343f9b95a4.tar.gz
Fix indentation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--chrome-shutdown-hook.py18
3 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc0011f4f64f..634b434f7e23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chrome-shutdown-hook
pkgdesc = Gently shutdown Chrome/Chromium on logout from Gnome Shell.
- pkgver = 1.2.2
+ pkgver = 1.2.3
pkgrel = 1
url = https://www.google.com/chrome/index.html
arch = any
@@ -12,7 +12,7 @@ pkgbase = chrome-shutdown-hook
source = chrome-shutdown-hook.desktop
source = chrome-shutdown-hook.py
md5sums = e9e039b29bf1c7a027ef6b3a2946b6a9
- md5sums = 0d8a66f32402712970b45bd31a74e5af
+ md5sums = 34a5272e929a1f735b400f799cf1a7af
pkgname = chrome-shutdown-hook
diff --git a/PKGBUILD b/PKGBUILD
index f371b78d2424..7f219a5c2949 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael Goehler <somebody dot here at gmx dot de>
pkgname=chrome-shutdown-hook
-pkgver=1.2.2
+pkgver=1.2.3
pkgrel=1
pkgdesc="Gently shutdown Chrome/Chromium on logout from Gnome Shell."
arch=('any')
@@ -13,7 +13,7 @@ license=('GPL')
source=("chrome-shutdown-hook.desktop"
"chrome-shutdown-hook.py")
md5sums=('e9e039b29bf1c7a027ef6b3a2946b6a9'
- '0d8a66f32402712970b45bd31a74e5af')
+ '34a5272e929a1f735b400f799cf1a7af')
package() {
cd "${srcdir}"
diff --git a/chrome-shutdown-hook.py b/chrome-shutdown-hook.py
index 87fd099c5c57..23f538637786 100644
--- a/chrome-shutdown-hook.py
+++ b/chrome-shutdown-hook.py
@@ -14,20 +14,24 @@ import gnome.ui
import gtk
def chrome_clean_shutdown(*args):
- subprocess.call("/usr/bin/pkill -15 -P 1 chrome", shell=True)
+ subprocess.call('/usr/bin/pkill -15 -P 1 chrome', shell=True)
return True
+
def chromium_clean_shutdown(*args):
- subprocess.call("/usr/bin/pkill -15 -P 1 chromium", shell=True)
+ subprocess.call('/usr/bin/pkill -15 -P 1 chromium', shell=True)
return True
+
def main():
- prog = gnome.init("chrome_clean_shutdown", "1.2.2")
+ prog = gnome.init('chrome_clean_shutdown', '1.2.3')
client = gnome.ui.master_client()
- if (subprocess.call("hash chromium", shell=True) == 0):
- client.connect("save-yourself", chromium_clean_shutdown)
- if (subprocess.call("hash google-chrome-stable", shell=True) == 0):
- client.connect("save-yourself", chrome_clean_shutdown)
+ if subprocess.call('hash chromium', shell=True) == 0:
+ client.connect('save-yourself', chromium_clean_shutdown)
+ if subprocess.call('hash google-chrome-stable', shell=True) == 0:
+ client.connect('save-yourself', chrome_clean_shutdown)
+
+
main()
gtk.main()