summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClastres Térence2016-08-12 13:17:54 +0200
committerClastres Térence2016-08-12 13:17:54 +0200
commiteb8e8067419d1cad6f2b4c2cb4cfd02783ae8bdb (patch)
tree4048b47583d887f642d7ae799ea354e1a1be4c45
parent8f6a620830b7b917eb5b34f572640fef0f30087c (diff)
downloadaur-eb8e8067419d1cad6f2b4c2cb4cfd02783ae8bdb.tar.gz
Fix bad close when working on multiple windows
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--chrome-shutdown-hook.py4
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3111db1c230b..847070a212d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = chrome-shutdown-hook
source = chrome-shutdown-hook.desktop
source = chrome-shutdown-hook.py
md5sums = e9e039b29bf1c7a027ef6b3a2946b6a9
- md5sums = 5e6f900651799632327ebd1cc74b15b5
+ md5sums = 6bc8f9293b6311241e0fe9523de788cc
pkgname = chrome-shutdown-hook
diff --git a/PKGBUILD b/PKGBUILD
index ee79c4ca4c44..16f154474815 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ license=('GPL')
source=("chrome-shutdown-hook.desktop"
"chrome-shutdown-hook.py")
md5sums=('e9e039b29bf1c7a027ef6b3a2946b6a9'
- '5e6f900651799632327ebd1cc74b15b5')
+ '6bc8f9293b6311241e0fe9523de788cc')
package() {
cd "${srcdir}"
diff --git a/chrome-shutdown-hook.py b/chrome-shutdown-hook.py
index 88fa746cc19d..07c361ab3f94 100644
--- a/chrome-shutdown-hook.py
+++ b/chrome-shutdown-hook.py
@@ -14,11 +14,11 @@ import gnome.ui
import gtk
def chrome_clean_shutdown(*args):
- subprocess.call("/usr/bin/pkill -15 chrome", shell=True)
+ subprocess.call("/usr/bin/pkill -15 -P 1 chrome", shell=True)
return True
def chromium_clean_shutdown(*args):
- subprocess.call("/usr/bin/pkill -15 chromium", shell=True)
+ subprocess.call("/usr/bin/pkill -15 -P 1 chromium", shell=True)
return True
def main():