summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShayne Hartford (ShayBox)2020-03-27 21:43:56 -0400
committerShayne Hartford (ShayBox)2020-03-27 21:43:56 -0400
commit5f24c3f881763f4cad15d044bbd0652e0c29549b (patch)
tree06c52bb57a94bb6c36b412ae1f71054f381cab77
downloadaur-5f24c3f881763f4cad15d044bbd0652e0c29549b.tar.gz
Added theme
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD49
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b95cefcd23e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = chromeos-kde-git
+ pkgdesc = ChromeOS theme for kde plasma
+ pkgver = r13.715710d
+ pkgrel = 1
+ url = https://github.com/vinceliuice/chromeos-kde
+ arch = any
+ license = GPL3
+ makedepends = git
+ options = !strip
+ source = git+https://github.com/vinceliuice/chromeos-kde.git
+ sha256sums = SKIP
+
+pkgname = chromeos-kde-git
+ optdepends = chromeos-gtk-theme: Matching GTK theme
+ optdepends = kvantum-theme-chromeos: Layan theme for Kvantum Qt style (recommended)
+ optdepends = tela-icon-theme: Matching icon theme
+ provides = chromeos-kde
+
+pkgname = kvantum-theme-chromeos-git
+ pkgdesc = Layan theme for KDE Plasma 5
+ depends = kvantum-qt5
+ provides = kvantum-theme-chromeos
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b5d865d5e09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Shayne Hartford <shayneehartford@gmail.com>
+
+pkgbase=chromeos-kde-git
+pkgname=(chromeos-kde-git kvantum-theme-chromeos-git)
+_pkgname=chromeos-kde
+pkgver=r13.715710d
+pkgrel=1
+pkgdesc="ChromeOS theme for kde plasma"
+arch=(any)
+url="https://github.com/vinceliuice/$_pkgname"
+license=('GPL3')
+options=('!strip')
+source=("git+$url.git")
+sha256sums=('SKIP')
+makedepends=('git')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package_chromeos-kde-git() {
+ provides=('chromeos-kde')
+ optdepends=('chromeos-gtk-theme: Matching GTK theme'
+ 'kvantum-theme-chromeos: Layan theme for Kvantum Qt style (recommended)'
+ 'tela-icon-theme: Matching icon theme')
+
+ cd $_pkgname
+
+ install -d "$pkgdir"/usr/share
+
+ cp -r aurorae "$pkgdir"/usr/share
+ cp -r color-schemes "$pkgdir"/usr/share
+ cp -r plasma "$pkgdir"/usr/share
+ cp -r sddm "$pkgdir"/usr/share
+}
+
+package_kvantum-theme-chromeos-git() {
+ provides=('kvantum-theme-chromeos')
+ pkgdesc="Layan theme for KDE Plasma 5"
+ depends=(kvantum-qt5)
+
+ cd $_pkgname
+
+ install -d "$pkgdir"/usr/share
+
+ cp -r Kvantum "$pkgdir"/usr/share
+}