summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrancoism902020-10-17 20:12:48 +0200
committerfrancoism902020-10-17 20:12:48 +0200
commit982c6027c41c84f03c0f3f3df05d2110c765a725 (patch)
tree583650277f15b5a7ca97c0a4a252d1bfc7db1d4e
downloadaur-982c6027c41c84f03c0f3f3df05d2110c765a725.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD46
-rw-r--r--fix-theme-installer-path.patch33
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..356e6498f7bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = chromeos-kde-theme-git
+ pkgdesc = ChromeOS theme for the KDE Plasma desktop.
+ pkgver = r28.55d0e85
+ pkgrel = 1
+ url = https://github.com/vinceliuice/ChromeOS-kde
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = plasma-desktop
+ optdepends = kvantum-qt5
+ optdepends = chromeos-gtk-theme-git
+ optdepends = tela-icon-theme-git
+ optdepends = sddm
+ source = chromeos-kde::git+https://github.com/vinceliuice/ChromeOS-kde.git
+ source = fix-theme-installer-path.patch
+ sha256sums = SKIP
+ sha256sums = 3c5ec095be345bc5e560c0f594e1afdef9b2ffef9e3de90c52673382ec85f729
+
+pkgname = chromeos-kde-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9905073ab9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Francois Menning <f.menning@pm.me>
+
+_gitname=chromeos-kde
+pkgname=chromeos-kde-theme-git
+pkgver=r28.55d0e85
+pkgrel=1
+pkgdesc="ChromeOS theme for the KDE Plasma desktop."
+arch=('any')
+url="https://github.com/vinceliuice/ChromeOS-kde"
+license=('GPL3')
+depends=('plasma-desktop')
+optdepends=('kvantum-qt5' 'chromeos-gtk-theme-git' 'tela-icon-theme-git' 'sddm')
+makedepends=('git')
+source=(
+ "${_gitname}::git+https://github.com/vinceliuice/ChromeOS-kde.git"
+ 'fix-theme-installer-path.patch'
+)
+sha256sums=('SKIP'
+ '3c5ec095be345bc5e560c0f594e1afdef9b2ffef9e3de90c52673382ec85f729')
+
+pkgver() {
+ cd ${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare () {
+ export SRCDIR="$srcdir/$_gitname"
+ export PKGDIR="$pkgdir"
+
+ cd "$SRCDIR"
+ patch -Np1 -i "$srcdir"/fix-theme-installer-path.patch
+}
+
+package() {
+ export SRCDIR="$srcdir/$_gitname"
+ export PKGDIR="$pkgdir"
+
+ cd "$SRCDIR"
+ bash install.sh
+
+ # sddm
+ sddmdir="${pkgdir}/usr/share/sddm/themes"
+
+ install -dm755 "${sddmdir}"
+ cp -r sddm/ChromeOS "${sddmdir}"
+}
diff --git a/fix-theme-installer-path.patch b/fix-theme-installer-path.patch
new file mode 100644
index 000000000000..27b833684d0e
--- /dev/null
+++ b/fix-theme-installer-path.patch
@@ -0,0 +1,33 @@
+--- /install.sh
+--- /install.sh
+@@ -4,23 +4,13 @@
+ ROOT_UID=0
+
+ # Destination directory
+-if [ "$UID" -eq "$ROOT_UID" ]; then
+- AURORAE_DIR="/usr/share/aurorae/themes"
+- SCHEMES_DIR="/usr/share/color-schemes"
+- PLASMA_DIR="/usr/share/plasma/desktoptheme"
+- LAYOUT_DIR="/usr/share/plasma/layout-templates"
+- LOOKFEEL_DIR="/usr/share/plasma/look-and-feel"
+- KVANTUM_DIR="/usr/share/Kvantum"
+- WALLPAPER_DIR="/usr/share/wallpapers"
+-else
+- AURORAE_DIR="$HOME/.local/share/aurorae/themes"
+- SCHEMES_DIR="$HOME/.local/share/color-schemes"
+- PLASMA_DIR="$HOME/.local/share/plasma/desktoptheme"
+- LAYOUT_DIR="$HOME/.local/share/plasma/layout-templates"
+- LOOKFEEL_DIR="$HOME/.local/share/plasma/look-and-feel"
+- KVANTUM_DIR="$HOME/.config/Kvantum"
+- WALLPAPER_DIR="$HOME/.local/share/wallpapers"
+-fi
++AURORAE_DIR="${PKGDIR}/usr/share/aurorae/themes"
++SCHEMES_DIR="${PKGDIR}/usr/share/color-schemes"
++PLASMA_DIR="${PKGDIR}/usr/share/plasma/desktoptheme"
++LAYOUT_DIR="${PKGDIR}/usr/share/plasma/layout-templates"
++LOOKFEEL_DIR="${PKGDIR}/usr/share/plasma/look-and-feel"
++KVANTUM_DIR="${PKGDIR}/usr/share/Kvantum"
++WALLPAPER_DIR="${PKGDIR}/usr/share/wallpapers"
+
+ THEME_NAME=ChromeOS
+