summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxsmile2018-03-21 20:34:02 +0100
committerxsmile2018-03-21 20:34:02 +0100
commit15b470d2fa3330438bd3513f0991a3cd4119a1e1 (patch)
treea9e6c806ead76f93cd0cc06682d5d8a78d1cb017
downloadaur-15b470d2fa3330438bd3513f0991a3cd4119a1e1.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD28
-rw-r--r--chromexup.install9
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48cde9579350
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = chromexup
+ pkgdesc = External extension updater for Chromium based browsers
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/xsmile/chromexup
+ install = chromexup.install
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-requests
+ source = https://github.com/xsmile/chromexup/archive/0.3.0.tar.gz
+ md5sums = 60d4bbfbad69442becc643bff8c7c013
+
+pkgname = chromexup
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c687d85e61bb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+pkg/*
+src/*
+
+*.zip
+*.tar*
+
+*.asc
+*.sig
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5f5dfc65072
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: xsmile <>
+
+pkgname=chromexup
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='External extension updater for Chromium based browsers'
+arch=('any')
+url='https://github.com/xsmile/chromexup'
+license=('MIT')
+makedepends=('python-setuptools')
+depends=('python-requests')
+install="$pkgname.install"
+source=("$url/archive/$pkgver.tar.gz")
+md5sums=('60d4bbfbad69442becc643bff8c7c013')
+
+package() {
+ cd $pkgname-$pkgver
+
+ # Systemd scripts
+ install -Dm644 scripts/systemd/$pkgname.service -t "$pkgdir"/usr/lib/systemd/user
+ install -Dm644 scripts/systemd/$pkgname-daily.timer -t "$pkgdir"/usr/lib/systemd/user
+ install -Dm644 scripts/systemd/$pkgname-weekly.timer -t "$pkgdir"/usr/lib/systemd/user
+
+ # License
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+
+ python setup.py install --root="$pkgdir" --optimize=1
+}
diff --git a/chromexup.install b/chromexup.install
new file mode 100644
index 000000000000..6953f9edfc94
--- /dev/null
+++ b/chromexup.install
@@ -0,0 +1,9 @@
+post_install() {
+ cat << EOM
+:: Instructions
+1. Create the configuration file '~/.config/chromexup/config.ini' using the template at
+ '/usr/share/chromexup/config.ini.example' and edit it to your liking.
+2. For automatic updates enable one of the systemd user timers 'chromexup-{daily,weekly}.timer'.
+3. Run 'chromexup' manually if needed.
+EOM
+}