summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Playfair Cal2020-04-05 19:42:54 +1000
committerDaniel Playfair Cal2020-04-05 19:42:54 +1000
commit579548882df2149b827e528bbe70b5f2df4bfdef (patch)
treeed05fb94f5d838392feaaff659ca585d685e3851
parentb34ba8844f012cba3c11e5b639920a7d39f4760b (diff)
downloadaur-579548882df2149b827e528bbe70b5f2df4bfdef.tar.gz
83.0.4100.3-1
-rw-r--r--.SRCINFO19
-rw-r--r--0001-add-missing-algorithm-header.patch25
-rw-r--r--0002-libstdc-fix-incomplete-type-in-AXTree-for-NodeSetSiz.patch60
-rw-r--r--0003-Revert-FragmentItem-Two-fixes-for-outline.patch84
-rw-r--r--PKGBUILD30
-rw-r--r--rebuild-Linux-frame-button-cache-when-activation.patch62
-rw-r--r--rename-Relayout-in-DesktopWindowTreeHostPlatform.patch64
7 files changed, 195 insertions, 149 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4219069aec9..86263a26c9e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chromium-dev-ozone
pkgdesc = Chromium built with patches for wayland support via Ozone (dev channel)
- pkgver = 81.0.4044.91
+ pkgver = 83.0.4100.3
pkgrel = 1
url = https://www.chromium.org/Home
install = chromium.install
@@ -17,7 +17,7 @@ pkgbase = chromium-dev-ozone
makedepends = pipewire
makedepends = clang
makedepends = lld
- makedepends = gn
+ makedepends = gn-git
makedepends = java-runtime-headless
depends = gtk3
depends = nss
@@ -37,7 +37,6 @@ pkgbase = chromium-dev-ozone
depends = icu
depends = libxml2
depends = fontconfig
- depends = harfbuzz
depends = libvpx
depends = re2
depends = snappy
@@ -57,18 +56,20 @@ pkgbase = chromium-dev-ozone
conflicts = chromium
options = debug
options = !strip
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-81.0.4044.91.tar.xz
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-83.0.4100.3.tar.xz
source = chromium-launcher-6.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v6.tar.gz
- source = rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
- source = rebuild-Linux-frame-button-cache-when-activation.patch
source = chromium-widevine.patch
source = chromium-skia-harmony.patch
- sha256sums = cec9da1fe5c5a99e97e9ca29d0836b12239439ede40794e52a9a2fdef065d4ca
+ source = 0001-add-missing-algorithm-header.patch
+ source = 0002-libstdc-fix-incomplete-type-in-AXTree-for-NodeSetSiz.patch
+ source = 0003-Revert-FragmentItem-Two-fixes-for-outline.patch
+ sha256sums = de935646f509f31110c0c80353fb82178a8f6ff4fa39e07449f20bb3abdccde7
sha256sums = 04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1
- sha256sums = ae3bf107834bd8eda9a3ec7899fe35fde62e6111062e5def7d24bf49b53db3db
- sha256sums = 46f7fc9768730c460b27681ccf3dc2685c7e1fd22d70d3a82d9e57e3389bb014
sha256sums = 709e2fddba3c1f2ed4deb3a239fc0479bfa50c46e054e7f32db4fb1365fed070
sha256sums = 771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1
+ sha256sums = 09f847e4abaa91f9bf92e084ec45f331dbb79936e742fb3ec9ed7a916503ef12
+ sha256sums = ad336230b964644ed8db148c497091a001d8601a220b5dd7307b91d13b5473d4
+ sha256sums = b65b6cf6e0239ddb6c44b8b2fdc87f711b9e936e8fa6cdd2bdd0f4988b3d759f
pkgname = chromium-dev-ozone
diff --git a/0001-add-missing-algorithm-header.patch b/0001-add-missing-algorithm-header.patch
new file mode 100644
index 000000000000..1d8140735609
--- /dev/null
+++ b/0001-add-missing-algorithm-header.patch
@@ -0,0 +1,25 @@
+From 472df7c01d1b3d7dd85a664a384488393e526ef4 Mon Sep 17 00:00:00 2001
+From: Daniel Playfair Cal <daniel.playfair.cal@gmail.com>
+Date: Sat, 4 Apr 2020 17:26:43 +1100
+Subject: [PATCH 1/3] add missing algorithm header
+
+---
+ extensions/browser/install/crx_install_error.cc | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/extensions/browser/install/crx_install_error.cc b/extensions/browser/install/crx_install_error.cc
+index a9765bb0a5a4..bd0d3e35a167 100644
+--- a/extensions/browser/install/crx_install_error.cc
++++ b/extensions/browser/install/crx_install_error.cc
+@@ -4,6 +4,8 @@
+
+ #include "extensions/browser/install/crx_install_error.h"
+
++#include <algorithm>
++
+ #include "base/logging.h"
+ #include "extensions/browser/install/sandboxed_unpacker_failure_reason.h"
+
+--
+2.26.0
+
diff --git a/0002-libstdc-fix-incomplete-type-in-AXTree-for-NodeSetSiz.patch b/0002-libstdc-fix-incomplete-type-in-AXTree-for-NodeSetSiz.patch
new file mode 100644
index 000000000000..5311beefa009
--- /dev/null
+++ b/0002-libstdc-fix-incomplete-type-in-AXTree-for-NodeSetSiz.patch
@@ -0,0 +1,60 @@
+From 6800459ad3b60208f27f638d8c6d170fb8461c84 Mon Sep 17 00:00:00 2001
+From: Stephan Hartmann <stha09@googlemail.com>
+Date: Sun, 5 Apr 2020 08:29:21 +0000
+Subject: [PATCH 2/3] libstdc++: fix incomplete-type in AXTree for
+ NodeSetSizePosInSetInfo
+
+std::unordered_map<T, U> requires U to be fully declared. ax_tree.h
+has only forward declaration of NodeSetSizePosInSetInfo. Therefore,
+move declaration from ax_tree.cc.
+Bug: 957519
+Change-Id: Ic1f4bf3ebfea229ece84251e46d4461b31873868
+---
+ ui/accessibility/ax_tree.cc | 10 ++--------
+ ui/accessibility/ax_tree.h | 9 ++++++++-
+ 2 files changed, 10 insertions(+), 9 deletions(-)
+
+diff --git a/ui/accessibility/ax_tree.cc b/ui/accessibility/ax_tree.cc
+index 7b8d9b1b1610..e9154028d664 100644
+--- a/ui/accessibility/ax_tree.cc
++++ b/ui/accessibility/ax_tree.cc
+@@ -567,14 +567,8 @@ struct AXTreeUpdateState {
+ const AXTree& tree;
+ };
+
+-struct AXTree::NodeSetSizePosInSetInfo {
+- NodeSetSizePosInSetInfo() = default;
+- ~NodeSetSizePosInSetInfo() = default;
+-
+- int32_t pos_in_set = 0;
+- int32_t set_size = 0;
+- base::Optional<int> lowest_hierarchical_level;
+-};
++AXTree::NodeSetSizePosInSetInfo::NodeSetSizePosInSetInfo() = default;
++AXTree::NodeSetSizePosInSetInfo::~NodeSetSizePosInSetInfo() = default;
+
+ struct AXTree::OrderedSetContent {
+ explicit OrderedSetContent(const AXNode* ordered_set = nullptr)
+diff --git a/ui/accessibility/ax_tree.h b/ui/accessibility/ax_tree.h
+index a51ca8de4c84..8c1c57517ac0 100644
+--- a/ui/accessibility/ax_tree.h
++++ b/ui/accessibility/ax_tree.h
+@@ -328,7 +328,14 @@ class AX_EXPORT AXTree : public AXNode::OwnerTree {
+ bool enable_extra_mac_nodes_ = false;
+
+ // Contains pos_in_set and set_size data for an AXNode.
+- struct NodeSetSizePosInSetInfo;
++ struct NodeSetSizePosInSetInfo {
++ NodeSetSizePosInSetInfo();
++ ~NodeSetSizePosInSetInfo();
++
++ int32_t pos_in_set = 0;
++ int32_t set_size = 0;
++ base::Optional<int> lowest_hierarchical_level;
++ };
+
+ // Represents the content of an ordered set which includes the ordered set
+ // items and the ordered set container if it exists.
+--
+2.26.0
+
diff --git a/0003-Revert-FragmentItem-Two-fixes-for-outline.patch b/0003-Revert-FragmentItem-Two-fixes-for-outline.patch
new file mode 100644
index 000000000000..92cd35db0f6e
--- /dev/null
+++ b/0003-Revert-FragmentItem-Two-fixes-for-outline.patch
@@ -0,0 +1,84 @@
+From d73794f48b5b20b05c0bd6c4657181f16dce8c2a Mon Sep 17 00:00:00 2001
+From: Daniel Playfair Cal <daniel.playfair.cal@gmail.com>
+Date: Sun, 5 Apr 2020 18:07:27 +1000
+Subject: [PATCH 3/3] Revert "[FragmentItem] Two fixes for outline"
+
+This reverts commit a340aadc092315215068045d847516f985b6a9f3.
+---
+ .../layout/ng/layout_ng_block_flow_mixin.cc | 13 ++-----
+ .../ng/ng_physical_container_fragment.cc | 34 -------------------
+ 2 files changed, 2 insertions(+), 45 deletions(-)
+
+diff --git a/third_party/blink/renderer/core/layout/ng/layout_ng_block_flow_mixin.cc b/third_party/blink/renderer/core/layout/ng/layout_ng_block_flow_mixin.cc
+index ef990b7ce3fd..4beb7958545c 100644
+--- a/third_party/blink/renderer/core/layout/ng/layout_ng_block_flow_mixin.cc
++++ b/third_party/blink/renderer/core/layout/ng/layout_ng_block_flow_mixin.cc
+@@ -110,18 +110,9 @@ void LayoutNGBlockFlowMixin<Base>::AddOutlineRects(
+ To<NGPhysicalBoxFragment>(PaintFragment()->PhysicalFragment())
+ .AddSelfOutlineRects(additional_offset, include_block_overflows,
+ &rects);
+- return;
+- }
+-
+- if (const NGPhysicalBoxFragment* fragment = CurrentFragment()) {
+- if (fragment->HasItems()) {
+- fragment->AddSelfOutlineRects(additional_offset, include_block_overflows,
+- &rects);
+- return;
+- }
++ } else {
++ Base::AddOutlineRects(rects, additional_offset, include_block_overflows);
+ }
+-
+- Base::AddOutlineRects(rects, additional_offset, include_block_overflows);
+ }
+
+ // Retrieve NGBaseline from the current fragment.
+diff --git a/third_party/blink/renderer/core/layout/ng/ng_physical_container_fragment.cc b/third_party/blink/renderer/core/layout/ng/ng_physical_container_fragment.cc
+index 82f57612ce45..a2f8092c791a 100644
+--- a/third_party/blink/renderer/core/layout/ng/ng_physical_container_fragment.cc
++++ b/third_party/blink/renderer/core/layout/ng/ng_physical_container_fragment.cc
+@@ -90,40 +90,6 @@ void NGPhysicalContainerFragment::AddOutlineRectsForNormalChildren(
+ const PhysicalOffset& additional_offset,
+ NGOutlineType outline_type,
+ const LayoutBoxModelObject* containing_block) const {
+- if (const auto* box = DynamicTo<NGPhysicalBoxFragment>(this)) {
+- if (const NGFragmentItems* items = box->Items()) {
+- for (NGInlineCursor cursor(*items); cursor; cursor.MoveToNext()) {
+- DCHECK(cursor.Current().Item());
+- const NGFragmentItem& item = *cursor.Current().Item();
+- if (item.Type() == NGFragmentItem::kLine) {
+- AddOutlineRectsForDescendant(
+- {item.LineBoxFragment(), item.OffsetInContainerBlock()},
+- outline_rects, additional_offset, outline_type, containing_block);
+- continue;
+- }
+- if (item.Type() == NGFragmentItem::kBox) {
+- if (const NGPhysicalBoxFragment* child_box = item.BoxFragment()) {
+- DCHECK(!child_box->IsOutOfFlowPositioned());
+- AddOutlineRectsForDescendant(
+- {child_box, item.OffsetInContainerBlock()}, outline_rects,
+- additional_offset, outline_type, containing_block);
+- }
+- continue;
+- }
+- DCHECK(item.IsText());
+- }
+- // Don't add |Children()|. If |this| has |NGFragmentItems|, children are
+- // either line box, which we already handled in items, or OOF, which we
+- // should ignore.
+- DCHECK(std::all_of(PostLayoutChildren().begin(),
+- PostLayoutChildren().end(), [](const NGLink& child) {
+- return child->IsLineBox() ||
+- child->IsOutOfFlowPositioned();
+- }));
+- return;
+- }
+- }
+-
+ for (const auto& child : PostLayoutChildren()) {
+ // Outlines of out-of-flow positioned descendants are handled in
+ // NGPhysicalBoxFragment::AddSelfOutlineRects().
+--
+2.26.0
+
diff --git a/PKGBUILD b/PKGBUILD
index f5e009d59f77..c89be9af2a3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-dev-ozone
-pkgver=81.0.4044.91
+pkgver=83.0.4100.3
pkgrel=1
_launcher_ver=6
pkgdesc="Chromium built with patches for wayland support via Ozone (dev channel)"
@@ -19,7 +19,7 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
provides=('chromium')
conflicts=('chromium')
makedepends=('python' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git'
- 'pipewire' 'clang' 'lld' 'gn' 'java-runtime-headless')
+ 'pipewire' 'clang' 'lld' 'gn-git' 'java-runtime-headless')
optdepends=('pepper-flash: support for Flash content'
'pipewire: WebRTC desktop sharing under Wayland'
'kdialog: needed for file dialogs in KDE'
@@ -28,16 +28,18 @@ optdepends=('pepper-flash: support for Flash content'
install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
- rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
- rebuild-Linux-frame-button-cache-when-activation.patch
chromium-widevine.patch
- chromium-skia-harmony.patch)
-sha256sums=('cec9da1fe5c5a99e97e9ca29d0836b12239439ede40794e52a9a2fdef065d4ca'
+ chromium-skia-harmony.patch
+ 0001-add-missing-algorithm-header.patch
+ 0002-libstdc-fix-incomplete-type-in-AXTree-for-NodeSetSiz.patch
+ 0003-Revert-FragmentItem-Two-fixes-for-outline.patch)
+sha256sums=('de935646f509f31110c0c80353fb82178a8f6ff4fa39e07449f20bb3abdccde7'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
- 'ae3bf107834bd8eda9a3ec7899fe35fde62e6111062e5def7d24bf49b53db3db'
- '46f7fc9768730c460b27681ccf3dc2685c7e1fd22d70d3a82d9e57e3389bb014'
'709e2fddba3c1f2ed4deb3a239fc0479bfa50c46e054e7f32db4fb1365fed070'
- '771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
+ '771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1'
+ '09f847e4abaa91f9bf92e084ec45f331dbb79936e742fb3ec9ed7a916503ef12'
+ 'ad336230b964644ed8db148c497091a001d8601a220b5dd7307b91d13b5473d4'
+ 'b65b6cf6e0239ddb6c44b8b2fdc87f711b9e936e8fa6cdd2bdd0f4988b3d759f')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@@ -46,7 +48,7 @@ declare -gA _system_libs=(
[flac]=flac
[fontconfig]=fontconfig
[freetype]=freetype2
- [harfbuzz-ng]=harfbuzz
+ # [harfbuzz-ng]=harfbuzz
[icu]=icu
[libdrm]=
#[libjpeg]=libjpeg
@@ -95,10 +97,6 @@ prepare() {
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
third_party/libxml/chromium/*.cc
- # https://crbug.com/1049258
- patch -Np1 -i ../rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
- patch -Np1 -i ../rebuild-Linux-frame-button-cache-when-activation.patch
-
# Load bundled Widevine CDM if available (see chromium-widevine in the AUR)
# M79 is supposed to download it as a component but it doesn't seem to work
patch -Np1 -i ../chromium-widevine.patch
@@ -106,6 +104,10 @@ prepare() {
# https://crbug.com/skia/6663#c10
patch -Np0 -i ../chromium-skia-harmony.patch
+ patch -Np1 -i ../0001-add-missing-algorithm-header.patch
+ patch -Np1 -i ../0002-libstdc-fix-incomplete-type-in-AXTree-for-NodeSetSiz.patch
+ patch -Np1 -i ../0003-Revert-FragmentItem-Two-fixes-for-outline.patch
+
for PATCH in ${_bugfix_patches[@]}
do
echo "Applying $PATCH"
diff --git a/rebuild-Linux-frame-button-cache-when-activation.patch b/rebuild-Linux-frame-button-cache-when-activation.patch
deleted file mode 100644
index 40764b3ba7ab..000000000000
--- a/rebuild-Linux-frame-button-cache-when-activation.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From d10f885b9327399be9348b780967ebd6b7f2c4bc Mon Sep 17 00:00:00 2001
-From: Tom Anderson <thomasanderson@chromium.org>
-Date: Fri, 7 Feb 2020 22:44:54 +0000
-Subject: [PATCH] Rebuild Linux frame button cache when activation state
- changes
-
-This fixes an issue where the frame buttons would always render in an
-inactive state on Linux (see repro steps in bug 1049258).
-
-Bug: 1049258
-R=sky
-CC=pkasting
-
-Change-Id: Ic5af33199003e1d1cdf6cedf506e32388ea11fa9
-Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2044538
-Auto-Submit: Thomas Anderson <thomasanderson@chromium.org>
-Commit-Queue: Scott Violet <sky@chromium.org>
-Reviewed-by: Scott Violet <sky@chromium.org>
-Cr-Commit-Position: refs/heads/master@{#739585}
----
- .../ui/views/frame/desktop_linux_browser_frame_view.cc | 6 +++---
- .../desktop_aura/desktop_window_tree_host_platform.cc | 3 +++
- 2 files changed, 6 insertions(+), 3 deletions(-)
-
-diff --git a/chrome/browser/ui/views/frame/desktop_linux_browser_frame_view.cc b/chrome/browser/ui/views/frame/desktop_linux_browser_frame_view.cc
-index 954e776057f..4f579955675 100644
---- a/chrome/browser/ui/views/frame/desktop_linux_browser_frame_view.cc
-+++ b/chrome/browser/ui/views/frame/desktop_linux_browser_frame_view.cc
-@@ -22,13 +22,13 @@ DesktopLinuxBrowserFrameView::DesktopLinuxBrowserFrameView(
- : OpaqueBrowserFrameView(frame, browser_view, layout),
- nav_button_provider_(std::move(nav_button_provider)) {}
-
--DesktopLinuxBrowserFrameView::~DesktopLinuxBrowserFrameView() {}
-+DesktopLinuxBrowserFrameView::~DesktopLinuxBrowserFrameView() = default;
-
- void DesktopLinuxBrowserFrameView::Layout() {
- // Calling MaybeUpdateCachedFrameButtonImages() from Layout() is sufficient to
- // catch all cases that could update the appearance, since
-- // DesktopWindowTreeHostPlatform::OnWindowStateChanged() does a layout any
-- // time any properties change.
-+ // DesktopWindowTreeHostPlatform::On{Window,Activation}StateChanged() does a
-+ // layout any time the maximized and activation state changes, respectively.
- MaybeUpdateCachedFrameButtonImages();
- OpaqueBrowserFrameView::Layout();
- }
-diff --git a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
-index 9c695d8e5b1..9662f19aa90 100644
---- a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
-+++ b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
-@@ -677,9 +677,12 @@ void DesktopWindowTreeHostPlatform::OnCloseRequest() {
- }
-
- void DesktopWindowTreeHostPlatform::OnActivationChanged(bool active) {
-+ if (is_active_ == active)
-+ return;
- is_active_ = active;
- aura::WindowTreeHostPlatform::OnActivationChanged(active);
- desktop_native_widget_aura_->HandleActivationChanged(active);
-+ ScheduleRelayout();
- }
-
- base::Optional<gfx::Size>
diff --git a/rename-Relayout-in-DesktopWindowTreeHostPlatform.patch b/rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
deleted file mode 100644
index eda3cbdbaaf3..000000000000
--- a/rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From 5a2cd2409c7d65c019ad9f4595a4e85315857ac4 Mon Sep 17 00:00:00 2001
-From: Tom Anderson <thomasanderson@chromium.org>
-Date: Mon, 3 Feb 2020 23:18:46 +0000
-Subject: [PATCH] Rename Relayout() in DesktopWindowTreeHostPlatform to
- ScheduleRelayout()
-
-R=sky
-
-Bug: None
-Change-Id: I680cafd25935e59a280e3b2baac754d3d5f13a35
-Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2036553
-Auto-Submit: Thomas Anderson <thomasanderson@chromium.org>
-Reviewed-by: Scott Violet <sky@chromium.org>
-Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
-Cr-Commit-Position: refs/heads/master@{#737974}
----
- .../desktop_aura/desktop_window_tree_host_platform.cc | 6 +++---
- .../widget/desktop_aura/desktop_window_tree_host_platform.h | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
-index 6c00d49eb3f..9c695d8e5b1 100644
---- a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
-+++ b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
-@@ -556,7 +556,7 @@ void DesktopWindowTreeHostPlatform::SetFullscreen(bool fullscreen) {
- DCHECK_EQ(fullscreen, IsFullscreen());
-
- if (IsFullscreen() == fullscreen)
-- Relayout();
-+ ScheduleRelayout();
- // Else: the widget will be relaid out either when the window bounds change
- // or when |platform_window|'s fullscreen state changes.
- }
-@@ -669,7 +669,7 @@ void DesktopWindowTreeHostPlatform::OnWindowStateChanged(
- // Now that we have different window properties, we may need to relayout the
- // window. (The windows code doesn't need this because their window change is
- // synchronous.)
-- Relayout();
-+ ScheduleRelayout();
- }
-
- void DesktopWindowTreeHostPlatform::OnCloseRequest() {
-@@ -712,7 +712,7 @@ gfx::Rect DesktopWindowTreeHostPlatform::ToPixelRect(
- return gfx::ToEnclosingRect(rect_in_pixels);
- }
-
--void DesktopWindowTreeHostPlatform::Relayout() {
-+void DesktopWindowTreeHostPlatform::ScheduleRelayout() {
- Widget* widget = native_widget_delegate_->AsWidget();
- NonClientView* non_client_view = widget->non_client_view();
- // non_client_view may be NULL, especially during creation.
-diff --git a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.h b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.h
-index 89beb8d2245..75a401e02a7 100644
---- a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.h
-+++ b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.h
-@@ -129,7 +129,7 @@ class VIEWS_EXPORT DesktopWindowTreeHostPlatform
- gfx::Rect ToPixelRect(const gfx::Rect& rect_in_dip) const;
-
- private:
-- void Relayout();
-+ void ScheduleRelayout();
-
- Widget* GetWidget();
- const Widget* GetWidget() const;