summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-02-08 22:47:49 +0100
committersL1pKn072017-02-08 22:48:56 +0100
commit6cde785f2181e31512def7ad5cd8cba224164c37 (patch)
tree2de99ab5f76ef9a243514f61cbd390734e26bed2
parent266062016cb9839622cadefbdc262b89c09787e1 (diff)
downloadaur-6cde785f2181e31512def7ad5cd8cba224164c37.tar.gz
Update to 58.0.3004.3
- Fixed nodejs installation by upstream. now use system nodejs
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01a8e834503f..3345c8be0fc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Feb 5 19:26:30 UTC 2017
+# Wed Feb 8 21:48:01 UTC 2017
pkgbase = chromium-dev
pkgdesc = The open-source project behind Google Chrome (Dev Channel)
- pkgver = 58.0.3000.4
+ pkgver = 58.0.3004.3
pkgrel = 1
url = http://www.chromium.org
install = chromium-dev.install
@@ -22,7 +22,8 @@ pkgbase = chromium-dev
makedepends = git
makedepends = imagemagick
makedepends = hwids
- makedepends = npm
+ makedepends = nodejs
+ makedepends = wget
depends = jsoncpp
depends = libxslt
depends = libxss
@@ -46,18 +47,18 @@ pkgbase = chromium-dev
optdepends = libexif: Need for read EXIF metadata
optdepends = ttf-font: For some typography
options = !strip
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-58.0.3000.4.tar.xz
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-58.0.3004.3.tar.xz
source = chromium-launcher-3.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v3.tar.gz
source = chromium-dev.svg
source = BUILD.gn
source = https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-system-ffmpeg-r4.patch
- source = enable_vaapi_on_linux_58.0.3000.4.diff::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/f02f22cdc0923ab18c44dc46dda0942e078b870d/debian/patches/enable_vaapi_on_linux.diff
- source = specify-max-resolution_58.0.3000.4.patch::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/f02f22cdc0923ab18c44dc46dda0942e078b870d/debian/patches/specify-max-resolution.patch
- source = fix-gl-image_58.0.3000.4.patch::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/f02f22cdc0923ab18c44dc46dda0942e078b870d/debian/patches/fix-gl-image.patch
+ source = enable_vaapi_on_linux_58.0.3004.3.diff::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/f02f22cdc0923ab18c44dc46dda0942e078b870d/debian/patches/enable_vaapi_on_linux.diff
+ source = specify-max-resolution_58.0.3004.3.patch::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/f02f22cdc0923ab18c44dc46dda0942e078b870d/debian/patches/specify-max-resolution.patch
+ source = fix-gl-image_58.0.3004.3.patch::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/f02f22cdc0923ab18c44dc46dda0942e078b870d/debian/patches/fix-gl-image.patch
source = minizip.patch
source = chromium-widevine-r1.patch
source = fix_668446_r1.diff
- sha256sums = ceaa08e4d6bbc95af2da994fb36465e84908870efb225cd2a59436560291faa1
+ sha256sums = 4110ce13c1655b1ff9dc67adafb8f8d1861e0df27b4e143cb80800f4967d24d9
sha256sums = 8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28
sha256sums = dd2b5c4191e468972b5ea8ddb4fa2e2fa3c2c94c79fc06645d0efc0e63ce7ee1
sha256sums = c7d9974834fc3803b5f1a1d310ff391306964caaabc807a62f8e5c3d38526ee6
diff --git a/PKGBUILD b/PKGBUILD
index 7988b19ecf5c..42f2e7145c41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _enable_vaapi=0 # Patch for VAAPI HW acceleration NOTE: don't work in some grap
## -- Package and components information -- ##
##############################################
pkgname=chromium-dev
-pkgver=58.0.3000.4
+pkgver=58.0.3004.3
_launcher_ver=3
pkgrel=1
pkgdesc="The open-source project behind Google Chrome (Dev Channel)"
@@ -58,7 +58,8 @@ makedepends=('libexif'
'git'
'imagemagick'
'hwids'
- 'npm'
+ 'nodejs'
+ 'wget'
)
optdepends=('libva-vdpau-driver-chromium: HW video acceleration for NVIDIA users'
'libva-mesa-driver: HW video acceleration for Nouveau, r600 and radeonsi users'
@@ -247,6 +248,7 @@ _keeplibs=(
'third_party/modp_b64'
'third_party/mt19937ar'
'third_party/node'
+ 'third_party/node/node_modules/vulcanize/third_party/UglifyJS2'
'third_party/openh264'
'third_party/openmax_dl'
'third_party/opus'
@@ -419,6 +421,10 @@ prepare() {
# https://crbug.com/668446
patch -p0 -i "${srcdir}/fix_668446_r1.diff"
+ # Setup nodejs dependency
+ mkdir -p third_party/node/linux/node-linux-x64/bin/
+ ln -s /usr/bin/node third_party/node/linux/node-linux-x64/bin/node
+
# Try to fix libpng errors.
msg2 "Attempt for fix libpng errors"
for _path in 'chrome/app/theme' 'chrome/renderer' 'ui'; do
@@ -455,14 +461,6 @@ prepare() {
msg2 "Update libaddressinput strings."
python2 third_party/libaddressinput/chromium/tools/update-strings.py
- msg2 "Update nodejs deps"
- # Fix some things in the update_node_binaries script
- sed -e 's|latest-v6.x|${NODE_VERSION}|g' \
- -e 's|rm "SHASUMS256.txt"|rm -fr "SHASUMS256.txt"|g' \
- -i third_party/node/update_node_binaries
-
- ./third_party/node/update_node_binaries
- ./third_party/node/update_npm_deps
if [ "${_build_nacl}" = "1" ]; then
msg2 "Setup NaCl/PNaCl SDK: Download and install NaCl/PNaCl toolchains"
@@ -549,9 +547,8 @@ package() {
ln -s /usr/lib/chromium-dev/chromedriver "${pkgdir}/usr/bin/chromedriver-dev"
# Install libs.
- for i in libwidevinecdmadapter libclearkeycdm; do
- install -Dm755 "${i}.so" "${pkgdir}/usr/lib/chromium-dev/${i}.so"
- done
+ install -Dm755 libclearkeycdm.so "${pkgdir}/usr/lib/chromium-dev/libclearkeycdm.so"
+ install -Dm755 libwidevinecdmadapter.so "${pkgdir}/usr/lib/chromium-dev/libwidevinecdmadapter.so"
install -Dm644 natives_blob.bin "${pkgdir}/usr/lib/chromium-dev/natives_blob.bin"
install -Dm644 snapshot_blob.bin "${pkgdir}/usr/lib/chromium-dev/snapshot_blob.bin"