summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-12-17 15:35:57 +0100
committersL1pKn072017-12-17 15:35:57 +0100
commita5d8fffd2fb571c9ca72e6f731056e53f40e826d (patch)
tree4b39429e40706a586f8193bb11ec88967a02686a
parent6df39ba8f8395100dd8676aa4c8f67a8eb4292a2 (diff)
downloadaur-a5d8fffd2fb571c9ca72e6f731056e53f40e826d.tar.gz
remove i686 support
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD48
2 files changed, 21 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 689578cf0f26..28ec1ec51b95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
# Generated by mksrcinfo v8
-# Sun Dec 17 14:11:34 UTC 2017
+# Sun Dec 17 14:35:42 UTC 2017
pkgbase = chromium-dev
pkgdesc = The open-source project behind Google Chrome (Dev Channel)
pkgver = 65.0.3294.5
pkgrel = 1
url = http://www.chromium.org
install = chromium-dev.install
- arch = i686
arch = x86_64
license = BSD
makedepends = libexif
@@ -23,6 +22,7 @@ pkgbase = chromium-dev
makedepends = hwids
makedepends = nodejs
makedepends = wget
+ makedepends = ncurses5-compat-libs
depends = libxslt
depends = libxss
depends = minizip
diff --git a/PKGBUILD b/PKGBUILD
index 67c1575660dd..e3216b87d852 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ pkgname=chromium-dev
pkgver=65.0.3294.5
pkgrel=1
pkgdesc="The open-source project behind Google Chrome (Dev Channel)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://www.chromium.org'
license=('BSD')
depends=(
@@ -116,17 +116,12 @@ _google_api_key="AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM"
_google_default_client_id="413772536636.apps.googleusercontent.com"
_google_default_client_secret="0ZChLK6AxeA3Isu96MkwqDR4"
-# Build NaCL?. disabled if detect 32bit system
-# VULKAN!! (seems only build with 64 bits) # https://crbug.com/582558 NOTE: disabled by default
-if [ "${CARCH}" = "i686" ]; then
- _build_nacl=0
- _nacl=false
-elif [ "${CARCH}" = "x86_64" ]; then
- _build_nacl=1
- _nacl=true
- _vulkan=0
- makedepends+=('ncurses5-compat-libs')
-fi
+# Build NaCL
+# VULKAN!! # https://crbug.com/582558 NOTE: disabled by default
+_build_nacl=1
+_nacl=true
+_vulkan=0
+makedepends+=('ncurses5-compat-libs')
# Need you use ccache?.
if [ "${_use_ccache}" = "1" ]; then
@@ -509,23 +504,18 @@ prepare() {
if [ "${_use_clang}" = "0" ]; then
_set_gcc
elif [ "${_use_clang}" = "1" ]; then
- if [ "${CARCH}" = 'i686' ]; then
- _set_gcc
- _compiler_msg=": Build with (bundled) clang is not possible in 32bit systems."
- elif [ "${CARCH}" = 'x86_64' ]; then
- _compiler=Clang
- _flags+=(
- 'is_clang=true'
- 'clang_use_chrome_plugins=true'
- )
- _clang_path="${srcdir}/chromium-${pkgver}/third_party/llvm-build/Release+Asserts/bin"
- _c_compiler="${_clang_path}/clang"
- _cpp_compiler="${_clang_path}/clang++"
- export CXXFLAGS="${CXXFLAGS//-fno-plt/}"
- export CFLAGS="${CFLAGS//-fno-plt/}"
- CFLAGS+=' -Wno-unknown-warning-option'
- CXXFLAGS+=' -Wno-unknown-warning-option'
- fi
+ _compiler=Clang
+ _flags+=(
+ 'is_clang=true'
+ 'clang_use_chrome_plugins=true'
+ )
+ _clang_path="${srcdir}/chromium-${pkgver}/third_party/llvm-build/Release+Asserts/bin"
+ _c_compiler="${_clang_path}/clang"
+ _cpp_compiler="${_clang_path}/clang++"
+ export CXXFLAGS="${CXXFLAGS//-fno-plt/}"
+ export CFLAGS="${CFLAGS//-fno-plt/}"
+ CFLAGS+=' -Wno-unknown-warning-option'
+ CXXFLAGS+=' -Wno-unknown-warning-option'
fi
# Export compilers