summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-09-09 16:14:18 +0200
committersl1pkn072015-09-09 16:15:05 +0200
commitca4cf8b2516ac283417ea9b26a8e1d9d5657d863 (patch)
tree74b8f10fb611b20e33378f74f3d4a6a2fd48e9a3
parent55e4c619ad13ecbfff2855dd54115948a232d0e2 (diff)
downloadaur-ca4cf8b2516ac283417ea9b26a8e1d9d5657d863.tar.gz
Update to 47.0.2503.0
- Temporarily use bundled icu - Add missing resources
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f181331f5561..f1d6fd9f3a18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chromium-dev
pkgdesc = The open-source project behind Google Chrome (Dev Channel)
- pkgver = 47.0.2498.0
+ pkgver = 47.0.2503.0
pkgrel = 1
url = http://www.chromium.org
install = chromium-dev.install
@@ -12,20 +12,19 @@ pkgbase = chromium-dev
makedepends = gperf
makedepends = ninja
makedepends = perl-json
- makedepends = python2-beautifulsoup3
+ makedepends = python2-beautifulsoup4
+ makedepends = python2-html5lib
makedepends = python2-simplejson
makedepends = python2-jinja
makedepends = subversion
makedepends = yasm
makedepends = git
- makedepends = clang
makedepends = cmake
makedepends = ocaml
makedepends = libffi
makedepends = chrpath
depends = desktop-file-utils
depends = gtk2
- depends = icu
depends = jsoncpp
depends = libwebp
depends = libxslt
@@ -49,14 +48,14 @@ pkgbase = chromium-dev
optdepends = libexif: Need for read EXIF metadata
optdepends = ttf-font: For some typography
options = !strip
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-47.0.2498.0.tar.xz
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-47.0.2503.0.tar.xz
source = chromium-launcher-2.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v2.tar.gz
source = chromium-dev.desktop
source = chromium-dev.xml
source = chromium-dev.svg
source = chromium-system-jinja-r8.patch
source = enable_vaapi_on_linux.diff
- sha1sums = 8b6cb99a1eff2cef896e206b9771990b9fc259f9
+ sha1sums = 18b63f2943050d99096741d88f513e876ac15cd3
sha1sums = 55f9646683bc8b92587f8e0a36aff242cb436a24
sha1sums = 0acc45b901418f270d0b2068502e39c407c74ea4
sha1sums = 2b98c549332e7337307ce287e150930cfc1dfa5f
diff --git a/PKGBUILD b/PKGBUILD
index 27d2e8fb7f0f..587aaf737884 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
## -- Build options -- ##
#########################
-_use_clang=1 # Use clang compiler (system). Results in faster build and smaller chromium.
+_use_clang=0 # Use clang compiler (system). Results in faster build and smaller chromium.
_use_bundled_clang=1 # Use bundled clang compiler (needs build). NOTE: if use this option , _use_clang need set to 1
_use_ccache=0 # Use ccache when build
_use_pax=0 # If set 1 to change PaX permisions in executables NOTE: only use if use PaX environment
@@ -17,7 +17,7 @@ _use_pax=0 # If set 1 to change PaX permisions in executables NOTE:
## -- Package and components information -- ##
##############################################
pkgname=chromium-dev
-pkgver=47.0.2498.0
+pkgver=47.0.2503.0
_launcher_ver=2
pkgrel=1
pkgdesc="The open-source project behind Google Chrome (Dev Channel)"
@@ -26,7 +26,7 @@ url='http://www.chromium.org'
license=('BSD')
depends=('desktop-file-utils'
'gtk2'
- 'icu'
+ #'icu'
'jsoncpp'
#'libsrtp'
'libwebp'
@@ -51,7 +51,8 @@ makedepends=('libexif'
'gperf'
'ninja'
'perl-json'
- 'python2-beautifulsoup3'
+ 'python2-beautifulsoup4'
+ 'python2-html5lib'
'python2-simplejson'
'python2-jinja'
'subversion'
@@ -200,7 +201,6 @@ _necesary=('base/third_party/dmg_fp'
'third_party/catapult/tracing/third_party/gl-matrix'
'third_party/catapult/tracing/third_party/jszip'
'third_party/catapult/tracing/third_party/tvcm'
- 'third_party/catapult/tracing/third_party/tvcm/third_party/beautifulsoup/polymer_soup.py'
'third_party/catapult/tracing/third_party/tvcm/third_party/rcssmin'
'third_party/catapult/tracing/third_party/tvcm/third_party/rjsmin'
'third_party/cld_2'
@@ -217,6 +217,7 @@ _necesary=('base/third_party/dmg_fp'
'third_party/google_input_tools/third_party/closure_library/third_party/closure'
'third_party/hunspell'
'third_party/iccjpeg'
+ 'third_party/icu'
'third_party/jstemplate'
'third_party/khronos'
'third_party/leveldatabase'
@@ -364,7 +365,7 @@ _use_system=('-Duse_system_expat=1'
'-Duse_system_flac=1'
'-Duse_system_fontconfig=1'
'-Duse_system_harfbuzz=1'
- '-Duse_system_icu=1'
+ '-Duse_system_icu=0'
'-Duse_system_jsoncpp=1'
'-Duse_system_libevent=0'
'-Duse_system_libexif=1'
@@ -563,7 +564,7 @@ package() {
install -Dm644 snapshot_blob.bin "${pkgdir}/usr/lib/chromium-dev/snapshot_blob.bin"
# Install Resources
- for i in content_resources keyboard_resources resources chrome_100_percent chrome_200_percent; do
+ for i in content_resources keyboard_resources resources chrome_100_percent chrome_200_percent chrome_material_100_percent chrome_material_200_percent; do
install -Dm644 "${i}.pak" "${pkgdir}/usr/lib/chromium-dev/${i}.pak"
done