summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-01-22 00:40:02 +0100
committerGustavo Alvarez2016-01-22 00:40:02 +0100
commitcf179b8e640c8ed6cc0600fae730d6e60f7d1515 (patch)
treebdb68cc72abfafff08e848dadfb0207c33d5fea1
parentf37486ef90b7b4b6ec044a600cc82e6fc64ab0d7 (diff)
downloadaur-cf179b8e640c8ed6cc0600fae730d6e60f7d1515.tar.gz
Update to 49.0.2623.13
- Use better widevine patch
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD9
-rw-r--r--chromium-widevine-r0.patch53
4 files changed, 66 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38959c4e789e..96446729b340 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jan 21 07:21:17 UTC 2016
+# Thu Jan 21 23:38:46 UTC 2016
pkgbase = chromium-dev
pkgdesc = The open-source project behind Google Chrome (Dev Channel)
- pkgver = 49.0.2623.0
+ pkgver = 49.0.2623.13
pkgrel = 1
url = http://www.chromium.org
install = chromium-dev.install
@@ -54,7 +54,7 @@ pkgbase = chromium-dev
optdepends = ttf-font: For some typography
optdepends = libappindicator-gtk2: Needed for show systray icon in the panel in plasma-next (KF5)
options = !strip
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-49.0.2623.0.tar.xz
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-49.0.2623.13.tar.xz
source = chromium-launcher-3.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v3.tar.gz
source = chromium-dev.desktop
source = chromium-dev.xml
@@ -63,7 +63,8 @@ pkgbase = chromium-dev
source = https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-system-ffmpeg-r2.patch
source = https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-snapshot-toolchain-r1.patch
source = enable_vaapi_on_linux-r3.diff
- sha1sums = f51aa25bbb219d4283f430c2a692935bcb9e9450
+ source = chromium-widevine-r0.patch
+ sha1sums = ac40c9bff7e7ca5b0c59d053d7e37683828cef08
sha1sums = d18f8d96e80be9c31d994cc6362d7d8041c53319
sha1sums = 0acc45b901418f270d0b2068502e39c407c74ea4
sha1sums = 2b98c549332e7337307ce287e150930cfc1dfa5f
@@ -72,6 +73,7 @@ pkgbase = chromium-dev
sha1sums = 450cd81653499eb50f0f7df1b0d4d1c1620365a5
sha1sums = 7b9c1a7e0e581413dbebb0e894f68ce2f2ba0e6a
sha1sums = aab4fa1f9aad1a80fdb35545eb74739a240fe0ae
+ sha1sums = fa9ff0ff9049784b4a1ec37292530ae61aece610
makedepends_x86_64 = lib32-gcc-libs
makedepends_x86_64 = lib32-zlib
diff --git a/.gitignore b/.gitignore
index 234029409ae6..d35ae3020016 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,4 +7,4 @@
!chromium-dev.xml
!chromium-dev.svg
!enable_vaapi_on_linux-r3.diff
-!chromium-system-ffmpeg-r2.patch
+!chromium-widevine-r0.patch
diff --git a/PKGBUILD b/PKGBUILD
index 8ba92f37971f..4dc5850c8a5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ _use_gtk3=0 # If set 1, then build with GTK3 support, if set 0, then
## -- Package and components information -- ##
##############################################
pkgname=chromium-dev
-pkgver=49.0.2623.0
+pkgver=49.0.2623.13
_launcher_ver=3
pkgrel=1
pkgdesc="The open-source project behind Google Chrome (Dev Channel)"
@@ -85,6 +85,7 @@ source=("https://commondatastorage.googleapis.com/chromium-browser-official/chro
'https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-snapshot-toolchain-r1.patch'
# Misc Patches
'enable_vaapi_on_linux-r3.diff'
+ 'chromium-widevine-r0.patch'
# Patch from crbug (chromium bugtracker)
)
sha1sums=( #"$(curl -sL https://gsdview.appspot.com/chromium-browser-official/?marker=chromium-${pkgver}.tar.x | awk -v FS='<td>"' -v RS='"</td>' '$0=$2' | head -n1)"
@@ -99,6 +100,7 @@ sha1sums=( #"$(curl -sL https://gsdview.appspot.com/chromium-browser-official/?m
'7b9c1a7e0e581413dbebb0e894f68ce2f2ba0e6a'
# Misc Patches
'aab4fa1f9aad1a80fdb35545eb74739a240fe0ae'
+ 'fa9ff0ff9049784b4a1ec37292530ae61aece610'
# Patch from crbug (chromium bugtracker)
)
options=('!strip')
@@ -439,8 +441,9 @@ prepare() {
patch -p1 -i "${srcdir}/enable_vaapi_on_linux-r3.diff"
# Patch from crbug (chromium bugtracker)
- # fix the missing define (if not, fail build) (need upstream fix) # https://crbug.com/473866
- sed '14i#define WIDEVINE_CDM_VERSION_STRING "The Cake Is a Lie"' -i "third_party/widevine/cdm/stub/widevine_cdm_version.h"
+ # https://crbug.com/473866
+ patch -p0 -i "${srcdir}/chromium-widevine-r0.patch"
+ sed 's|@WIDEVINE_VERSION@|The Cake Is a Lie|g' -i "third_party/widevine/cdm/stub/widevine_cdm_version.h"
##
diff --git a/chromium-widevine-r0.patch b/chromium-widevine-r0.patch
new file mode 100644
index 000000000000..4ae0ab3ec078
--- /dev/null
+++ b/chromium-widevine-r0.patch
@@ -0,0 +1,53 @@
+diff -upr chrome/common/chrome_content_client.cc chrome/common/chrome_content_client.cc
+--- chrome/common/chrome_content_client.cc 2016-01-20 22:01:20.000000000 +0200
++++ chrome/common/chrome_content_client.cc 2016-01-21 20:02:02.788936626 +0200
+@@ -158,7 +158,12 @@ void ComputeBuiltInPlugins(std::vector<c
+ #if defined(WIDEVINE_CDM_AVAILABLE) && defined(ENABLE_PEPPER_CDMS) && \
+ !defined(WIDEVINE_CDM_IS_COMPONENT)
+ static bool skip_widevine_cdm_file_check = false;
+- if (PathService::Get(chrome::FILE_WIDEVINE_CDM_ADAPTER, &path)) {
++ bool widevine_cdm_present =
++ skip_widevine_cdm_file_check ||
++ (PathService::Get(chrome::FILE_WIDEVINE_CDM, &path) &&
++ base::PathExists(path));
++ if (widevine_cdm_present &&
++ PathService::Get(chrome::FILE_WIDEVINE_CDM_ADAPTER, &path)) {
+ if (skip_widevine_cdm_file_check || base::PathExists(path)) {
+ content::PepperPluginInfo widevine_cdm;
+ widevine_cdm.is_out_of_process = true;
+diff -upr chrome/common/chrome_paths.cc chrome/common/chrome_paths.cc
+--- chrome/common/chrome_paths.cc 2016-01-20 22:01:20.000000000 +0200
++++ chrome/common/chrome_paths.cc 2016-01-21 19:18:51.287978456 +0200
+@@ -375,6 +375,11 @@ bool PathProvider(int key, base::FilePat
+ return false;
+ cur = cur.AppendASCII(kWidevineCdmAdapterFileName);
+ break;
++ case chrome::FILE_WIDEVINE_CDM:
++ if (!GetInternalPluginsDirectory(&cur))
++ return false;
++ cur = cur.AppendASCII(kWidevineCdmFileName);
++ break;
+ #endif // defined(WIDEVINE_CDM_AVAILABLE) && defined(ENABLE_PEPPER_CDMS)
+ case chrome::FILE_RESOURCES_PACK:
+ #if defined(OS_MACOSX) && !defined(OS_IOS)
+diff -upr chrome/common/chrome_paths.h chrome/common/chrome_paths.h
+--- chrome/common/chrome_paths.h 2016-01-14 03:49:22.000000000 +0200
++++ chrome/common/chrome_paths.h 2016-01-21 19:18:51.287978456 +0200
+@@ -99,6 +99,7 @@ enum {
+ DIR_COMPONENT_WIDEVINE_CDM, // Directory that contains component-updated
+ // Widevine CDM files.
+ FILE_WIDEVINE_CDM_ADAPTER, // Full path to the Widevine CDM adapter file.
++ FILE_WIDEVINE_CDM, // Full path to the Widevine CDM file.
+ FILE_RESOURCES_PACK, // Full path to the .pak file containing
+ // binary data (e.g., html files and images
+ // used by internal pages).
+diff -upr third_party/widevine/cdm/stub/widevine_cdm_version.h third_party/widevine/cdm/stub/widevine_cdm_version.h
+--- third_party/widevine/cdm/stub/widevine_cdm_version.h 2016-01-14 01:05:17.000000000 +0200
++++ third_party/widevine/cdm/stub/widevine_cdm_version.h 2016-01-21 19:18:51.287978456 +0200
+@@ -12,4 +12,6 @@
+
+ #define WIDEVINE_CDM_AVAILABLE
+
++#define WIDEVINE_CDM_VERSION_STRING "@WIDEVINE_VERSION@"
++
+ #endif // WIDEVINE_CDM_VERSION_H_