summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-04-11 16:51:22 +0200
committersL1pKn072019-04-11 16:51:22 +0200
commitdd27a37ccdc99c21036c8862924ebfb5bd8ea4b1 (patch)
tree87b4af6b5b3be95cc401633596ea10c7ed9b8356
parent675859c018584ec5a15afa44349de14abfe8db9a (diff)
downloadaur-dd27a37ccdc99c21036c8862924ebfb5bd8ea4b1.tar.gz
mimic chromium-ffmpeg-clang.patch into the pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD30
-rw-r--r--chromium-ffmpeg-clang.patch34
4 files changed, 20 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f0f71fec8b7..24e4404b196c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Apr 6 16:02:45 UTC 2019
+# Thu Apr 11 14:50:08 UTC 2019
pkgbase = chromium-dev
pkgdesc = The open-source project behind Google Chrome (Dev Channel)
pkgver = 75.0.3753.4
@@ -35,7 +35,7 @@ pkgbase = chromium-dev
depends = opus
depends = libva
optdepends = pepper-flash: PPAPI Flash Player
- optdepends = chromium-widevine-dev: Widevine plugin (eg: Netflix) (Dev Channel)
+ optdepends = chromium-widevine: Widevine plugin (eg: Netflix)
optdepends = kdialog: Needed for file dialogs in KF5
optdepends = kwalletmanager: Needed for storing passwords in KWallet5
optdepends = ttf-font: For some typography
@@ -47,7 +47,6 @@ pkgbase = chromium-dev
source = git+https://github.com/foutrelis/chromium-launcher.git
source = chromium-dev.svg
source = enable-vaapi.patch
- source = chromium-ffmpeg-clang.patch
source = chromium-widevine-r4.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/chromium-widevine.patch?h=packages/chromium
source = chromium-skia-harmony.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/chromium-skia-harmony.patch?h=packages/chromium
source = nullptr.patch.base64::https://chromium-review.googlesource.com/changes/chromium%2Fsrc~1552864/revisions/2/patch?download
@@ -56,7 +55,6 @@ pkgbase = chromium-dev
sha256sums = SKIP
sha256sums = dd2b5c4191e468972b5ea8ddb4fa2e2fa3c2c94c79fc06645d0efc0e63ce7ee1
sha256sums = 4b785aeee1cab89bf410de063b7769ef4eb99130888ece60a38a584019747b9f
- sha256sums = 0d386161052bf8bd3f6c68bdaf766042c75e84db8c3aa356f2e2f8b83511f29f
sha256sums = d081f2ef8793544685aad35dea75a7e6264a2cb987ff3541e6377f4a3650a28b
sha256sums = 5887f78b55c4ecbbcba5930f3f0bb7bc0117c2a41c2f761805fcf7f46f1ca2b3
sha256sums = 9a8fc71db40d2749819906041fc0eead2b9326521be898cc150b967b936fcbd3
diff --git a/.gitignore b/.gitignore
index 56a2c6a15469..5ba5598890f7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,4 @@
!PKGBUILD
!chromium-dev.install
!chromium-dev.svg
-!chromium-ffmpeg-clang.patch
!enable-vaapi.patch
diff --git a/PKGBUILD b/PKGBUILD
index e7212f52ce7d..91a47ad8dcb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -59,7 +59,7 @@ makedepends=(
)
optdepends=(
'pepper-flash: PPAPI Flash Player'
- 'chromium-widevine-dev: Widevine plugin (eg: Netflix) (Dev Channel)'
+ 'chromium-widevine: Widevine plugin (eg: Netflix)'
#
'kdialog: Needed for file dialogs in KF5'
'kwalletmanager: Needed for storing passwords in KWallet5'
@@ -78,9 +78,9 @@ source=(
'git+https://github.com/foutrelis/chromium-launcher.git'
'chromium-dev.svg'
# Patch form Gentoo.
+
# Misc Patches.
'enable-vaapi.patch' # Use Saikrishna Arcot patch again :https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/4d40b58013b518373b2544d486d3de40796edd36/debian/patches/enable_vaapi_on_linux_2.diff'
- 'chromium-ffmpeg-clang.patch'
# Patch from crbug (chromium bugtracker) or Arch chromium package.
'chromium-widevine-r4.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/chromium-widevine.patch?h=packages/chromium'
'chromium-skia-harmony.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/chromium-skia-harmony.patch?h=packages/chromium'
@@ -96,7 +96,6 @@ sha256sums=(
# Misc Patches
'4b785aeee1cab89bf410de063b7769ef4eb99130888ece60a38a584019747b9f'
- '0d386161052bf8bd3f6c68bdaf766042c75e84db8c3aa356f2e2f8b83511f29f'
# Patch from crbug (chromium bugtracker) or Arch chromium package
'd081f2ef8793544685aad35dea75a7e6264a2cb987ff3541e6377f4a3650a28b'
'5887f78b55c4ecbbcba5930f3f0bb7bc0117c2a41c2f761805fcf7f46f1ca2b3'
@@ -511,14 +510,8 @@ prepare() {
sed "s|fuse-ld=lld|fuse-ld=${_clang_path}${_lld}|g" -i build/config/compiler/BUILD.gn
# Setup bundled ffmpeg.
- # Setup the linker in ffmpeg.
- cat "${srcdir}/chromium-ffmpeg-clang.patch" | sed -e "s|__CLANG_PATH__|${_clang_path}|g" -e "s|__LLD__|${_lld}|g" | patch -p1 -i -
- # Disable lto.
- # This avoid messages like:
- # bfd plugin: LLVM gold plugin has failed to create LTO module: Unknown attribute kind (60) (Producer: 'LLVM9.0.0svn' Reader: 'LLVM 8.0.0')
- # when you have installed clang in the system.
- sed 's|--enable-lto|--disable-lto|g' \
- -i third_party/ffmpeg/chromium/scripts/build_ffmpeg.py
+ # add build verbose output
+ sed "s|'make', '-j|'make', 'V=1', '-j|g" -i third_party/ffmpeg/chromium/scripts/build_ffmpeg.py
# Use system opus.
rm -fr third_party/opus/src/include
ln -sf /usr/include/opus/ third_party/opus/src/include
@@ -535,7 +528,20 @@ build() {
msg2 "Build bundled ffmpeg"
pushd third_party/ffmpeg &> /dev/null
- chromium/scripts/build_ffmpeg.py linux x64 --branding ChromeOS
+ # Disable lto.
+ # NOTE: This avoid messages like:
+ # bfd plugin: LLVM gold plugin has failed to create LTO module: Unknown attribute kind (60) (Producer: 'LLVM9.0.0svn' Reader: 'LLVM 8.0.0')
+ # when you have installed clang in the system.
+ # Use bundled clang
+ chromium/scripts/build_ffmpeg.py linux x64 --branding ChromeOS -- \
+ --disable-lto \
+ --cc="${_clang_path}clang" \
+ --cxx="${_clang_path}clang++" \
+ --ld="${_clang_path}clang" \
+ --ar="${_clang_path}llvm-ar" \
+ --extra-ldflags="-fuse-ld=${_clang_path}${_lld}" \
+# --disable-asm
+
chromium/scripts/copy_config.sh
chromium/scripts/generate_gn.py
popd &> /dev/null
diff --git a/chromium-ffmpeg-clang.patch b/chromium-ffmpeg-clang.patch
deleted file mode 100644
index 1a9d15fd0f3d..000000000000
--- a/chromium-ffmpeg-clang.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/third_party/ffmpeg/chromium/scripts/build_ffmpeg.py
-+++ b/third_party/ffmpeg/chromium/scripts/build_ffmpeg.py
-@@ -425,7 +425,7 @@ def BuildFFmpeg(target_os, target_arch, host_os, host_arch, parallel_jobs,
- os.path.join('libavutil', GetDsoName(target_os, 'avutil', 56)),
- ]
- PrintAndCheckCall(
-- ['make', '-j%d' % parallel_jobs] + libraries, cwd=config_dir)
-+ ['make', 'V=1', '-j%d' % parallel_jobs] + libraries, cwd=config_dir)
- for lib in libraries:
- shutil.copy(
- os.path.join(config_dir, lib), os.path.join(config_dir, 'out'))
-@@ -782,9 +782,10 @@ def ConfigureAndBuild(target_arch, target_os, host_os, host_arch, parallel_jobs,
- if 'win' not in target_os:
- configure_flags['Common'].extend([
- '--enable-pic',
-- '--cc=clang',
-- '--cxx=clang++',
-- '--ld=clang',
-+ '--cc=__CLANG_PATH__clang',
-+ '--cxx=__CLANG_PATH__clang++',
-+ '--ld=__CLANG_PATH__clang',
-+ '--ar=__CLANG_PATH__llvm-ar',
- ])
-
- # Clang Linux will use the first 'ld' it finds on the path, which will
-@@ -792,7 +792,7 @@ def ConfigureAndBuild(target_arch, target_os, host_os, host_arch, parallel_jobs,
- # ld.lld, to ensure that things like cross-compilation and LTO work.
- # This does not work for arm64, ia32 and is always used on mac.
- if target_arch not in ['arm64', 'ia32', 'mipsel'] and target_os != 'mac':
-- configure_flags['Common'].append('--extra-ldflags=-fuse-ld=lld')
-+ configure_flags['Common'].append('--extra-ldflags=-fuse-ld=__CLANG_PATH____LLD__')
-
- # Should be run on Mac, unless we're cross-compiling on Linux.
- if target_os == 'mac':