summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-08-26 07:48:11 +0200
committersL1pKn072017-08-26 07:48:16 +0200
commitfa0fce834385c9353e1efdc8782bd911ff341511 (patch)
tree6013c4299da4299f2994657cc48b091983a64baf
parent56fc44e51abf27750d34487486d810a77d6b6206 (diff)
downloadaur-fa0fce834385c9353e1efdc8782bd911ff341511.tar.gz
do'h
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD23
3 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d45377040e0a..7b6c223ed436 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Aug 24 20:18:26 UTC 2017
+# Sat Aug 26 05:47:19 UTC 2017
pkgbase = chromium-dev
pkgdesc = The open-source project behind Google Chrome (Dev Channel)
pkgver = 62.0.3192.0
diff --git a/.gitignore b/.gitignore
index d04f8c970759..9021d728e092 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,3 +7,4 @@
!chromium-widevine-r1.patch
!minizip.patch
!vaapi_patch-r3.patch
+!chromium-blink-gcc7-r1.patch
diff --git a/PKGBUILD b/PKGBUILD
index f53278e27774..04113e3fac26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -68,13 +68,6 @@ optdepends=(
#
'libappindicator-gtk3: Needed for show systray icon in the panel on GTK3 Desktop based'
)
-if [ "${_enable_vaapi}" = "1" ]; then
- optdepends+=('libva-vdpau-driver-chromium: HW video acceleration for NVIDIA users'
- 'libva-mesa-driver: HW video acceleration for Nouveau, R600 and RadeonSI users'
- 'libva-intel-driver: HW video acceleration for Intel users'
- )
- depends+=('libva')
-fi
source=( #"https://gsdview.appspot.com/chromium-browser-official/chromium-${pkgver}.tar.xz"
"https://commondatastorage.googleapis.com/chromium-browser-official/chromium-${pkgver}.tar.xz"
"git+https://github.com/foutrelis/chromium-launcher.git"
@@ -325,11 +318,18 @@ _flags=(
# NOTE : The detector is Experimental, Can kill you kitty/doggy/waifu/husbando
# NOTE 2: vfio-pci is for avoid systems with KVM VGA passtrought enabled
# NOTE 3: Nvidia (bloob drivers) seems have problem with this patch. disable it
+_enable_vaapi=0
_vga_drivers="$(lspci -vk | grep -A10 VGA | grep 'Kernel driver in use' | cut -d ' ' -f5)"
for _driver in ${_vga_drivers}; do
if [ "${_driver}" != "vfio-pci" ] && [ "${_driver}" != "nvidia" ]; then
_enable_vaapi=1
_flags+=('use_vaapi=true')
+ optdepends+=(
+# 'libva-vdpau-driver-chromium: HW video acceleration for NVIDIA users'
+ 'libva-mesa-driver: HW video acceleration for Nouveau, R600 and RadeonSI users'
+ 'libva-intel-driver: HW video acceleration for Intel G45 and HD users'
+ )
+ depends+=('libva')
break
fi
done
@@ -410,18 +410,11 @@ prepare() {
sed 's|base/||' -i cc/output/vulkan_renderer.h
# Apply VAAPI patch
- if [ "${_enable_vaapi}" = 1 ]; then
+ if [ "${_enable_vaapi}" = "1" ]; then
msg2 "Enable VAAPI"
patch -p1 -i "${srcdir}/vaapi_patch-r3.patch" # base64 -d "${srcdir}/vaapi_patch-r3.base64" | patch -p1 -i -
fi
- # Fix paths.
- sed -e 's|i386-linux-gnu/||g' \
- -e 's|x86_64-linux-gnu/||g' \
- -e 's|/usr/lib/va/drivers|/usr/lib/dri|g' \
- -e 's|/usr/lib64/va/drivers|/usr/lib/dri|g' \
- -i content/common/sandbox_linux/bpf_gpu_policy_linux.cc
-
patch -p1 -i "${srcdir}/minizip.patch"
# Patch from crbug (chromium bugtracker).